You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

flash360

Trainee

Posts: 87

Location: All over

Occupation: this

  • Send private message

41

Wednesday, April 1st 2009, 7:59am

Thanks Graydon - works well - as soon as I read it I knew it would. Need to simplify mt thinking!! *tongue*

for other out there -

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
<action name="showgallery">
   	 set(plugin[gallery].freezeview, true);
   	set(plugin[showgallery].enable,false);
	tween(plugin[showgallery].alpha,0,distance(1,0.15),,set(plugin[showgallery].visible,false));
	
	

	set(plugin[hidegallery].enable,true);
	set(plugin[hidegallery].visible,true);
	tween(plugin[hidegallery].alpha,1,distance(1,0.15));
	set(plugin[black].visible,true);
	tween(plugin[black].alpha,0.5,distance(1,0.15));

	set(plugin[gallery].url,simpleviewer.swf?xmlDataPath=gallery/gallery.xml);

	set(plugin[gallery].visible,true);
	tween(plugin[gallery].alpha,1,distance(1,0.15));
	set(plugin[gallery].dropshadow(2,45,0x000000,3,1);
</action>


Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
<action name="closegallery">

		set(plugin[gallery].visible,false);
		
		set(plugin[logo].visible,true);
		tween(plugin[logo].alpha,1,distance(1,0.15));
		
		set(plugin[hidegallery].enable,false);
		tween(plugin[hidegallery].alpha,0,distance(1,0.15),,set(plugin[hidegallery].visible,false));
		
		set(plugin[showgallery].enable,true);
		set(plugin[showgallery].visible,true);
		tween(plugin[showgallery].alpha,1,distance(1,0.15));
		tween(plugin[black].alpha,0,distance(1,0.15),,set(plugin[black].visible,flase));
	
</action>


Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
<plugin name="black"
 	    	url="images/bottom.jpg"
	    	keep="false"
 	    	visible="false" enabled="true" handcursor="false" 			capture="true" children="true"
 	    	zorder="-20"
 	    	alpha="0.30" blendmode="normal"
 	    	smoothing="true"
 	    	origin="centre" edge="centre"
 	    	width="100%" height="100%"
	    	scale="1"
	    	onloaded=""
	    	onover=""
	    	onhover=""
	    	onout=""
	    	ondown=""
	    	onup=""
	    	onclick=""
	    	ox=""
	    	oy=""
	    	rotate="0"
	    	/>

- SZIKRA -

Beginner

Posts: 34

Location: Hungary, Szeged

  • Send private message

42

Friday, July 10th 2009, 11:57am

TiltViewer or Carousels

Hello!

Why dont I make a gallery with te TiltViewer or Carousels like with the simplewiewer?...

This is my source code:


<!-- show and hide gallery buttons (show button is visible, hide button is invisible at start -->
<plugin name="showgallery" url="showgallery.png" align="bottom" y="20" visible="true" onclick="action(showgallery);" />
<plugin name="hidegallery" url="hidegallery.png" align="bottom" y="20" visible="false" onclick="action(hidegallery);" />


<!-- a "empty" and hidden plugin for the simpleviewer -->
<plugin name="gallery" url="" visible="false" />


<!-- action to load and show the simpleviewer gallery -->
<action name="showgallery">
<!-- swap buttons -->
set(plugin[showgallery].visible,false);
set(plugin[hidegallery].visible,true);

<!-- load the simpleviewer -->
set(plugin[gallery].url,TiltViewer.swf?xmlDataPath=gallery.xml);
set(plugin[gallery].visible,true);
</action>

<!-- action to hide the simpleviewer gallery -->
<action name="hidegallery">
<!-- swap buttons -->
set(plugin[showgallery].visible,true);
set(plugin[hidegallery].visible,false);

<!-- hide simpleviewer -->
set(plugin[gallery].visible,false);
</action>

*cry* *question* *question* *question*

43

Monday, July 13th 2009, 9:39am

Hi,

see here for the "Tiltviewer" Usage:

http://www.simpleviewer.net/tiltviewer/x…l_instruct.html

and here:
http://www.simpleviewer.net/tiltviewer/config_options.html

I think the "useFlickr" and "xmlURL" parameters are the important ones,
e.g.

Source code

1
set(plugin[gallery].url,TiltViewer.swf?xmlURL=gallery.xml&useFlickr=false);


and the XML format of the galleray.xml must be also like in the documentation (I'm not sure yet if it's the same format as in simpleviewer)

best regards,
Klaus

- SZIKRA -

Beginner

Posts: 34

Location: Hungary, Szeged

  • Send private message

44

Monday, July 13th 2009, 6:38pm

Thanks Klaus the answer,

but unfortunately it do nothing else.

Hmm... I cant find the solution *sad*

rbackhaus

Trainee

Posts: 66

Location: connecticut usa

  • Send private message

45

Wednesday, January 13th 2010, 8:29pm

simple viewer

Hi guys,.

Wondering on this simple viewer thing.....I followed the examples and think I got it, but as it goes to load, I get a message top left corner stating "embedding in flash requires simplviewer Pro".....is that the case now or am i doing something wrong??? Is there an alternative to use? Thanks

Rob

rbackhaus

Trainee

Posts: 66

Location: connecticut usa

  • Send private message

46

Wednesday, January 13th 2010, 10:44pm

all set,....found my error

booghy08

Beginner

Posts: 35

Location: Romania

Occupation: panos

  • Send private message

47

Sunday, February 7th 2010, 1:01pm

i tested the code Klaus gave us , but there is a problem,when simple viewer loads it says that Upgrade to Pro version
does the exemple did by klaus was made with a PRO version of simple viewer?

48

Monday, February 8th 2010, 9:30pm

Hi,
does the exemple did by klaus was made with a PRO version of simple viewer?
no, I have used the normal (not pro) simpleviewer...

best regards,
Klaus

49

Thursday, February 11th 2010, 11:52pm

Hello from France,

Is it possible to load a scene in KrPano by a carousel or the simpleviewer by clicking on an image.

E.g: I have my tour.xml with all my scene and hotspots, plugins etc... in it, and a carousel or simpleviewer like plugin, and when I click on an image of this, it's like Onclick in krpano on a thumbail.

I know to do that in krpano, but how to do this with a carousel, i don't find where to input a code like: onclick="loadscene(scene1)".

Thanks for your answers! *confused*

Boubou

Trainee

Posts: 67

Location: Paris

Occupation: Photographer

  • Send private message

50

Saturday, February 13th 2010, 3:22pm

I do not understand why my thumbnails are visible and the images not...

Basic code:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
<plugin name="showgallery" url="galerie hordagodata/graphics/galleryb1.png" align="bottom" x="-100" y="10" visible="true"  onclick="action(showgallery);" />
 <plugin name="hidegallery" url="galerie hordagodata/graphics/galleryb2.png" align="bottom" x="-100" y="10" visible="false" onclick="action(hidegallery);" />
 
 <plugin name="gallery" url="" visible="false" align="bottom" keep="true"/> 
 
 <plugin name="fond"
                url="galerie hordagodata/graphics/fond.png"
                keep="false"
                visible="false" enabled="true" handcursor="false"                       
    capture="true" children="true"
                zorder="-20"
                alpha="0.30" blendmode="normal"
                smoothing="true"
                origin="centre" edge="centre"
                width="100%" height="100%"
                scale="1"
                />
 
 <action name="showgallery">
  set(plugin[showgallery].visible,false);
  set(plugin[hidegallery].visible,true);
  set(plugin[gallery].url,simpleviewer.swf?xmlDataPath=gallery.xml);
  set(plugin[gallery].visible,true);
  set(plugin[gallery].align,bottom);
  set(plugin[fond].visible,true);
        tween(plugin[fond].alpha,0.5,distance(1,0.15));
 </action>
 
 <action name="hidegallery">
  set(plugin[showgallery].visible,true);
  set(plugin[hidegallery].visible,false);
  set(plugin[gallery].visible,false);
  set(plugin[fond].visible,false);
  tween(plugin[fond].alpha,0,distance(1,0.15));
 </action> 


code gallery:

<?xml version="1.0" encoding="UTF-8"?>

<simpleviewergallery

title="gallery"
align="bottom"
textColor="FFFFFF"
frameColor="FFFFFF"
thumbPosition="LEFT"
galleryStyle="MODERN"
thumbColumns="3"
thumbRows="4"
showOpenButton="false"
showFullscreenButton="false"
frameWidth="10"
maxImageWidth="600"
maxImageHeight="600"
imagePath="images/"
thumbPath="thumbs/"
useFlickr="false"
flickrUserName=""
flickrTags=""
languageCode=""
languageList=""
>
<image imageURL="images/cheki-01.jpg" thumbURL="thumbs/cheki-01.jpg" linkURL="" linkTarget="" >
<caption>cheki-01.jpg</caption>
</image>
<image imageURL="images/cheki-02.jpg" thumbURL="thumbs/cheki-02.jpg" linkURL="" linkTarget="" >
<caption>cheki-02.jpg</caption>
</image>
<image imageURL="images/cheki-03.jpg" thumbURL="thumbs/cheki-03.jpg" linkURL="" linkTarget="" >
<caption>cheki-03.jpg</caption>

And the basic files:

-galerie hordago data

-swf object

-galerie hordago.html

-galerie hordago.xml

-galerie hordago0.xml

-images

-thumbs

-gallery.xml

-simpleviewer.swf

-galerie hordago.swf

;-)

Boubou

Trainee

Posts: 67

Location: Paris

Occupation: Photographer

  • Send private message

51

Saturday, February 13th 2010, 9:52pm

I think it could be much expressive with a link...

So, have look and tell me what's going wrong ;-)

The 360° panoramic

This post has been edited 1 times, last edit by "Boubou" (Feb 19th 2010, 10:33am)


milotimbol

Intermediate

Posts: 210

Location: Antipolo City, Philippines

Occupation: Software Engineer

  • Send private message

52

Sunday, February 14th 2010, 10:04am

Boubou,

I had the same problem. What I did was I used the older version 1.9. For some reason I could not make the new version of simple viewer work with krpano.

http://www.360philippines.com/businesses/so-fab-shoes/ (click on show gallery)

Im not sure if you can still download the old version for free. What I did was buy the pro version, and included in the download is the 1.9 source code

you can find my xml here

http://www.360philippines.com/panoramas/…ab/panorama.xml

Boubou

Trainee

Posts: 67

Location: Paris

Occupation: Photographer

  • Send private message

53

Monday, February 15th 2010, 3:44pm

Thank you Melotimbol!

I'll try to download Simpleviewer V1.9 ;-)

Boubou

Trainee

Posts: 67

Location: Paris

Occupation: Photographer

  • Send private message

54

Friday, February 19th 2010, 10:31am

No Simplviewer v1.9 aviable *cry*

I ask Simpleviewer for a solutionto this bug...

milotimbol

Intermediate

Posts: 210

Location: Antipolo City, Philippines

Occupation: Software Engineer

  • Send private message

55

Sunday, February 21st 2010, 1:12pm

You have to buy the new version...the 1.9 code is included in the download.

56

Sunday, February 21st 2010, 10:16pm

Or you can visit this link and scroll to the bottom and download v1.9

http://www.simpleviewer.net/simpleviewer…rt/upgrade.html

57

Monday, February 22nd 2010, 10:17pm

tilt viewer

Hi!

Did someone was able to include the tilt viewer gallery?
The simple viewer works fine, but the tilt viewer seems like just closing a second after start.
Here is the example - link.

Thanks, Dmitry.

milotimbol

Intermediate

Posts: 210

Location: Antipolo City, Philippines

Occupation: Software Engineer

  • Send private message

58

Tuesday, February 23rd 2010, 4:16pm

There was a talk about this before and klaus mentioned that you cant use tiltviewer with krpano because of a "stage" thing issue with flash, i cant remember which thread. but.. I did see the tilt viewer open in your example but it disappeared and wont open again.. maybe its a newer version than the one talked about before.

59

Tuesday, February 23rd 2010, 7:29pm

There was a talk about this before and klaus mentioned that you cant use tiltviewer with krpano because of a "stage" thing issue with flash, i cant remember which thread. but.. I did see the tilt viewer open in your example but it disappeared and wont open again.. maybe its a newer version than the one talked about before.


Thanks Milo,
Seems like the "thing" happends somwhere inside the TiltViewer. Yep, the gallery is openingjust one time - the second time the visible attribute is changing without plugin reloading (as I can understand).
Howewer, I've rigistered on the tilt TiltViewer support forum and statred a threadthere. If they will be not able to help me - I'll use the SimpleViewer. Seems like it doesn't have any problems with krpano.

michel

Professional

Posts: 1,153

Location: ANDORRA

Occupation: TV

  • Send private message

60

Saturday, February 27th 2010, 9:08pm

Hi wiskey,

Try this code on your html:

Source code

1
<div id="krpanoDIV"><embed type="application/x-shockwave-flash" src="krpano.swf" style="" id="krpanoSWFObject" name="krpanoSWFObject" quality="high" allowfullscreen="true" allowscriptaccess="always" flashvars="xmlURL=./plugins/gallery.xml,xml=3.xml" width="100%" height="100%"></div>

note the flashvars="xmlURL=./plugins/gallery.xml,xml=3.xml"

Edited:
This link works:
http://perfectumlab.com/galery/panorams/…useFlickr=false
so, try this code on your xml:

Source code

1
set(plugin[gallery].url, ./plugins/tiltviewer.swf?useFlickr=false&xmlURL=gallery.xml);

note: xmlURL seems to be relative to the tiltviewer.swf path... so, xmlURL=./plugins/gallery.xml does not work but xmlURL=../plugins/gallery.xml does.

SAlut.

This post has been edited 3 times, last edit by "michel" (Feb 27th 2010, 10:21pm)