Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 19. Februar 2009, 19:41

Wellen an der Decke

Hallo... in unserem aktuellen Pano 'Fasching' haben wir in einer Turnhalle fotografiert und ein spherisches Pano erstellt ... warum haben wir an der Decke jetzt 'wellige' Leisten ? siehe: http://www.delmenhorst-mittendrin.de/fasching.html

in der xml-datei haben wir eingetragen wie folgt - ist das eventuell ganz falsch ?


<image type="SPHERE" hfov="360">
<sphere url="../pano/fasching_01.jpg" />
</image>
<view fisheye="0" limitview="auto" />


Danke für Hilfe. *confused*

2

Donnerstag, 19. Februar 2009, 21:18

Hi,

das kommt durch das Kugelpanorama,

der 3D Darstellung der "Kugel" wird sich durch "Dreiecke" nur "angenähert",
in der Beta Version sieht man diese Dreiecke durch Drücken der TAB Taste,

die Darstellung wird genauer durch "mehr" Dreiecke, das geht
mit der "details" Einstellung (Default=16), im XML z.B.:
<display details="24" />

ODER:

durch Verwendung eines Würfelpanorama,
dann gibt es (vor allem auch mit Flash10) diese Problem nicht mehr,

das Kugelpanorama kann man sehr einfach mit dem "SPHERE to CUBE" (mac) oder "kshpere_to_cube.bat"
Droplet umrechnen, einfach das Kugelpanorama Bild darauf ziehen, und das Programm rechnet
das Panorama um,

Schöne Grüße,
Klaus

3

Donnerstag, 19. Februar 2009, 22:47

frage

also die <display>-einstellung klappt schon mal wunder bar und die bild-darstellung ist sehr viel besser


jetzt habe ich dann ein 1,2 mb grosses pano auf die bat-datei gezogen und die hat mir 6 cubes mit insgesamt 27 mb im format .tif zurück gerechnet .... hmmm ... da habe ich doch wohl die einstellungen ( wo mache ich das ) noch nicht richtig, oder ?

oder muss ich die tif-daten in jpgs zurück verwandeln ?

auch habe ich das xml-Beispiel abgeschaut, bekomme im Player aber die sechsfache Fehlermeldung 'download of 'null' failed....

<view hlookat="-9.494365" vlookat="-10.999712" fov="99" fovmin="30" fovmax="170" limitfov="true" fisheye="0.33" fisheyefovlink="1.00" />

<image type="CUBE" tilesize="512">
<level tiledimagewidth="1024" tiledimageheight="1024" details="16">
<left url="../pano/fasching_01_l.jpg" />
<front url="../pano/fasching_01_f.jpg" />
<right url="../pano/fasching_01_r.jpg" />
<back url="../pano/fasching_01_b.jpg" />
<up url="../pano/fasching_01_u.jpg" />
<down url="../pano/fasching_01_d.jpg" />
</level>

</image>

jetzt wird's schwer für so einen Nicht-Versteher wie ich einer bin ... *blink*

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »mthrills« (19. Februar 2009, 23:16)


4

Freitag, 20. Februar 2009, 13:21

Hi,

ja, mit dem ksphere_to_cube.bat Droplet werden standardmäßig TIFF Dateien erstellt,
TIFF deshalb um noch ein Bearbeiten zu ermöglichen (z.B. Nadir bearbeiten, Nachschärfen, JPEG-Qualität anpassen, ...)

die TIFF's direkt ins Flash zu laden ist auch gar nicht möglich

es wäre aber auch möglich gleich JPEGs zu erstellen,
dazu die "ksphere_to_cube.bat" Datei mit einem Texteditor öffnen und diese Zeile:

Quellcode

1
 %~dp0\ktransform cube6 %1 %~dpn1.tif

mit dieser ersetzen:

Quellcode

1
%~dp0\ktransform cube6 %1 %~dpn1.jpg -jpegoptimize -jpegquality=85
(wobei bei -jpegquality= noch die JPEG Qualität angegeben werden kann, 100=beste Qualität, 0=schlechteste)

der <image> Knoten im XML sollte so richtig sein: (eventuell die Pfade überprüfen)

Quellcode

1
2
3
4
5
6
7
8
<image type="CUBE">
    <left  url="../pano/fasching_01_l.jpg" /> 
    <front url="../pano/fasching_01_f.jpg" /> 
    <right url="../pano/fasching_01_r.jpg" /> 
    <back  url="../pano/fasching_01_b.jpg" /> 
    <up    url="../pano/fasching_01_u.jpg" /> 
    <down  url="../pano/fasching_01_d.jpg" /> 
</image>


Schöne Grüße,
Klaus

5

Sonntag, 22. Februar 2009, 00:42

Sauber

Danke, Klaus...... funktioniert alles sauberst.