You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Friday, January 28th 2011, 12:52pm

krpano in Typo3 einbinden über Flash-embed Funktion klappt nicht! decoding failed

Hallo zusammen,

Für einen Kunden habe ich ein Kugelpanorama zusammengestellt, welches auf dessen Webseite angezeigt werden soll. Das ist nicht das erst mal, dass diese Kunde Material bekommt und auf der Seite einbindet aber diesmal will es einfach nicht klappen.

Ich habe mit der aktuellste Version von krprotect die xml, die swf und die Buttons der Navigationsleiste in eine swf-Datei verschmolzen. Die Bilder der Würfelflächen liegen extra in der gleichen logischen Ebene wie die swf-Datei.

Ruft man diese swf durch Eingabe der direkten Adresse im Browser auf wird alles angezeigt (zum Testen habe ich die Thumbs, die die unterschiedlichen Szenen anfahren deaktiviert und lasse nur die erste Szene laden)
Hier der Link zur swf

Der Kunde benutzt als CMS Typo3. Jetzt soll das Pano auf einer html-Seite dargestellt werden. Dafür hat er die swf mittel "embed" eingebunden:

Source code

1
2
3
4
5
6
7
8
9
10
<div id="spalte1" style="width: 49%; float:left">
	<!--  CONTENT ELEMENT, uid:5015/html [begin] -->
		<div id="c5015" class="csc-default">

		<!--  Raw HTML content: [begin] -->
			<embed width="250px" height="178px" allowscriptaccess="always" allowfullscreen="true" quality="high" bgcolor="#000000" name="krpanoSWFObject" id="krpanoSWFObject" style="" src="http://www.neumarkt.de/fileadmin/neumarkt.de/mitarbeiter/Bilder/Kultur/Veranstaltungsraeume/kleinejurahalle/Jurahalle_klein.swf" type="application/x-shockwave-flash">
		<!--  Raw HTML content: [end] -->
			</div>
	<!--  CONTENT ELEMENT, uid:5015/html [end] -->
		</div>


Wird jetzt die Seite geladen dann bringt krpano die Fehlermeldung: decoding failed - links_preview.jpg
Dies ist das Preview-Bild der erste Szene, die geladen wird.
Die xml habe ich in den Anhang gepackt!


Wie kann das sein dass das Pano beim direkten Aufruf läuft, alle Bilder gefunden oder decodiert werden, sobald man die Flash-Datei einbettet geht nix mehr?
Die vorangegangenen Panoramen haben wir durch die gleiche Art und Weise eingebettet. Der einzige Unterschied ist jetzt, dass ich eine aktuellere Version von krpano und den Tools verwende als damals.


Bin total verzweifelt. Liegt es an krpano? Liegt es an Typo3? *question*
Hoffentlich kann mir jemand helfen.......

Wünsche ein angenehmes Wochenende.

Gruß
Matthias
Matze has attached the following file:

2

Tuesday, February 1st 2011, 2:03pm

Hi,

wie lauten im kprotect Tool die Pfade der Dateien in der Liste der eingebunden Dateien?

Schöne Grüße,
Klaus

3

Tuesday, February 1st 2011, 8:24pm

Hallo Klaus,

es liegt nicht an krprotect.
Ich habe jetzt eine Version gemacht mit der Original swf Datei, der xml, der license Datei und mit allen notwendigen Würfelflächen auf einer einzigen logischen Ebene, also keine Unterordner. Dazu hab ich eine html-Datei erstellt.
Zuerst haben wir die swf-Datei wieder über den embed-Befehl eingebunden, aber es kam wieder der gleiche Fehler: decoding failed - links_preview.jpg

Dann haben wir die html-Datei über einen iFrame eingebunden. Das hat auch nicht funktioniert. Die html-Datei im Browser direkt aufgerufen geht, per iFrame aus einer anderen html-Datei geht nicht.

Jetzt haben wir es so gelöst, dass beim Klick auf ein Vorschaubild ein neues Browserfenster aufgeht, wo das Panorama als Vollbild erscheint. Aber das ist ja nicht das gelbe vom Ei.

Gibt es einen Link wo man alte Versionen von krpano und den tools runterladen kann, denn ich habe jetzt nur noch die Erklärung, dass die alten Panos deshalb funktionieren weil sie mit einer älteren Version erstellt wurden.


Gruß
Matthias