You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Friday, December 2nd 2011, 4:46am

ERROR: iPhone / iPad Version not available!

I've made a few panos and tours with the new 1.0.8.14 version, and everything seems to work much better on iPhones and iPads now. However, I came across this error message that says "ERROR: iPhone / iPad Version not available!" a lot of times on virtual tours and panos with more complex stuff like text boxes. I have not yet found a way to get rid of these errors, the simpler panos without hotspots just work, even with plugin images and other stuff, but the virtual tour panos just don't seem to work anymore on iDevices. Is there a general solution for this problem, like a fixed thing that causes this error, or is the matter more complicated? Maybe someone here on the forum with lots of experience with iPad support can help me out here. Any help on this matter is greatly appreciated!

EDIT: I just went all the way and took a "working" iPad pano and then, step by step, copied over all the code from the XML of the non-working pano, and then it suddenly worked. I really don't know what I did wrong now, but at least I seem to have found a way to fix these problems.

EDIT EDIT: No, it doesn't work. It worked offline with the iPad simulator tool provided with the krpano package, but it does not work online on our server with a real iPad/iPhone or the simulator... Stumped again.

This post has been edited 2 times, last edit by "Usabell" (Dec 2nd 2011, 5:22am)


2

Friday, December 2nd 2011, 5:29am

Do you have a working and non working example? Are you using the same .js file for both?

3

Friday, December 2nd 2011, 5:35am

I have a working example here (just got it to work by replacing the .js file):

http://blende12.ch/360speisesaal/tour.html

and a non-working example with the exact same .js file here:

http://blende12.ch/team/team.html

This one works offline in the simulator, though. It doesn't work online with the simulator or real iPhone. I know that some effects and stuff don't work on iOS, but it shouldn't just give that error and at least try its best, like offline on the simulator.
I'd be really thankful for any clues on what might cause this.

4

Friday, December 2nd 2011, 5:41am

Both work on my iPhone iOS 5.0.1. Did you previously view that tour on your iPhone before uploading the new .js? I have noticed the iPhone caches the files for a while.

Try browsing to the path to your js with safari and then revisit the tour. I believe that will force the loading of the new .js.


Jarred

5

Friday, December 2nd 2011, 5:45am

Yay, I tried that and reloading the website and now it works here, too. So it's just the JS files I need to replace, great!

Thanks a lot, you really helped me out here!

6

Friday, December 2nd 2011, 5:45am

*thumbup*

Similar threads