You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, January 18th 2012, 1:27pm

Selbe xml-Datei für PC und iPhone/Pad?

Hallo,
ich habe am iPhone-iPad-Simulator feststellen müssen, dass die xml-Datei für PC-Ansicht (mit plugins, Button, googlemap usw.) sich nicht im Safari-Browser bzw. im i-Phone-Layout einlesen lässt.
"FATAL ERROR: ......_001.xml - loading or parsing failed!"
Es liegt defenitiv mit den zusätzlichen Inhalten für die Plugins zusammen. Ich gehe eigentlich davon schwer aus, dass Apple wie Windows/Androide auf die selbe xml-Datei zugreifen. Oder brauche ich da noch extra eine html5-file *question* Keine Ahnung bin noch relativ Einsteiger *smile*
Sollte es so hoffentlich sein, wo und wie sollte es verändert werden?
Ich habe mal für die PC-Version den Code unten stehen:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
<krpano version="1.0.8" logkey="false">
<!-- plugins einbinden -->
<!--plugin name="editor" url="plugins/editor.swf" keep="true" />
<plugin name="options" url="plugins/options.swf" keep="true" />
<!-- mittenmarke -->
<!--plugin name="marker" url="plugins/target.png" align="center" 
x="0"
y="18"
alpha= "0.5"/>
<!-- include für tooltip_rot -->
<include url="plugins/text_rot.xml" keep="true" />
<!-- include für tooltip -->
<include url="plugins/text.xml" keep="true" />
<!-- include für map und actions -->
<include url="plugins/googlemap.xml" keep="true" />


	<include url="skin/defaultskin.xml" />
	
	<view hlookat="0" vlookat="0" maxpixelzoom="1.0" limitview="auto" />

	<preview url="Weingarten/Muensterplatz_001.tiles/preview.jpg" />

	<image type="CUBE" multires="true" tilesize="758" prealign="0|195.39|0">
		<level tiledimagewidth="2653" tiledimageheight="2653">
			<cube url="Weingarten/Muensterplatz_001.tiles/l2_%s_%0v_%0h.jpg" />
		</level>
		<level tiledimagewidth="1327" tiledimageheight="1327">
			<cube url="Weingarten/Muensterplatz_001.tiles/l1_%s_%0v_%0h.jpg" />
		</level>
		<mobile>
			<cube url="Weingarten/Muensterplatz_001.tiles/mobile_%s.jpg" />
		</mobile>
		<tablet>
			<cube url="Weingarten/Muensterplatz_001.tiles/tablet_%s.jpg" />
		</tablet>
	</image>
	/> 
<hotspot name="Kirchplatz, Treppenabgang"
ath="0.68" 
atv="-10.40"
url="plugins/hotspot.png"
alpha="1.0"
edge="top"
onhover="set(alpha,0.5);showtext(Kirchplatz - Eingang Basilika,tooltip);"
onout="set(alpha,1.0);"
onclick="loadpano(Kirchplatz_Eingang_Basilika.xml,null,MERGE,BLEND(2));"
/>
<hotspot name="Kleine Münsterplatz"
ath="54.21" 
atv="4.84"
url="plugins/hotspot.png"
alpha="1.0"
edge="top"
onhover="set(alpha,0.5);showtext(Kleine Münsterplatz,tooltip_rot);"
onout="set(alpha,1.0);"
onclick="loadpano(Kleine_Muensterplatz.xml,null,MERGE,BLEND(2));"
/>
<hotspot name="Postplatz"
ath="-54.17" 
atv="0.98"
url="plugins/hotspot.png"
alpha="1.0"
edge="top"
onhover="set(alpha,0.5);showtext(Postplatz,tooltip_rot);"
onout="set(alpha,1.0);"
onclick="loadpano(Postplatz.xml,null,MERGE,BLEND(2));"
/>
<hotspot name="Kirchstraße, Ecke Schützenstraße"
ath="187.91" 
atv="1.40"
url="plugins/hotspot.png"
alpha="1.0"
edge="top"
onhover="set(alpha,0.5);showtext(Kirchstraße - Ecke Schützenstraße,tooltip_rot);"
onout="set(alpha,1.0);"
onclick="loadpano(Kirchstrasse_Ecke_Schuetzenstraße.xml,null,MERGE,BLEND(2));"


/>


</krpano>


Wäre mir eine große Hilfe, wenn es eine einfache Lösung gäbe. Danke im Voraus und Gruß, Thomas

2

Wednesday, January 18th 2012, 4:38pm

Die Aufrufe einiger Deiner Plugins (Zeile 3 und 6) sind falsch, z.B.:

Source code

1
<!--plugin name=

Das sollte so heißen:

Source code

1
<plugin name=

Das Auskommentieren sollte besser so geschehen:

Source code

1
<!-- <plugin name="editor" url="plugins/editor.swf" keep="true" /> -->


Gruß
Karsten

3

Friday, January 20th 2012, 11:20am

Plugins deaktiviert

Hallo Karsten,
das sind Plugins für Editor, Option und der Marker, wo zentrisch im Sreen platziert ist für Hotspots-Ausrichtungen. Die drei Plugins waren da gerade im deaktiviertem Zustand. Ich habe die drei mal entfernt und es ging. Aber nur beweglich sichtbar, changepano funktioniert nicht im Safari, bzw. Simulator.
Das Plugin für GoogleMap mag er auch nicht. Ist das normal? Unterstützen iPhones keine GoogleMap-Karten?
Gruß, Thomas

4

Friday, January 20th 2012, 1:40pm

RE: Plugins deaktiviert

Das Plugin für GoogleMap mag er auch nicht. Ist das normal? Unterstützen iPhones keine GoogleMap-Karten?

Ja genau, dass iPhone kann die Google Map nicht anzeigen.

Grüße
Noob

5

Wednesday, January 25th 2012, 5:51pm

Hi,

das Google Maps Plugin gibt es momentan nur für Flash (swf=Flash, js=Javascript/HTML5),

hier eine Auflistung aller Plugins - bei manchen gibt es mittlerweile auch eine HTML5 Version (.js), allerdings noch nicht bei allem:
http://krpano.com/plugins/

Schöne Grüße,
Klaus