Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

BriarB

Anfänger

  • »BriarB« ist der Autor dieses Themas

Beiträge: 23

Wohnort: New Zealand

Beruf: Professional Photographer

  • Nachricht senden

1

Freitag, 22. Mai 2009, 06:41

installing radar plugin

Another beginner request. Can someone give me some clues on putting the radar control into a virtual tour? I have the radar.swf, and have read what I can, the skeller.xml seams to point to something else (settings.xml) so a basic help would be great.

Tuur

Erleuchteter

Beiträge: 2 775

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

2

Freitag, 22. Mai 2009, 15:34

Yo,


put this in the main xml.. or something similar.. the radar setting are the heading .. the x-y are the place of the spots and the heart of the radar (most of the time u like the radar on the spot!!);-)



Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
<plugin name="map" url="......./map.png" align="righttop" x="10" y="10" 
			keep="true"
			
	        scalechildren=""
			scale="0.7"
	        destscale="0.7"
	        onclick="action(closemap);"
			/>

	<!-- radar -->
	<plugin name="radar" url="....../plugins/radar.swf" zorder="5" origin="righttop" edge="center" keep="true"  x="293" y="87" width="80" height="80" />

	
			
			
			
	<plugin name="spot1" url="......./buttons/mappoint.png" zorder="10" origin="righttop" edge="center" keep="true"  x="193" y="287" onhover="showtext(I LOVE KRPANO);"         onclick="action(load1);" />
    
   <plugin name="spot2" url="....../buttons/mappoint.png" zorder="10" origin="righttop" edge="center" keep="true"  x="192" y="226" onhover="showtext(I REALLY LOVE KRPANO);"         onclick="action(load2);" />
   
</plugin>



 <action name="load1">
    	set(plugin[spotx].x,193);
    	set(plugin[spotx].y,287);
    	set(plugin[radar].x,193);
    	set(plugin[radar].y,287);
    	 loadpano(1.xml,null,MERGE,BLEND(1));
    	set(plugin[radar].heading,12);
    </action>
   
    
    <action name="load2">
    	set(plugin[spotx].x,192);
    	set(plugin[spotx].y,226);
    	set(plugin[radar].x,192);
    	set(plugin[radar].y,226);
    	loadpano(2.xml,null,MERGE,BLEND(1));
    	set(plugin[radar].heading,270);
    </action>



<action name="showspots">
	set(plugin[spot1].visible,true);
	set(plugin[spot2].visible,true);
		
	tween(plugin[spot1].alpha,1);
	tween(plugin[spot2].alpha,1);
	    </action>
    
    <action name="hidespots">
    	set(plugin[spot1].visible,false);
    	set(plugin[spot2].visible,false);
    	    </action>


succes

Cheers
Tuur
http://www.virtualtuur.com
Skype:studiotuur

3

Freitag, 22. Mai 2009, 23:04

and watch the examples from your krpano download ;-)

BriarB

Anfänger

  • »BriarB« ist der Autor dieses Themas

Beiträge: 23

Wohnort: New Zealand

Beruf: Professional Photographer

  • Nachricht senden

4

Freitag, 22. Mai 2009, 23:11

Thanks Tuur. you're the Master to me!!

Line 1 I changed map.png to my own .jpg which comes up fine.

Line 17 buttons/mappoint.png....?should I have this in my example/buttons folder? (I don't)

So at the moment when I just have pluginname="map" that works.

When I add plugin name "radar" I get xml parser error #2070

Graydon

Profi

Beiträge: 614

Wohnort: Texas

Beruf: Industrial gas turbine services.

  • Nachricht senden

5

Samstag, 23. Mai 2009, 07:44

Thanks Tuur. you're the Master to me!!
Way to go Tuur! *smile*

here's something on the 2070 error... XML parser error Error=#2070

Tuur

Erleuchteter

Beiträge: 2 775

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

6

Sonntag, 24. Mai 2009, 12:08

Yo,

so make a map point in photoshop or so and "Line 17 buttons/mappoint.png....?should I have this in my example/buttons folder? (I don't)
" put it in the right place.

Tuur
http://www.virtualtuur.com
Skype:studiotuur

Tuur

Erleuchteter

Beiträge: 2 775

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

7

Sonntag, 24. Mai 2009, 19:54

Zitat


you're the Master to me!!
Way to go Tuur!


*g*

finaly
http://www.virtualtuur.com
Skype:studiotuur

BriarB

Anfänger

  • »BriarB« ist der Autor dieses Themas

Beiträge: 23

Wohnort: New Zealand

Beruf: Professional Photographer

  • Nachricht senden

8

Sonntag, 24. Mai 2009, 23:26

Thanks to Tuur for the off-line help, most appreciated.

I now have the radars working, and yes I made a mappoint.png in Photoshop which works fine. I will update this on my site soon.

I have one thing left...the panos will not load from the spot:


<action name="load1">
set(plugin[spotx].x,140);
set(plugin[spotx].y,110);
set(plugin[radar].x,140);
set(plugin[radar].y,110);
loadpano(main.mov,null,MERGE,BLEND(1));
set(plugin[radar].heading,180);
</action>]



I have this four times for the four .mov files, but when you click the spot it just goes black. I can only think that I have to address the .mov file in some different way.[code]

Also, for Tuur, what is the meaning of the "show spot" action in your coding? It does not seem to do anything, in fact I can delete it without (apparent) effect.
»BriarB« hat folgende Datei angehängt:
  • crusoe.xml (7,68 kB - 57 mal heruntergeladen - zuletzt: 13. März 2016, 19:44)

BriarB

Anfänger

  • »BriarB« ist der Autor dieses Themas

Beiträge: 23

Wohnort: New Zealand

Beruf: Professional Photographer

  • Nachricht senden

9

Montag, 25. Mai 2009, 00:32

Using loadscene(Main Cabin, null,MERGE,BLEND(1)); rather than load pano works.

http://www.assetimaging.co.nz/krpano/exa…nes/crusoe.html

comment?

Tuur

Erleuchteter

Beiträge: 2 775

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

10

Montag, 25. Mai 2009, 00:47

Hi BriarB,

when you make the map close or open you maybe want the spots not to be visible... i have a button for the map in the control panel and let the map disapear.. when you open it opens and then the spots tween in.. *love*

Good luck

Tuur *thumbsup*

Looks good the boat... gonna do ships soon.. *thumbup*
http://www.virtualtuur.com
Skype:studiotuur

Shanti

Fortgeschrittener

Beiträge: 301

Wohnort: Puerto Vallarta

Beruf: Web Developer

  • Nachricht senden

11

Montag, 25. Mai 2009, 08:31

when you click on the scenes buttons (on the bottom) it does not change the spot on the map :)

BriarB

Anfänger

  • »BriarB« ist der Autor dieses Themas

Beiträge: 23

Wohnort: New Zealand

Beruf: Professional Photographer

  • Nachricht senden

12

Montag, 25. Mai 2009, 10:24

Tuur and Shanti. Thanks for your comments. I still don't understand half of what I have achieved so far...a case of "try this, try that" but it has been fascinating learning from you guys.
I actually can remove the buttons now and have everything driven from the map, that gets round the fact that buttons and map are not connected.
When I do that I get no titles of the panos showing, that is another exercise.
My brain is in overload so I am going to have to go out and do what I really like...taking images. So the next tour will be with better panos, and maybe develop the map more.
I still can't work out the: set(plugin[spotx].x,140); coding, just cant see what it is supposed to do.
Thanks again, I'll be back soon!! *smile*

Shanti

Fortgeschrittener

Beiträge: 301

Wohnort: Puerto Vallarta

Beruf: Web Developer

  • Nachricht senden

13

Montag, 25. Mai 2009, 10:34

BriarB: to be fair, I didn't really checked thew complete source, but I think you did a GREAT job on this map.
Joining the buttons with the map should not be to hard to do, I will peak through your code and see if I can find any reason as to why is not working :)

14

Freitag, 10. Juli 2009, 17:11

Hi everybody,

As an absolute beginner I tried to modify crusoe.xml file to my needs, but radar doesn't work for me.
You can see it here: www.3dpanoramy.sk/kuriska/pokus.html
The red hotspots work fine, but no sign of a radar at all.
Can anybody tell me what is wrong?

Thanks.

Juraj

15

Montag, 13. Juli 2009, 10:12

Hi,

the code is correct, but the radar.swf is too old (from version 1.0.7),
see here:
http://www.3dpanoramy.sk/kuriska/radar.swf

the old radar plugin doesn't work with the "parent" setting,
you need to use the one from the 1.0.8 beta

best regards,
Klaus

16

Dienstag, 14. Juli 2009, 17:06

Klaus,

Thanks for your help, my radar works now OK.

Juraj

17

Donnerstag, 17. Februar 2011, 08:46

The Parser error is caused by...

Yo,


put this in the main xml.. or something similar.. the radar setting are the heading .. the x-y are the place of the spots and the heart of the radar (most of the time u like the radar on the spot!!);-)



Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
<plugin name="map" url="/map.png" align="righttop" x="10" y="10" 
			keep="true"
			 scalechildren=""
			scale="0.7"
	                destscale="0.7"
	                onclick="action(closemap);"
			/>

	<!-- radar -->
	<plugin name="radar" url="/plugins/radar.swf" zorder="5" origin="righttop"
          edge="center" keep="true"  x="293" y="87" width="80" height="80" 
         />
	<plugin name="spot1" url="/buttons/mappoint.png" zorder="10" origin="righttop" 
          edge="center" keep="true"  x="193" y="287" onhover="showtext(I LOVE KRPANO);" onclick="action(load1);" 
        />
        <plugin name="spot2" url="/buttons/mappoint.png" zorder="10" origin="righttop" 
          edge="center" keep="true"  x="192" y="226" onhover="showtext(I REALLY LOVE KRPANO);" onclick="action(load2);" 
        />

 <action name="load1">
    	set(plugin[spotx].x,193);
    	set(plugin[spotx].y,287);
    	set(plugin[radar].x,193);
    	set(plugin[radar].y,287);
    	 loadpano(1.xml,null,MERGE,BLEND(1));
    	set(plugin[radar].heading,12);
 </action>
    
    <action name="load2">
    	set(plugin[spotx].x,192);
    	set(plugin[spotx].y,226);
    	set(plugin[radar].x,192);
    	set(plugin[radar].y,226);
    	loadpano(2.xml,null,MERGE,BLEND(1));
    	set(plugin[radar].heading,270);
    </action>



<action name="showspots">
	set(plugin[spot1].visible,true);
	set(plugin[spot2].visible,true);
		
	tween(plugin[spot1].alpha,1);
	tween(plugin[spot2].alpha,1);
 </action>
    
<action name="hidespots">
    	set(plugin[spot1].visible,false);
    	set(plugin[spot2].visible,false);
</action>


succes

Cheers
Tuur
Hey Thanks Tuur for this great starting point... just a note though for those of us trying a copy and paste, adding the necessary components, then getting a parser error 2070...
the code includes a "plugin" closing tag on line 21 that is not needed. I cleaned it up ... as above. Works now.

Don't forget to check your URL/Folder locations and add the necessary mappoints and map graphics to your appropriate folder as well.
Cheers!

AndreaLorena

Anfänger

Beiträge: 4

Wohnort: Santiago, Chile

Beruf: Graphic Designer

  • Nachricht senden

18

Montag, 14. Januar 2013, 13:52

when you click on the scenes buttons (on the bottom) it does not change the spot on the map :)
This^
How can I fix it? *sad*

Ähnliche Themen