Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 5. September 2009, 12:30

Startbild ausblenden geht nicht korrekt

Hallo,
ich baue gerade eine virtuelle Tour aus 4 Panoramen. Beim ersten aufrufen soll ein "startbild.jpg" eingeblendet werden, und das soll nach ein paar Sekunden ausgeblendet werden, und dann nie wieder erscheinen.
Doch beim Wechsel zwischen den Panoramen kommt das Startbild erneut, was nicht so sein soll.

Im folgenden die Code-Teile:

In der XML des ersten Panoramas:

<krpano version="1.0.6" onstart="tween(plugin[startbild].alpha,0,5,easeInExpo,set(plugin[startbild].visible,false));">

Diese ruft weiterhin eine plugins.xml auf. In dieser ist u.a. folgender Code:


<action name="fadein">
set(plugin[startbild].visible,true);
tween(plugin[startbild].alpha,1,0.5);
</action>

<action name="fadeout">
tween(plugin[startbild].alpha,0,0.5,easeoutquad,set(plugin[startbild].visible,false));
</action>
<plugin name="startbild" url="startbild2.png" origin="center" zorder="200"
onclick="timerset(0.3,0,plugin[startbild].alpha,1,0,linear,,false, set(plugin[startbild].visible,false); "
/>


Was muss ich ändern, damit das Startbild nicht mehr bei jedem Panorama-Wechsel neu eingeblendet wird?

2

Dienstag, 8. September 2009, 11:11

Hi,

verwendest du noch die Version 1.0.6?
ich würde zuerst empfehlen die 1.0.7 oder 1.0.8 beta zu verwenden?

wie sieht der gesamte Code aus?

wird die plugins.xml in jedem Panorama eingebunden?
(wird das Bild z.B. in der plugins.xml definiert und diese jedesmal neu geladen, und beim Laden des neuen Panoramas kein KEEPALL angegeben dann erscheint das Bild jedes mal wieder)

wie werden die anderen Panoramen geladen?
(welche Parameter beim loadpano() Aufruf)

Schöne Grüße,
Klaus