Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

21

Mittwoch, 26. Oktober 2016, 14:12

I have problem with onvideocomplete: actually, nothing happend !

Quellcode

1
2
3
4
5
6
7
<plugin name="video"
            	url.html5="%SWFPATH%/plugins/videoplayer.js"
            	url.flash="%SWFPATH%/plugins/videoplayer.swf"
            	pausedonstart="true" loop="false" volume="1.0" buffertime="1.0" playbackrate="1.0"
            	onloaded="add_video_sources();set(layer[skin_btn_vr].enabled,true);tween(layer[skin_btn_vr].alpha, 1.0);"
            	onvideocomplete="trace('end');loadscene(nextscene);"
    	/>


What am I missing ? *cry*

22

Mittwoch, 26. Oktober 2016, 17:35

Illegal instruction: 4

I have downloaded the latest krPano 1.19-pr8 and installe it. I drag-and-drop two pictures onto the applet and I receive from the Terminal this message: Illegal instruction: 4
My last krPano 1.18.5 is still working well.
I trying to install my license to 1.19, nothing happen.
I'm affraid to trash the 1.18 if the newer doesn't work.
What is wrong ? I didn't find this message in searching the forum.


Jacques

23

Freitag, 28. Oktober 2016, 10:04

Suggestion :

OK for the testing server, but it would be interesting to open also the "tour-editor.html" file

24

Dienstag, 1. November 2016, 12:46

Hi,
and I receive from the Terminal this message: Illegal instruction: 4
Sorry, no idea at the moment... the latest krpano Mac versions was changed for OSX Sierra support, but should basically work back to OSX 10.9 (at least in my tests they do).

So this is either this a OSX or CPU compatibility problem or a Gatekeeper/code-signing problem...

Therefore:
What OSX version?
What CPU do you have?
Everything else default or is something custom?


OK for the testing server, but it would be interesting to open also the "tour-editor.html" file
What do you mean?

Best regards,
Klaus

25

Mittwoch, 2. November 2016, 08:30

<skin_settings
webvr="false"

doesn't disable the button in the menu

26

Mittwoch, 2. November 2016, 11:51

webvr="false"

doesn't disable the button in the menu
That's not possible - when the skin_settings.webvr setting is disabled, then the webvr plugin will not be loaded and then there will be no webvr onavailable event or webvr.isavailable state and so also no vr button be added...

27

Mittwoch, 2. November 2016, 16:00

Hello,
I apologise if this is a repeated question, but i could not find an answer to my specific problem:

I'm running 1.19-pr8, making a presentation for cardboardVR. I have 5 hotspots, in each a short inline video. I would like to have these videos play when using the crosshair cursor (during VR viewing), only they start playing after the screen is touched (both on android/ios) and not when the crosshair overlaps with the video. Is there a workaround for this? I read something about this being a limitation on IOS, but this means it should work on android already, but it doesn't.

28

Mittwoch, 2. November 2016, 16:10

We have updated to the latest release. WE can now play the pano video on iphone ios 10. However, for some reason once the user touches the screen, the native player is shown until the user hits done, the krpano video is playing again in 360 mode and functioning as expected.

Do you know a reason why the native player shows on first touch only?
I have the same inside a wrapped Titanium app. Everything opens fine and the video starts playing without a touch. As soon as I hit the VR button in the skin it will open the videos in a native overlay and when I click "done" it stays away. The videos will play inline when I switch rooms. Just the first click on the VR button seems to open all videos in the fullscreen overlay

29

Samstag, 5. November 2016, 02:03

Hello Klaus!

We recently wanted to update to PR8 (from PR3) but we found a problem with it. We have some hotspots that are rendered using canvas elements, and for some reason these do not show up visually. The hotspots seem to be there because their onover actions for example do work, but the graphics are not visible. The same code works in the PR3 version though. Any idea what might cause this, and if there's a workaround?

Cheers!

30

Freitag, 11. November 2016, 09:29

Hi,
I'm running 1.19-pr8, making a presentation for cardboardVR. I have 5 hotspots, in each a short inline video. I would like to have these videos play when using the crosshair cursor (during VR viewing), only they start playing after the screen is touched (both on android/ios) and not when the crosshair overlaps with the video. Is there a workaround for this?
Each video-instance would require a user-interaction like a touch to be able to start playing. That's a core non-krpano-related mobile limitation.

A workaround would be using only ONE videoplayer for all these hotspots and changing only the videourl via the playvideo() action. In this case only one initial touch would be required - e.g. the first touch via the onmousedown event could be used to start playing a video and directly after starting pause it, later play or video-change calls are possible without additional touch.

See included webvr example for something similar - there the videopano will be handled that way.

I have the same inside a wrapped Titanium app. Everything opens fine and the video starts playing without a touch. As soon as I hit the VR button in the skin it will open the videos in a native overlay and when I click "done" it stays away. The videos will play inline when I switch rooms. Just the first click on the VR button seems to open all videos in the fullscreen overlay
Make sure that the krpano viewer and the videoplayer plugin are up-to-date. Then the native iPhone videoplayer shouldn't be used.


We recently wanted to update to PR8 (from PR3) but we found a problem with it. We have some hotspots that are rendered using canvas elements, and for some reason these do not show up visually. The hotspots seem to be there because their onover actions for example do work, but the graphics are not visible. The same code works in the PR3 version though. Any idea what might cause this, and if there's a workaround?
Use renderer="css3d" for the <hotspot>.

Best regards,
Klaus

31

Freitag, 11. November 2016, 17:34

Use renderer="css3d" for the .

Many thanks, it works now. Outside VR mode only, of course. In the final version will hotspots like this (rendered with code) work inside VR mode too?

32

Mittwoch, 16. November 2016, 08:47

I have the same inside a wrapped Titanium app. Everything opens fine and the video starts playing without a touch. As soon as I hit the VR button in the skin it will open the videos in a native overlay and when I click "done" it stays away. The videos will play inline when I switch rooms. Just the first click on the VR button seems to open all videos in the fullscreen overlay
Make sure that the krpano viewer and the videoplayer plugin are up-to-date. Then the native iPhone videoplayer shouldn't be used.


All versions are: krpano 1.19-pr8 (videoplayer, webvr, krpano.js).I'll try to check it again.

surfermedina

Anfänger

Beiträge: 3

Wohnort: Boston

Beruf: Media consulting and video production

  • Nachricht senden

33

Donnerstag, 17. November 2016, 00:11

Videos won't stop playing in WebVR example

Hi Klaus;

In the WebVR example on Mac desktop browsers (Chrome, Safari and Firefox on Mac OSX 10.11, El Cap), it seems like videos won't stop playing once initiated.

When you click on a video from the main window, the video plays fine. But when you click the "Home" button, the audio from the video can be heard. I suppose the video is continuing to play in the background?

I created an example below. I didn't change any code; I only swapped the media files in the "video" folder.
http://www.moreyummy.com/wp-content/test/examples/webvr/

This question may have been asked before by forum user Virtuoza back in April, 2016, but I don't think it was addressed. My apologies if it was, and if so, could someone please direct me to the solution.

Thank you.


P.S. I may have fixed this issue, but Klaus, it would be good if you could help us validate to make sure ...


In Line 99 of krpano_vr.xml, I noticed that the video event was ignoring desktops. So I added ".or.HTML5" to the code. Viola, problem fixed.


<events name="video_events" devices="mobile.or.tablet.or.HTML5" keep="true"

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »surfermedina« (17. November 2016, 01:10)


34

Dienstag, 22. November 2016, 15:45

Hi,
This question may have been asked before by forum user Virtuoza back in April, 2016, but I don't think it was addressed. My apologies if it was, and if so, could someone please direct me to the solution.
Sorry, it seems I have missed that...

In Line 99 of krpano_vr.xml, I noticed that the video event was ignoring desktops. So I added ".or.HTML5" to the code. Viola, problem fixed.
Right, that was the problem - the video pause call was only done on mobiles and tablets. The example will be fixed in the next release.

Best regards,
Klaus

35

Montag, 5. Dezember 2016, 02:41

KRPano1.19 content can't show in Android 4.4.2 Webview

Hi!

I try to play KRPano 1.19 contents on Android Webview based app. But it can't.
The error message says "Adobe flashplayer or Html5 browser with WebGL or CSS3D support required!"

When I use KRPano 1.18, it can play contents correctly.

Is there any changes on system requirements on KRPano 1.19?

Please tell me!

abuethe

Anfänger

Beiträge: 18

Wohnort: Geesthacht

Beruf: Systemadministrator

  • Nachricht senden

36

Freitag, 9. Dezember 2016, 20:28

Solved: Desktop Chrome broken ? (Mac OS Sierra)

Pretty sure it worked once, but as of today for me I can´t seem to play even the simplest normal tour with chrome. Not with the testing server, not online. Anyone else?

Only a empty window with all buttons working - yet no pano to see :)

My testurl: http://panoteam.de/360/gst/index.html - runs on everything BUT Desktop Chrome :(

- even worse - it seems that other panos from for example down to 1,19-pr4 are also broken :(


Good lord - it turned out, that disabling hardware acceleration solved the problem I was encountering. Took me a while to figure that out. Ok. Never mind, Klaus! :)

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »abuethe« (11. Dezember 2016, 19:26)


37

Donnerstag, 22. Dezember 2016, 13:58

Christmas present

We used to get Christmas presents from Klaus every year. Shall we look forward to get some this year as well?

38

Samstag, 24. Dezember 2016, 10:33

Hi,

no sorry, unfortunately no special Christmas presents this year, but therefore many news next year!

Merry Christmas and a Happy New Year to everyone!

Klaus

philkrom

Anfänger

Beiträge: 35

Wohnort: Montpellier France

Beruf: Zooomez cofounder

  • Nachricht senden

39

Montag, 9. Januar 2017, 11:30

KRPano + HTC Vive ?

I am using VR since 2014 with Oculus DK1 and DK2 with Krpano tours. But I recently bought an HTC Vive, and if someone could explain the way I can display a tour on this device, it would be very helpfull. *whistling*

Best regards !
Philippe - Newbie in krpano code but very interested in everything about Oculus and VR devices *w00t*

Cofounder of the Zooomez project - zmz.fr - map on this link
If you want to support our project, please like our Facebook page *thumbsup*

40

Montag, 9. Januar 2017, 11:56


I am using VR since 2014 with Oculus DK1 and DK2 with Krpano tours. But I recently bought an HTC Vive, and if someone could explain the way I can display a tour on this device, it would be very helpfull.

Best regards !
You need Steam, SteamVR and browser with WebVR-support (Chromium or Firefox Nightly). https://webvr.info/