You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, October 5th 2011, 3:54pm

xml-Dateien als vTour verbinden

Hallo,

ich habe zwei Ordner mit jeweils einer xml-Datei.
In diesen Ordnern befinden sich mehrere Panoramen die in der xml-Datei als "Scenes" miteinander verknüpft sind.

Jetzt möchte ich gern ein Panorama aus Ordner 1 mit einem Panorama aus Ordner 2 verbinden per hotspot und habe dafür den Befehl
onclick= "loadpano(../Ordner2/index.xml,null,null,MERGE,BLEND(1));"
verwendet.

Es wird mir jedoch beim Klicken auf den hotspot nur ein schwarzer Bildschirm angezeigt.
Es kann eigentlich nicht daran liegen, dass er die Datei nicht findet. Wenn ich einen "falschen" Link angebe, zeigt er mir einen "loading error", bei richtigem Link einen schwarzen Bildschirm.

Was mache ich verkehrt?

Joscha

iceman_fx

Professional

Posts: 601

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

2

Wednesday, October 5th 2011, 8:28pm

prinzipiell ist es erst einmal möglich so zu arbeiten.
Ich mache dies teilweise auch noch so.

Hast Du mal das 2.Pano geprüft - geht das einzelnm ?
Denn da klingt eher nach einem Fehler im XML-Code.
Wichtig ist natürlich noch, das im 2.Pano auch die entsprechende Szene gestartet wird.
VG vom iceman

www.fotodesign360.de / www.falkomueller.com
_____________________________________________________________________________________________________________________
Sende eCards direkt aus Deinem Panorama. Send eCards from your panorama.
The eCard-Plugin for krpano >> http://ecardplugin.falkomueller.com

3

Thursday, October 6th 2011, 8:47am

Vielen Dank für die Antwort, iceman fx.
Beide Panoramen funktionieren einzeln problemlos.

Ich verwende das Automap-plugin bei beiden Panoramen.
Kann das zum Problem beitragen? Es bleibt nämlich nach dem Klicken auf den hotspot die Map des ersten Panoramas weiterhin sichtbar. Außerdem sieht man unten die Menüleiste. Der Rest ist schwarz.

Hast jemand noch eine Idee, woran es liegen könnte?
Habe den Quellcode der xml-Dateien angehängt. Vielleicht hilft es ja.

Es geht um den viewpoint "vpnachunten" und den hotspot "nachunten" in der Datei index_oben.xml.

Ratloser Gruß
Joscha

index_oben.xml
index_unten.xml

iceman_fx

Professional

Posts: 601

Location: Sachsen

Occupation: Webdesigner- und entwickler sowie Fotodesigner

  • Send private message

4

Thursday, October 6th 2011, 9:03am

Tja, ich selber nutze das automap-Plugin nicht.
Aber es ist zumindest eine weitere mögliche Fehlerquelle.

Ich vermute mal, dass der Aufruf gotoscene(terrasse1); ins Leere läuft.
Evtl. fehlt da die Aktion oder ist noch nicht verfügbar.

Hast Du es denn mal ohne dieses Plugin probiert - mit einem klassischen Hotspot und ohne irgendwelche Erweiterungen?
Probier auch mal folgendes: setze ein zusätzliches loadscene(terrasse1, null, MERGE); in den onstart der index_oben.xml (nach dem gotoscene) und schau mal ob es dann geladen wird.
VG vom iceman

www.fotodesign360.de / www.falkomueller.com
_____________________________________________________________________________________________________________________
Sende eCards direkt aus Deinem Panorama. Send eCards from your panorama.
The eCard-Plugin for krpano >> http://ecardplugin.falkomueller.com

5

Thursday, October 6th 2011, 9:47am

Vielen Dank für die schnelle Antwort!

Habe beides jetzt probiert.
• Entfernung der Automap-Funktion aus der xml-Datei war ohne Erfolg. Auch über einen hotspot funktioniert es nicht
• Zusätzliches loadscene war ohne Erfolg, auch Ersetzen von gotoscene mit loadscene war nicht erfolgreich

Du hattest geschrieben, dass ich in der index_oben.xml die Änderungen vornehmen sollte.
Mein Wunsch war es jedoch, mit einem hotspot in der index_oben.xml das Panorama index_unten.xml aufzurufen. Deshalb habe ich die gotoscene in der index_unten.xml angepasst: loadscene(flur, null, MERGE);

Aber wie gesagt: Leider ohne Erfolg...

Noch irgendeine Idee?