Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 24. Mai 2009, 12:16

Bilder in Textfeld

Hallo,
wenn ich Bilder in ein Textfeld laden will, soll ich das laut Doku mit folgendem HTML Code machen

Zitat

<img src="image.jpg" />
Habe das gemacht und das image.jpg in denselben Ordner wie die XML Datei gegeben, von wo aus das Textfeld inkl. Bild geladen wird. Leider wird dann lokal kein Bild angezeigt, erst wenn ich denn vollständigen Pfad angeben, funktionierts:

Zitat

file:///Users/Marc/FH/Bachelorarbeit/ARBEIT/TOUR/infos/bilder/image.jpg
(aber nur mit drei Slashes nach file: *confused*

Ist das nur lokal so, dass man den vollständigen Pfad angeben muss oder muss ich dann online auch http://url.de/...image.jpg angeben?

Gruß Marc

2

Mittwoch, 27. Mai 2009, 10:04

Hi,

in krpano werden relative Pfadangaben (url="...") normalerweise automatisch
angepasst und relativ, zu der XML in der definiert wurden, gemacht,

in einem Textfeld übernimmt allerdings Flash selber um das Laden,
dort können die Pfade nicht automatisch angepasst werden,
in dem Fall muss der Pfad der Grafik relativ zu der HTML Datei sein,

Schöne Grüße,
Klaus

3

Mittwoch, 27. Mai 2009, 10:56

habs nun versucht relativ zur HTML Datei (was ich eigentlich vorher auch schon versucht habe - wär eigentlich logisch :) ) jedoch hat es nicht geklappt.
Nun hab ich den PFad relativ zur XML Datei angepasst und dann funktioniert es!
Im Hauptordner liegt die tour.xml von dort aus wird die /Infos/info1.html aufgerufen und in dieser info1.html muss der Pfad des Bildes folgendermaßen angegeben werden:
<img src="Infos/Bilder/bild1.jpg" />
Dann funktionierts...


-Hauptordner
---tour.xml

-Infos
---info1.html
---Bilder
------bild1.jpg


Gruß Marc

4

Mittwoch, 27. Mai 2009, 11:07

Hi, ich meine relativ zu der HTML Datei, in der die krpano.swf eingebunden wird

5

Mittwoch, 27. Mai 2009, 11:09

ahh, okay, alles klar - dann funktionierts natürlich *thumbsup*
danke!

Ähnliche Themen