Sie sind nicht angemeldet.

Suchergebnisse

Suchergebnisse 1-20 von insgesamt 106.

Montag, 12. Juni 2017, 13:28

Forenbeitrag von: »floz«

UPDATE ver 3.0 - New lensflare plugin for HTML5, Flash and VR!

Yes, dynamically or at least where settings are specified in the xml from where your plugin is included...

Samstag, 10. Juni 2017, 13:24

Forenbeitrag von: »floz«

UPDATE ver 3.0 - New lensflare plugin for HTML5, Flash and VR!

I'd have essentially the same question - would it be possible to load your lensflare plugin from a central location, and just set some parameters locally in pano.xml? Right now I can do this with the good old Quellcode 1 <lensflare name="lf0" ath="115.63" atv="-49.63" size="0.17" blind="0.1" blindcurve="3.00" set="DEFAULT" visible="true" /> , but am looking to convert this to your plugin...

Samstag, 6. Mai 2017, 17:28

Forenbeitrag von: »floz«

copyswf

Thanks for your hard work, Klaus! Just wondering, will Quellcode 1 copyswf make a return in the .config files ? I'm creating panos batch-wise and don't need the .swf file to be created each time... Thanks!

Freitag, 8. Mai 2015, 12:59

Forenbeitrag von: »floz«

External interface NOT available ... when embedding on Facebook

For Facebook shares, you need to specify an SWF file in a special html meta tag. I did that, but forgot to append which XML file to actually use, since the SWF I referred to was just the bare-bones player (as created by one of the droplets). The trick was to append ?pano=bla.xml so that the player actually would know what to show So this finally worked: Quellcode 1 <meta property="og:video:secure_url" content="https://www.bild.nu/okura2/OKURA_lobby_DSC05497sRGB.swf?pano=https://www.bild.nu/okura...

Sonntag, 22. März 2015, 18:05

Forenbeitrag von: »floz«

External interface NOT available ... when embedding on Facebook

Hi there, I'm trying to get Facebook embeds working for a friend. It all seems to work, except that when the panorama is loaded, I get a blank screen and the log shows WARNING: External interface NOT available. Any idea why that could be happening? Here's the page (to be shared on Facebook) if you want to see for yourself: https://www.bild.nu/okura2 Thanks for any pointers! I've read the instructions relating to this with offline usage, but that's not the case here!

Sonntag, 9. November 2014, 11:50

Forenbeitrag von: »floz«

copyswf option gone ?

Klaus?

Sonntag, 19. Oktober 2014, 14:19

Forenbeitrag von: »floz«

copyswf option gone ?

Hi there, I just noticed that the copyswf option is gone (in 1.17 as well...). Since I have my templates elsewhere, how do I prevent errors like "ERROR: krpano.swf not found!" and "ERROR: calling the protect tool failed!" ? I simply don't want kmakemultires or now krpanotools makepano to copy any swf files. Thanks!

Mittwoch, 21. August 2013, 11:44

Forenbeitrag von: »floz«

Limit to domains + custom hostname

As always, thanks for your quick reply, Klaus. Can't this requirement be taken out, or at least be turned into a warning rather than an error?

Dienstag, 20. August 2013, 13:40

Forenbeitrag von: »floz«

Limit to domains + custom hostname

Hi there, Not sure if it's me, but I'm trying to use KRPano Protect to protect my krpano.swf and krpano.js to a server that (currently) can only be accessed by an IP address. If I add that IP to the "Limit domains" box at the bottom, all is good, no license error. If, however, I access this server with a (locally set) host name (to save me the typing of the IP address all the time...), I get a license error. If in turn I try to add that hostname to the domain list, I get a message "not a valid d...

Montag, 5. August 2013, 08:13

Forenbeitrag von: »floz«

Example/Tutorial - Extract a Distorted Hotspot from any kind of Pano Image (with perfect pixel alignment)

I'm trying to get this going on a FLAT pano. Now, this trick works perfectly fine in the Flash viewer, but not in the new HTML5 multires preview viewer (build 2013-07-30). In particular, the calc_pos_from_hfov_yaw_pitch_roll action is not placing the image correctly. It looks like the image's height and width is incorrect (the location seems right though...). Any idea why?

Donnerstag, 25. Juli 2013, 13:01

Forenbeitrag von: »floz«

set(view.fovmax,VAL) not working in HTML5

Ah, yes, that makes sense! I'm amazed by your insight into all this, well done!! Thanks, Alexey!

Donnerstag, 25. Juli 2013, 12:21

Forenbeitrag von: »floz«

set(view.fovmax,VAL) not working in HTML5

Thanks for your input, Alexey. Unfortunately, that didn't help. I did find the culprit, however. Klaus, not sure if this is something for you to look at, or if there's a simple logical explanation. This DOESN'T work: Quellcode 1 2 3 oninterrupt(break); lookto(90,0,80, smooth(45,45,60), false); set(view.fovmax,111); But this DOES (i.e. the fov is correctly limited in HTML5 [it always works fine in Flash...]) Quellcode 1 2 3 oninterrupt(break); set(view.fovmax,111); lookto(90,0,80, smooth(45,45,60...

Donnerstag, 25. Juli 2013, 03:03

Forenbeitrag von: »floz«

iOS7 and KRPano

Well, the problem is that iOS7 is still in beta, and things do change. Everyone around the interwebs applied the old hide-url-bar-trick by using javascript scrollto(0,0). However, since the URL bar behaviour has changed in iOS7 this is broken. Initially (beta 1), it was badly broken, as the scrollto command would scroll the content underneath the bar (so your web app navbar would actually be hidden!). Thankfully, Apple fixed this in beta 2 (or 3), so that scrollto now scrolls to the top and stuf...

Dienstag, 23. Juli 2013, 15:42

Forenbeitrag von: »floz«

set(view.fovmax,VAL) not working in HTML5

Is it possible that set(view.fovmax,111) is not working in HTML5? I can only set a fovmax statically in the <view> tag itself, but attempting to set it dynamically fails (as in, the value is not used). Is this a know issue? Thanks!

Freitag, 21. Juni 2013, 04:23

Forenbeitrag von: »floz«

krpano HTML5 Multiresolution Preview

Ok, found it. As Tuur was saying earlier: You can't use maxpixelzoom and you have do explicitely specify a (small value for) fovmin for it to work. And tilesize doesn't have to be 512px.

Freitag, 21. Juni 2013, 03:56

Forenbeitrag von: »floz«

krpano HTML5 Multiresolution Preview

Absolutely fantastic work, Klaus. Thank you! Quick question. I can't get it to work in my environment though. This may have several reasons. For instance, is a tile size of exactly 512px a requirement for the mutliresolution to kick in? I've also tried it with a pano that has a tile size of 480px, also to no avail. Cheers, Florian PS: If it helps, here's the XML I was trying it with (the normalview function gets called from within defaultskin.xml...) : Quellcode 1 2 3 4 5 6 7 8 9 10 11 12 13 14 ...

Mittwoch, 23. Januar 2013, 08:35

Forenbeitrag von: »floz«

Frage an klaus.krpano…

Hey super, ganz "unbürokratisch" :-) Vielen Dank und alles Gute, Flo

Mittwoch, 23. Januar 2013, 02:19

Forenbeitrag von: »floz«

(Even) better interpolation

Brilliant, can't wait to see that :-)