You are not logged in.

Search results

Search results 1-20 of 244.

Friday, June 29th 2018, 2:29pm

Author: benji33

SoundInterface, continuous. with loop. step-by-step

Set the soundinterface plugin with keep="true" attribute and launch the sound after a user gesture (prefered) with a playsound action with 0 value for loops (cf. https://krpano.com/plugins/soundinterface/#playsound) Sound should be played accross scenes

Friday, June 29th 2018, 11:51am

Author: benji33

Gyroscope v2

How is the default view of a panorama taken in account during spot naviguation of non oriented scenes ? For instance with this view tag the gyroscope returns the hlookat 0 & vlookat 0 position + gyroscope orientation as basis and in desktop the default view is respected with real hlookat and vlookat. If I remember the gyro1 plugin wasn't do that into the 1.19-pr3 version and was using real hlookat and vlookat sets positions. Something has changed with gyro2 if yes how to do? Thanks Source code 1...

Tuesday, June 26th 2018, 5:00pm

Author: benji33

Gyroscope v2 plugin and partial panoramas

Hello, I've tested Gyro2 with partial panoramas and it seems there are some strange behaviors, see below. Tested on iOS 11.4 Safari with an iPhone 6S. For instance I've a partial panorama with this view tag and the gyroscope is enabled only after the onavailable event check action which is done after a 1 second delay, see below my settings : Source code 1 2 3 4 5 6 7 8 9 10 11 12 <view fisheye="0" limitview="range" hlookatmin="-95.890000000000001" hlookatmax="95.890000000000001" vlookatmin="-13....

Wednesday, June 20th 2018, 2:20pm

Author: benji33

iOS 11.3.1 black-screen

Nice. In fact it's not really iOS, it's more a Safari issue because it's also present into macOS Safari 11.1.1 version. Chrome iOS seems not affected, but after all my tests I'm not sure LOL

Wednesday, June 20th 2018, 11:27am

Author: benji33

How to check browser version easily

Hello, I've tested this code with Safari 11.1.1 on macOS. Source code 1 2 3 4 5 if(device.safariversion GE 11, trace('VERIFED'); , trace('NOT VERIFIED'); ); It returns NOT VERIFIED. The check is VERIFED with single "." version as iOS ones but not with macOS ones due to the string comparison. There is a way to do it easily without a string parse? Better solution at this time : Source code 1 2 3 4 5 6 7 indexoftxt(indexsafariversion, get(device.safariversion), "."); subtxt(majorsafariversion, get(...

Tuesday, June 19th 2018, 4:44pm

Author: benji33

iOS 11.3.1 black-screen

In fact it's linked to the BLEND parameter of the loadscene action. Only the NOBLEND value is working, others values cause the black rendering. Any info on that Klaus? Thanks a lot.

Wednesday, May 23rd 2018, 9:41am

Author: benji33

Html div in Krpano and z-index issue

You're right. Seems to be a Chrome issue. It's not the first time that Chrome doesn't respect the z-index for fixed and absolute positionned divs.

Tuesday, May 15th 2018, 10:02am

Author: benji33

video autoplay

Some news on that with Safari 11 & Chrome 66 autoplay policies on desktop ?

Friday, May 4th 2018, 4:35pm

Author: benji33

Flying picture and hotspot with child layer issue

Thanks so it's why my hotspot with tooltip layer is over the flying hotspot picture. I'll have to manage a way to set tooltip as hotspot, simple, but apply offset and rotation linked to the hotspot one, with non defined picture size it will be more difficult to achieve

Thursday, May 3rd 2018, 3:49pm

Author: benji33

Flying picture and hotspot with child layer issue

Hi, I've tried to setup a picture hotspot with a flying attibute. It works. I've added a hotspot which is covered by the flying picture, with the add of zorder/zorder2 values (flying picture receive a zorder of 10 and hotspot a zorder value of 3). It works. But If I add a text layer created with the addlayer method as child of the previous hotspot, the hotspot itself and the layer are always over the flying picture even with all zorder changes. Is it a known issue with children layers ? Thanks, ...

Friday, March 16th 2018, 3:36pm

Author: benji33

Webvr not working with Chrome's latest updates

Hi, Of course the sample code above was designed for test only ;) Yes it's a workaround and not a fix ... sorry for the mistake. Thanks for the lesson about device motion/device orientation. I've tested the 2 libs for Chrome 65 on 3 devices and it works with them. But your previous workaround post with only the XML edit wasn't working. Thanks for this quick edit to partially solve the customers problem linked to the Chrome issue.

Friday, March 16th 2018, 9:31am

Author: benji33

Webvr not working with Chrome's latest updates

Hi, With this fix mobilevr_sensor="0" I've no result. No move on vertical and horizontal axis with the fix and vertical only without the fix ! (tested with Huawei P8, LG G4 and Samsung S6) With krpano 1.19pr14 webvr sample it doesn't work also. My own code Source code 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 <plugin name="webvr" devices="html5" keep="true" url="webvr.js" mousespeed="0.00125" multireslock="true" fullscreen_mirroring="true"...

Monday, March 12th 2018, 5:10pm

Author: benji33

Webvr not working with Chrome's latest updates

Here is the referenced issue : https://bugs.chromium.org/p/chromium/iss…ed&groupby&sort

Wednesday, February 21st 2018, 3:30pm

Author: benji33

krpano 1.19-pr14

Nice thanks Jérome !!! I'll have a look.

Monday, February 19th 2018, 11:51am

Author: benji33

krpano 1.19-pr14

I've an issue with z-index and fullscreen. In fact I use external div element out of the krpano div and I apply my own fullscreen treatment. But since latests krpano version I've noticed that the z-index of the krpano element is applied to the highest zindex available (2147483647) and the others div cannot be displayed anymore with Android Chrome browser when rotating the screen (which apply the fullscreen event). Is it a krpano or Chrome issue/feature ?

Thursday, January 18th 2018, 5:02pm

Author: benji33

krpano 1.19-pr14

Nice investigation :)

Thursday, January 18th 2018, 9:32am

Author: benji33

krpano 1.19-pr14

Quoted from "klaus.krpano" Sorry, can't reproduce anything like that. Just tested again (on Windows). Can you please explain your 'quick' rotations? Here is a video sample with closed Chrome dev tools : https://www.dropbox.com/sh/dq9jntg58uo9z…tpIn4lxPma?dl=0 Thanks for the answer to jeromebg.

Wednesday, January 17th 2018, 9:24am

Author: benji33

krpano 1.19-pr14

When Simulated VR mode is activated on Chrome desktop (PC) when rotating with the mouse on Yaw axis the view is refreshed at a previous position during "quick" rotations. Works good on Firefox. Many users report a difficulty to access a tour through the WebVR API with the Samsung Internet Browser for GearVR. It works great with the Oculus Browser. Do you know the difference between the 2 differents browsers? It seems that the Oculus Browser has a better use of the available resolution. John Carm...