You are not logged in.

Search results

Search results 1-20 of 68.

Friday, May 8th 2015, 7:55pm

Author: Ibrendie

krpano 1.19 - Pre Release 2

Absolutely fantastic! Just one small thing, your cloud example mentions an outdated video player plugin in the log...

Friday, May 1st 2015, 7:19pm

Author: Ibrendie

krpano 1.19 - Pre Release 1 - WebVR / MobileVR / Stereoscopic 3D Support (Oculus Rift, Google Cardboard, GearVR, ...)

I definitely agree. I think Klaus is way ahead with krpano compared to all other pano viewers. I will just wait for this feature in the final 1.19 release (if it will be available). In the meantime I can cover the Nadir with a nadir logo. I just started with stereo panoramas, and the most difficult part is the nadir .

Friday, May 1st 2015, 7:02pm

Author: Ibrendie

krpano 1.19 - Pre Release 1 - WebVR / MobileVR / Stereoscopic 3D Support (Oculus Rift, Google Cardboard, GearVR, ...)

Thanks for the explanation Jordi. I hope it will be possible to limit the vertical fov. It's a really simple way to hide the nadir spot.

Friday, May 1st 2015, 6:34pm

Author: Ibrendie

krpano 1.19 - Pre Release 1 - WebVR / MobileVR / Stereoscopic 3D Support (Oculus Rift, Google Cardboard, GearVR, ...)

Hi, I've a really simple question, I can't seem to get it working. What I want to achieve is to limit the vertical field of view to "hide" the nadir spot. I've the following view settings, which work great in non WebVR mode. Source code 1 <view hlookat="0" vlookat="0" fovtype="VFOV" fov="90" fovmin="30" fovmax="150" limitview="lookat" vlookatmin="-90" vlookatmax="+26" /> As soon as I click the EnterVR button the view is "reset" to the nadir spot (+90). The nadir is visible. Is the vlookatmax ign...

Tuesday, April 28th 2015, 4:20pm

Author: Ibrendie

krpano 1.19 - Pre Release 1 - WebVR / MobileVR / Stereoscopic 3D Support (Oculus Rift, Google Cardboard, GearVR, ...)

Klaus is back, jeej . I've a question for all WebVR enthousiasts over here. Maybe we can come up with a simple but effective way to share webvr.xml lens distortion presets with each other. As you may know the webvr.xml plugin file includes lens distortion presets for several different VR headsets. See http://krpano.com/plugins/webvr/#mobilevr_lens_fov . With all these new VR headsets coming out and in the future, maybe we can create a new thread and place all presets there. Good idea?

Tuesday, April 28th 2015, 2:11pm

Author: Ibrendie

"Best" krpano IDE/editor

Quoted from "klaus.krpano" Personally I'm preferring UltraEdit (Windows) - I'm working with it for years and all about krpano was developed with it . Without an auto complete file? Or "word file" as it is called in UltraEdit :) ?

Saturday, April 25th 2015, 2:01pm

Author: Ibrendie

"Best" krpano IDE/editor

It looks like the majority of you guys work in Windows, I don't, I work on Mac :) . Try Brackets, it's a fantastic editor!

Friday, April 24th 2015, 12:14pm

Author: Ibrendie

embedpano modifying path to xml

Quoted from "javi7" I have a base directory called "fullClimb." Inside of fullClimb, I have a directory called html which contains a file "demo.html" which contains the snipped I quoted above. I have another directory called "hi-res" which has folders for all my tile images ("1-1_Panorama.tiles", "2-1_Panorama.tiles", etc.) and a folder called "xml" with all of my xml files. So the relative path from demo.html to 1-1_Panorama.xml is "../hi-res/xml/1-1_Panorama.xml" and the absolute path is "/fu...

Thursday, April 23rd 2015, 8:53pm

Author: Ibrendie

embedpano modifying path to xml

Quoted from "javi7" I have the following line in a script tag on my html page: Quoted embedpano({swf:"/fullClimb/hi-res/xml/1-1_Panorama.swf", xml:"/fullClimb/hi-res/xml/1-1_Panorama.xml", target:"pano", html5:"prefer", passQueryParameters:true}); However, the viewer seems to be trying to load "/fullClimb/hi-res/xml/../../xml/1-1_Panorama.xml" instead of the path I have entered. Does anyone know why embedpano would interpolate the extra "../../xml" into the path? I have tried a variety of paths...

Thursday, April 23rd 2015, 2:45pm

Author: Ibrendie

Matterport

Quoted from "klaus.krpano" There is a misunderstanding - I don't mean how to render (that's the easy part) - I mean how to shoot/capture/record the 3d geometry or that depth map. When you shoot a pano, you shoot only a flat 2d image without any deep information. There would a laser scanner or 3d-stereo-process required to build that 3d-data. Maybe something like this Klaus :)? http://www.reddit.com/r/oculus/comments/…g_software_for/ http://www.faro.com/de-de/scenect/scenect

Thursday, April 23rd 2015, 2:36pm

Author: Ibrendie

"Best" krpano IDE/editor

As of 2015, with HTML5, CSS3(D), WebGL and WebVR support in krpano, I'm curious which IDE's or code editors the krpano users use :) ? I want to make a krpano auto-complete plugin for a code editor to help as many people as possible, so I have to know which code editors you use. I will focus on HTML5 functionality, not flash. Some editors I know: - Brackets.io (open-source, from Adobe, I use this one) - Atom.io (open-source, from Github themselves) - SublimeText (free, but can be bought to remove...

Wednesday, April 22nd 2015, 11:07pm

Author: Ibrendie

"Walking" in a virtual tour

I'm "closing" this thread. See Matterport for related discussion.

Wednesday, April 22nd 2015, 11:04pm

Author: Ibrendie

[WebVR] Detect if browser supports WebVR through external Javascript interface *SOLVED*

I used another method instead of detecting WebVR support through the external Javascript interface, I just show a message when WebVR isn't available. Solution: webvr.xml (plugin) In the plugin definition at the beginning of the file I added the action name of my warning layer to the onunavailable: Source code 1 onunavailable="show_warning();" xyz.xml (pano xml) I created a layer and set the alpha to 0.0 and autoalpha to 1.0 (autoalpha does the trick to also set visible to true based on the alpha...

Wednesday, April 22nd 2015, 10:52pm

Author: Ibrendie

Layer image not being cached

Up! Anyone know why the image is loaded everything again? Or is this maybe the default behavior of the layer > url variable?

Wednesday, April 22nd 2015, 10:50pm

Author: Ibrendie

Blend one pano image to another after some time *SOLVED*

I found a way to blend from one pano to another after some time. Actually it was easier then I thought. Solution: Source code 1 delayedcall(5, loadscene(scene2, null, MERGE, BLEND(10) ); ); 5 means AFTER 5 seconds start the loading of the next scene 10 means the blending duration from one scene to another scene takes 10 seconds See also http://krpano.com/docu/actions/#loadpano.blend

Tuesday, April 21st 2015, 10:44pm

Author: Ibrendie

Blend one pano image to another after some time *SOLVED*

Up.. Anyone know how to achieve something similar to the slider blend example, but without the slider part? Just a blend from one pano to another over some time period? Thanks.

Tuesday, April 21st 2015, 12:13pm

Author: Ibrendie

krpano 1.19 - Pre Release 1 - WebVR / MobileVR / Stereoscopic 3D Support (Oculus Rift, Google Cardboard, GearVR, ...)

Hi Klaus, What does the following line do? I don't understand it. I can't find a sensor_button layer and also not an action called update... Source code 1 callwith(layer[sensor_button],update()); Source code 1 <!-- when WebVR support is available show an EnterVR button --> <action name="webvr_onavailable"> loadsettings(); tween(layer[webvr_button].alpha,1); callwith(layer[sensor_button],update()); </action>

Monday, April 20th 2015, 9:41pm

Author: Ibrendie

krpano 1.19 - Pre Release 1 - WebVR / MobileVR / Stereoscopic 3D Support (Oculus Rift, Google Cardboard, GearVR, ...)

Quoted from "loomitz" I dont know why but my Pano crashes on osx on chromium or its Just me? http://loo.mx/Tours/Guanajuato.html Hi loomitz, Yes it crashes also on my Macbook (OS X Yosemite and Chromium WebVR build 0.4.4) with the following report: Crashed Thread: 17 Chrome_IOThread Exception Type: EXC_BAD_ACCESS (SIGSEGV) Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

Monday, April 20th 2015, 10:46am

Author: Ibrendie

Layer image not being cached

When using a layer to show a fullscreen image (url set to image, width and height to 100%) the image is loaded every time I visit my tour. It looks like the image isn't cached. I tried like 5 different browsers, because I read on this forum that the browser should do the caching. Any ideas why my fullscreen image isn't being cached?

Sunday, April 19th 2015, 11:14pm

Author: Ibrendie

krpano 1.19 - Pre Release 1 - WebVR / MobileVR / Stereoscopic 3D Support (Oculus Rift, Google Cardboard, GearVR, ...)

Hi, I'm trying to customize the webvr.xml plugin file. I've added an action to the onclick event of webvr_button (Enter/ExitVR button). However, when I EnterVR and the button changes to ExitVR, the ExitVR button doesn't do anything anymore when clicked on. What I want to achieve is that a scene isn't loaded until I click on the webvr_button (EnterVR button). I think it has something to do with the action webvr_onexitvr in the weber.xml plugin. Source code 1 2 3 4 5 6 7 <action name="webvr_onente...