You are not logged in.

Search results

Search results 1-20 of 130.

Wednesday, October 24th 2018, 3:43pm

Author: webseta

parent=stage focus issue?

Oh yeah, I just realized that on mobile (android, chrome) it's not working at all, not just the text input fields but even buttons stop working. Klaus, is there a workaround or a planned bugfix for this?

Wednesday, October 10th 2018, 3:08am

Author: webseta

krpano in embedded browser component

I am using the latest, PR16 version. Following up on this case I did a little test, opened a page capable of detailing some of the capabilities and limitations of the actual browser in this particular embedded browser module. You can view the results here: http://html5test.com/s/a6248640748a8445.html Anything that might give a clue as to why it's returning null for the krpano.webgl? Or any other idea/suggestion on what should I test further? Like I mentioned earlier, get.webgl.org tells me I hav...

Saturday, September 29th 2018, 3:12am

Author: webseta

parent=stage focus issue?

Interesting rebaj, you're saying you don't experience the issue I'm having in Chrome? At all?

Wednesday, September 26th 2018, 3:14pm

Author: webseta

parent=stage focus issue?

Anyway, I was actually able to solve this by giving it focus programmatically on a click. Not a nice/ideal solution, but works for now. One big issue is that this way I the care in the input can only be placed at the end of the text, so it's not possible to click into a specific position or to select the text inside it. Is there perhaps a workaround, or a fix planned for this?

Wednesday, September 26th 2018, 3:10pm

Author: webseta

parent=stage focus issue?

What do you mean? In the documentation it says: "Note - all <layer> or <plugin> elements will be placed inside this area. To place a <layer> or <plugin> element outside that area, set the parent attribute of that layer / plugin element to "STAGE"." I need the plugin to be outside the area.

Tuesday, September 25th 2018, 5:28am

Author: webseta

krpano in embedded browser component

Hi! I'm doing some experimenting in embedding the krpano html5 viewer in a desktop app, so not in a traditional browser window, but in a compact browser component used as part of a desktop application. I was intenting to use the makescreenshot api, but unfortunately I found that the krpano.webGL is undefined. I'd think it's simply because this browser component doesn't have webgl capabilities, but that is not true, first if I open https://get.webgl.orgit shows that I do have webgl functionality,...

Tuesday, September 25th 2018, 4:16am

Author: webseta

Batch to produce a projected snapshot from spherical pano

Hi! Any way to simulate architectural and fisheye projection with this function? Would save a shitload of time and work for us!

Friday, September 7th 2018, 12:29am

Author: webseta

parent=stage focus issue?

Open this link, close the black info layer that pops up, wait 3 seconds and then a layer will slide in from the left. At the top, there's an input field, this is the one I'm having trouble to get focus into. I appreciate what you wrote and how these things aren't easy, but it would be great if there was some kind of a workaround :) Cheers!

Thursday, August 16th 2018, 2:29am

Author: webseta

radar over video spot issue

Hi, this is still an issue, pls reply if possible.

Thursday, August 16th 2018, 2:27am

Author: webseta

parent=stage focus issue?

Hi, this is still an issue, pls reply if possible.

Thursday, July 26th 2018, 6:59pm

Author: webseta

radar over video spot issue

Dear Klaus! So we've recently managed to start producing video panoramas in out tours and one thing we've noticed is that the radar doesn't work for some reason on these. Now, of course it could be a number of factors, but simply put, whenever we navigate to a video panorama, the radar disappears and we get an error like this in the console: "Error: <path> attribute d: Expected number, "M 50,50 L NaN,NaN A 47.5,4…"." If we then navigate back to a traditional, image based spot, the radar comes ba...

Tuesday, June 19th 2018, 5:13pm

Author: webseta

parent=stage focus issue?

Klaus, could you please take a look at this?

Thursday, June 14th 2018, 10:54pm

Author: webseta

parent=stage focus issue?

Dear Klaus! I just tried to create a plugin that is displayed alongside the panorama, instead of over the image, by setting the plugins parent to stage. It all looks good, but when I put an input element in this plugin, it's very hard to get focus in it, meaning if I just single-click it, nothing happens, no matter how many times I try. If I double click, again nothing happens. But if I start clicking like mad, sometimes it finally gets focus. Please note this only happens with type=text inputs,...

Monday, May 28th 2018, 8:19am

Author: webseta

video panorama autoplay issue

Hmm, actually it seems I was binding the events in a wrong way. Now corrected, neither of them does fire. Are these events mobile-only?

Monday, May 28th 2018, 8:02am

Author: webseta

video panorama autoplay issue

Dear Klaus! We've just started to delve into the use of video panoramas. So far so good, but we've run into a problem. So I understand there is no autoplay on (some) mobile devices, but it seems Chrome has an interesting policy on autoplay in the desktop browser too. More importantly though, I'm not sure the video player plugin events work as they should - or maybe it is me doing something wrong. So when I load the video panorama by entering the url in the address bar, hitting enter, the autopla...

Monday, May 7th 2018, 2:38pm

Author: webseta

krpano 1.19-pr15 / pr16

Dear Klaus, we've updated to the latest version, now the issues with the gyro are thankfully gone. However, it seems that some default behavior is changed perhaps? So far we had a code that changed (switched) the enabled property of the gyro plugin after it became available, because that's how the gyro function could be enabled automatically on startup. With the new version it seems that this changed, as our code now results in disabling it automatically. It's not a big issue as it was a 1-minut...

Saturday, April 28th 2018, 7:09am

Author: webseta

Autosize doesn't work using custom font?

Dear Klaus, we've looked at the possibility of using some custom fonts for our textfield based plugins (layers), so far we've only been using Arial. Thing is, it seems the onautosized event isn't always working properly. Here's the code that sets the css for the layer in question: Source code 1 menuItem.css = "font-family:Armata,sans-serif;font-size:13px;color:#FFFFFF;text-align:center"; The text appears and displays fine, but (with a certain html string) it sets itself to a width of 111px, when...

Thursday, April 26th 2018, 4:09pm

Author: webseta

krpano 1.19-pr15 / pr16

Right, cause gmail blocked it. Sent it again, it seems this time it went through. Thanks!

Thursday, April 26th 2018, 4:33am

Author: webseta

krpano 1.19-pr15 / pr16

Sent you an email. Thanks!