You are not logged in.

Search results

Search results 1-19 of 19.

Friday, July 19th 2019, 7:12pm

Author: olly

function arguments resolve to null on mobile

Hi all, I have a problem that I hope someone can help me with. If you visit this tour on chrome desktop browser: 1476_testing and open the console, when you click the "BLANK CANVAS" hotspot you will see "skin_changeFitout_click() argument 1 = catA" reported in the console. If you then apply a Galaxy s5 profile in developer tools you will see "skin_changeFitout_click() argument 1 = null" and the scene fails to load as the scene name is malformed with null. It should still report "skin_changeFitou...

Thursday, January 10th 2019, 1:46pm

Author: olly

DOMException: Failed to read the 'localstorage'

Hi Klaus, Thank you for replying. I forgot to mention the error only shows when using the dev tools to emulate a mobile device. Is it anything to worry about in that context? Thanks, Olly

Thursday, January 10th 2019, 11:43am

Author: olly

DOMException: Failed to read the 'localstorage'

Hi there, I am getting the following console error when viewing a tour with chrome dev tools open: Source code 1 2 Uncaught DOMException: Failed to read the 'localStorage' property from 'Window': Access is denied for this document. https://d8d913s460fub.cloudfront.net/krpanocloud/webvr_localstorage.html?v=4:1:167 You can see our tours here I am currently using 1.19-pr16, have been creating tours for a couple of years and do not recall seeing this error before. FWIW, some older tours may have use...

Friday, May 11th 2018, 1:59pm

Author: olly

cannot load scene using onclick

Can anyone help explain why I cannot get my linkedscene to load on a hotspot? I have the following actions defined for onover and onclick of my hotspot: Source code 1 2 3 4 5 6 7 8 9 10 <action name="hotspot_setupChange_onOver"> trace(get(linkedscene)); txtreplace(newurl, url, '.png', '_over.png'); set(url, get(newurl)); </action> <action name="skin_hotspotstyle_click"> trace(get(linkedscene)); if(linkedscene, set(enabled,false); loadscene( get(linkedscene), null, txtadd(MERGE|,%1) , get(skin_se...

Friday, May 11th 2018, 1:25pm

Author: olly

Change hotspot url using calc

Thank you - that works. Just in case it helps others, I also figured out a way using txtreplace() Source code 1 2 3 4 <action name="hotspot_setupChange_onOver"> txtreplace(newurl, url, '.png', '_over.png'); set(url, get(newurl)); </action>

Friday, May 11th 2018, 11:36am

Author: olly

Change hotspot url using calc

Hi there, I am trying to change the url of a hotspot in an onOver action, as follows: Source code 1 2 3 <action name="hotspot_setupChange_onOver"> set( url, calc( url - '.png' + '_over.png' ) ); </action> But I get: Source code 1 GET http://192.168.1.5:53087/NaN_over.png 404 (Not Found) Can anyone point me in the right direction and explain why my code does not work? On a previous project I was successfully using this: Source code 1 2 3 <action name="hotspot_setupChange_onOver"> set( url, calc('...

Wednesday, September 7th 2016, 12:08pm

Author: olly

How to "Count" the children layer ?

Taken from http://krpano.com/docu/actions/#arrays: Quoted Every xml element with a name attribute is an element / item of an Array In this case surely layer[a], in the OP's example, should be an array? I would love to access layer[a].count and also a child object, using layer[a][0], but it doesn't seem to work. Please could someone clarify the situation and give me a pointer if it is just a problem with my syntax?

Thursday, September 1st 2016, 12:28pm

Author: olly

indexoftext and tolower

I am trying to compare the linkedscene var against xml.scene using the indexoftext and tolower functions: Source code 1 indexoftxt(index, xml.scene, tolower(linkedscene) ); I am using tolower because xml.scene appears to always be lowercase. However, the first trace outputs the linkedscene attribute as expected, whereas the second just outputs the text between the parentheses. Can someone help me with the syntax please? Source code 1 2 3 4 5 6 7 8 9 10 <style name="skin_hotspotstyle_setupChange"...

Thursday, September 1st 2016, 10:15am

Author: olly

Detecting change in device orientation

Thanks guys, that is a great help!

Wednesday, August 31st 2016, 3:27pm

Author: olly

Detecting change in device orientation

Is there a simple way of changing an attribute's value, based on device orientation? Something like this maybe: <layer name="help" type="container" height="33%" height.mobile.landscape="50%" height.mobile.portrait="33%" Or am I trying to do something fundamentally wrong here?

Tuesday, August 23rd 2016, 5:51pm

Author: olly

Referencing a layer name in an onover action & debugging

Figured them both out. Replacing "this" with "name" works: <action name="switchSetup_controls_onOver"> set(layer[name].background, true); </action> And adding showlog(true); to the startup action fixes my debugging issue. As you were...

Tuesday, August 23rd 2016, 1:54pm

Author: olly

Referencing a layer name in an onover action & debugging

What is the krpano syntax to write an action like this, similar to the way JS works? <action name="switchSetup_controls_onOver"> set(layer[this].css, font-family:Arial; font-size:16px; color:#000000;); set(layer[this].background, true); </action> Additionally is there anything special required to see errors in the console log? I never see any errors or the output from the trace command in Chrome's dev tools.. Any pointers greatly appreciated!

Thursday, July 28th 2016, 1:50pm

Author: olly

Stereo panos not possible in Internet Explorer?

Thanks for the pointer - sorry for the ridiculous question!

Wednesday, July 27th 2016, 6:56pm

Author: olly

Support for Samsung browser for Gear VR?

When I view one of our panos on the Samsung Internet app the resolution is terrible. I am changing the viewing "mode" to 360 2D. I tried adding mobilevr_webvr_dist="true" to webvr.xml but couldn't see any change. Did I miss something?

Wednesday, July 27th 2016, 5:58pm

Author: olly

Stereo panos not possible in Internet Explorer?

When I view any panos (created with krpano) on IE 10 the VR goggle icon is missing. Is that a known limitation? Sorry if it is written somewhere - I couldn't find it when I searched.

Wednesday, July 27th 2016, 10:50am

Author: olly

Animated Transparent Hotspot not displaying on mobile

Thank you for helping me solve that Umalo - much appreciated! The fire is created from layering copies of this asset on turbosquid: http://www.turbosquid.com/FullPreview/Index.cfm/ID/555484 and randomising the start frames. Thanks again, Olly

Tuesday, July 26th 2016, 10:10pm

Author: olly

Animated Transparent Hotspot not displaying on mobile

Interesting that it works in safari and not chrome. I lowercased all the names and the flames still work on desktop, but appear as black on my mobile. I have also added the original skin file,just habit that it was encrypted. Nothing special in there, I just added a custom hotspot for my main vr tours and the do_crop_animation function. I have left work now, but will pick back up on this in the morning and create a stripped down version to see if that helps.

Tuesday, July 26th 2016, 9:12pm

Author: olly

Animated Transparent Hotspot not displaying on mobile

Thanks for taking the time to reply Umalo. I am still learning krpano, but believe my tests are using webgl. What desktop environment is it not working on for you? Could it be falling back to flash for you? Please ignore the mask attribute, that was leftover when I tested that feature, I have removed it from the xml now. Could you have another look? Thanks again!

Tuesday, July 26th 2016, 6:39pm

Author: olly

Animated Transparent Hotspot not displaying on mobile

I am using the hotspot feature to add animated flames to an interior fireplace [url removed] It works perfectly on desktop, but appears as just a black image when viewed in Chrome on my Galaxy S6. The animated flames are a 8bit png file using crop animation. Can anyone point me in the right direction please? Many thanks, Olly