You are not logged in.

Search results

Search results 1-20 of 1,000. There are even more results, please redefine your search.

Saturday, April 4th 2020, 11:04am

Author: klaus.krpano

Question About 'levelsizes' and 'multires' xml attribute

Hi, that was a bug in the krpano tools, the levels were generated in the wrong order. It was fixed in 1.20.3: Quoted Fix: When using custom levelsizes for the multires tile generation, the level order was wrongly inverted. That means either change the order in the xml or in the config to keep it working as before. Best regards, Klaus

Saturday, April 4th 2020, 11:02am

Author: klaus.krpano

IOS 13.4 issues

Hi, right, that's because a very ugly bug in iOS 13.4. The gyro and VR controls are using the browsers 'devicemotion' event (by default) to get information about the current device rotation state. And in iOS 13.4 that event no longer reports the gyroscope rotation information, only the acceleration information are available. That makes the gyro/VR control working strangely slow and inaccurate. I had made a very simplified test-case for Apple here: https://krpano.com/ios/bugs/ios13-4-b1-gyro/ Tha...

Saturday, April 4th 2020, 10:48am

Author: klaus.krpano

more than 94 hot spots-problem in the latest version of IOS

Hi, here in detail: when rendering textfields with WebGL (the default), each textfield will be internally rendered to an image,and depending on the size of the textfield and the oversampling setting, that image can become very large,and at some point too much memory is used (depending on the actual system, browser and device). That means in such case consider use renderer="css3d" for that textfield hotspots, in this case the browser is rendering the textfields by its own. Best regards, Klaus

Wednesday, April 1st 2020, 10:47am

Author: klaus.krpano

Sync of two video with video player plugin

Hi, video loading/decoding/rendering is too much browser-based and there are too few browser-APIs for controlling the playback exactly. Best regards, Klaus

Wednesday, April 1st 2020, 10:45am

Author: klaus.krpano

Graphic context lost! Please reload......

Hi, you could try using the 32bit version of the krpano Tools application. That one uses a different NWJS/Chromium version as GUI framework, maybe that can help here... Additionally or alternatively you could try manually setting a smaller memory setting https://krpano.com/docu/xml/#memory E.g. Source code 1 <memory maxmem="400" devices="desktop" /> That might be able to help, but normally that shouldn't be necessary... I think the core problem would be more between the NWJS framework and your G...

Wednesday, April 1st 2020, 10:39am

Author: klaus.krpano

Custom tile urls - hotspot bug

Hi, thanks for reporting! That's numerical bug in the internal hotspot-hittesting code, at very small scales a value in the calculation gets very near to zero and a check for zero there is a bit inaccurate... That will be fixed soon in the next release (1.20.6). As workaround for the moment you could try using renderer="css3d" for the hotspots. That a different hotspot rendering and hit-testing will be used. Quoted these are crazy! scale values That's a very large 'pano' (134.217.728 x 134.217.7...

Tuesday, March 31st 2020, 5:30pm

Author: klaus.krpano

External ressources ( CORS ) step by step

Hi, please see here: https://enable-cors.org/server.html The .htaccess is for Apache web-servers, maybe you have a different one or another settings prevents that setting. Inside krpano normally nothing need to be done or set, enabling CORS is not krpano related. Best regards, Klaus

Tuesday, March 31st 2020, 5:26pm

Author: klaus.krpano

Graphic context lost! Please reload......

Hi, what GPU do you have? And is there an other GPU intensive application running at the same time? Best regards, Klaus

Tuesday, March 31st 2020, 5:19pm

Author: klaus.krpano

Wait till multi res tiles are loaded

Hi, use the PRELOAD flag: https://krpano.com/docu/actions/#loadpano.flags Maybe also just try the vtourskin.xml build-in 'autotour' feature - it autorotates the panos and after one round rotation it preloads the next pano and then blends to it. To enable it: Source code 1 <skin_settings ... autotour="true" ... /> Best regards, Klaus

Tuesday, March 31st 2020, 5:15pm

Author: klaus.krpano

ifnot( vs if(!

Hi, the 'ifnot' action is from a time when there were no operators supported. It has been removed the documentation, but it still keeps working and be supported. The effort for supporting it minimal, internally the ifnot action is simply mapped to the if action with the true/false actions swapped: Source code 1 ifnot(condition,trueaction,falseaction) => if(condition,falseaction,trueaction) That means no reason or need to change or convert anything. Best regards, Klaus

Thursday, March 26th 2020, 8:41pm

Author: klaus.krpano

Sync (Comparison) Plugin - Different Headings?

Hi, you could use the image.prealign setting: https://krpano.com/docu/xml/#image.prealign E.g. to rotate the pano image 90 degree in horizontal direction: Source code 1 2 3 <image ... prealign="0|90|0"> ... </image> Best regards, Klaus

Thursday, March 26th 2020, 8:39pm

Author: klaus.krpano

krpano 1.20

Quoted In version 1.20 this no longer works. Sorry, but that's not true, there were no changes and there is no reason why url parameters shouldn't work anymore... Please post your example (in a separate thread), maybe you haven't enabled the parameter passing or the deeplinking setting.

Wednesday, March 25th 2020, 10:11pm

Author: klaus.krpano

KEEPVIEW only for hotspots - NOT for thumbs

Hi, in the vtourskin.xml: - copy the 'skin_loadscene' action and make an own one, e.g. named 'skin_loadscene_hotspot', - there use MERGE|KEEPVIEW in the loadscene call - in the 'skin_hotspotstyle_click' action call the new 'skin_loadscene_hotspot' action instead of the 'skin_loadscene' one Best regards, Klaus

Wednesday, March 25th 2020, 10:07pm

Author: klaus.krpano

Gyroscope wird nicht beim Aufruf des Panoramas/der Tour geladen

Ich konnte das Problem jetzt doch nachvollziehen. Der Fix - suche in der vtourksin.xml nach dieser Zeile: Source code 1 if(plugin[skin_gyro].isavailable == true AND view.vlookatrange == 180, und ersetzte sie damit: Source code 1 if(plugin[skin_gyro].isavailable == true AND (view.vlookatrange == 180 OR global.lpinfo.scene === xml.scene), Der Grund: während des Little-Planet-Intros ist die Sichtbereich limitiert - und bei einem limitiertem Sichtbereich (z.B. bei Teil-Panoramen) wird das Gyro-Icon ...

Wednesday, March 25th 2020, 9:01pm

Author: klaus.krpano

Gyroscope wird nicht beim Aufruf des Panoramas/der Tour geladen

Quoted from "tollube" Aber wie update ich die einzeln? Die vtourskin.xml der Tour mit der vtourskin.xml aus der aktuellen Version (z.B. im templates/xml/skin Verzeichnis enthalten) ersetzen. Falls aber bereits gesehen, kann eigentlich nur mehr der Browser-Cache, welcher noch die alte Datei gespeichert hat, schuld sein. In dem Fall auf iOS: [Einstellungen] => [Safari] => [Erweitert] => [Website-Daten] => die eigene Website suchen und per Swipe die Daten löschen.

Wednesday, March 25th 2020, 8:17pm

Author: klaus.krpano

Gyroscope wird nicht beim Aufruf des Panoramas/der Tour geladen

Aktualisiere auch die vtourskin.xml! Bzw. siehe hier die Release-Notes der Version 1.20: https://krpano.com/docu/releasenotes/?ve…05#vtourskinxml Quoted Fix: The gyro-icon wasn't showing up when the the little-planet-intro was enabled.

Wednesday, March 25th 2020, 8:05pm

Author: klaus.krpano

Gyroscope wird nicht beim Aufruf des Panoramas/der Tour geladen

Hi, das Problem ist eher seltsam und weder auf iOS noch auf Android nachvollziehbar. Was für eine krpano Version wird verwendet? Eventuell eine sehr alte? Schöne Grüße, Klaus

Friday, March 20th 2020, 4:43pm

Author: klaus.krpano

Error in krpanotools on digitalocean or other cloud server

Hi, that's not an error from krpano, that's from your shell... Here something similar: https://unix.stackexchange.com/questions…rror-unexpected Maybe the execute permissions are missing... Best regards, Klaus

Wednesday, March 18th 2020, 10:50am

Author: klaus.krpano

Convert Sphere Cube Droplet will nicht

Hi, bei Problemen bitte einfach die betreffenden Dateien schicken. Ich kann nur etwas beheben wenn es mir auch bekannt und nachvollziehbar ist. Schöne Grüße, Klaus

Monday, March 16th 2020, 8:30pm

Author: klaus.krpano

Convert Sphere Cube Droplet will nicht

Quoted from "neoman666" Vielleicht weiß ja Klaus etwas über dieses hier geschilderte Problem und kann eine Lösung anbieten. Sorry, aber ohne weitere Informationen oder einer entsprechenden nicht-funktionierenden Datei kann ich da nichts machen. Quoted Es gibt wohl einen relativ neue Kompressionsmöglichkeit, welche scheinbar noch nicht jede Applikation beherrscht. JPEG ist eigentlich ein Standartformat, kann man nicht nachträglich etwas inkompatibles hinzufügen... Schöne Grüße, Klaus