You are not logged in.

Search results

Search results 1-20 of 20.

Tuesday, May 19th 2020, 2:52pm

Author: stephnx

360 Video playback in normal play mode staggering in landscape view on iOS

UPDATE I've noticed that if the player bar is hidden the video playback is still fluent, even though it's updating the time. Therefore I made a change in the videointerface.xml so whenever the plain 360 video starts it will start with the player bar hidden, when you tap on the screen the player bar shows but also pauses the video (since the bar is only needed to seek time in the timeline). After you press play, the player bar hides instantly. It's a compromise but at least the customer can use t...

Monday, May 18th 2020, 3:21pm

Author: stephnx

360 Video playback in normal play mode staggering in landscape view on iOS

UPDATE krpano at version 1.20.6 So after a few hours I found the cause of the problem but no solution to it: The lags are coming from the videointerface.xml skin, but only if the video time is updating, so if I call the "skin_video_setup()" method (see bellow). I'm using the bellow code for about 5 years now and worked just fine (except that I was using the old skin 1.18 where there were 2 different methods to initialize the playback skin), but if anybody notices a problem with the bellow code p...

Friday, May 15th 2020, 5:02pm

Author: stephnx

360 Video playback in normal play mode staggering in landscape view on iOS

Hello everyone, I have a cordova 9 iOS app which plays 360 videos with Krpano WebVR player. Everything plays nice except in normal player mode if I turn the device to landscape the whole playback start's to stagger. Switching to stereo becomes fluent or turning the device back to portrait also completely fluent. If somebody knows a solution I would much appreciate! Thank you.

Monday, January 20th 2020, 10:02am

Author: stephnx

Strange Things in iOS

Thank you very much Klaus for the help!!

Friday, January 17th 2020, 3:42pm

Author: stephnx

Strange Things in iOS

Dear Klaus, I found two of the similar issues reported in the forum so I answered them both in case somebody finds one or another. The solution for the issue, but I don't know how this will affect 360 video playback: when you open the inappbrowser you must set the option "mediaPlaybackRequiresUserAction=yes". I have Cordova 9, latest inappbrowser. I'm opening a WebVr scene with hotspots, everything works as expected, but once you are clicking on the button to Enter VR, first the krpano settings ...

Friday, January 17th 2020, 3:14pm

Author: stephnx

VR and iOS inApp Browser - strange popup

I found a solution for the issue but I don't know how this will affect 360 video playback! when you open the inappbrowser, add the option "mediaPlaybackRequiresUserAction=yes". This will disable the audio player to pop up, but still this is a KrPano issue which must be fixed, specially that I'm not using any audio plugin for krpano or anywhere else and still get this popup...

Friday, January 17th 2020, 2:31pm

Author: stephnx

Strange Things in iOS

Yes I have the same issue! Black background and white square overlaying the VRTour. If you tap on this overlay it shows that it is the native audio player of iOS trying to play a sound. If anybody has a solution please post!

Friday, January 17th 2020, 2:07pm

Author: stephnx

VR and iOS inApp Browser - strange popup

Quoted from "Taury" I'm having a strange problem with VR if called from within an iOS inAppBrowser. krpano with VR works fine within the default iOS browser (and it works fine on Android and the Android app). However, when "webvr.enterVR();" is triggered from within an iOS inAppBrowser (iOS 10), it opens an additional 2nd window, playing an unknown media file (maybe an empty sound file... I have no idea WHAT it is... but it's using a player interface). The 2nd window has to be closed manually, ...

Tuesday, December 11th 2018, 11:46am

Author: stephnx

Keep Layer alpha value when Hotspot alpha is changing

Hi all, I have a hotspot parented to a layer, I would like to keep the alpha of the layer and only change the hotspot alpha. I've tried with mergedalpha="false" but no difference. Could somebody suggest a solution. Thank you!

Tuesday, November 20th 2018, 11:55am

Author: stephnx

Get Hotspot onClick by code

I also needed this, to be able to toggle the onclick event from code. You can achieve this based on the documentation: callwith(hs,onclick); - Note: you have to remove the (); If you want to have the effect from external javascript: krpano.call("callwith(hotspot["+hs+"], onclick);");

Thursday, September 15th 2016, 5:29pm

Author: stephnx

VR video is opening in iOS 10 native video player

Dear Klaus, Thank you very much for the help you are providing! I also taking the chance to thank you for the hard work you investing into krpano to make it as suitable as possible for us! For others who might read this post, based on the solution provided by Klaus, I changed manually inside Cordova InappBrowser iOS source CDVInAppBrowser.m file the line into: self.allowinlinemediaplayback = YES; (since the <preference name="AllowInlineMediaPlayback" value="true" /> in config.xml is completely i...

Thursday, September 15th 2016, 11:38am

Author: stephnx

VR video is opening in iOS 10 native video player

Dear Klaus, I'm having an ios/android 360 video solution running on a hybrid app's inAppBrowser. Till iOS 10 everything was fine, but as you know on iOS 10 the app was crashing. I installed the pr7 release which runs on iOS9 and Android, but on iOS 10 the video is also opened by the native 2d video player, though I can notice that is still running in the webview too. I made some digging and I came to the conclusion the the issue is coming from the new videoplayer.js file from pr7, since if I'm r...

Tuesday, September 22nd 2015, 11:04am

Author: stephnx

is it possible to make 360 video live streaming?

While I had problems playing streaming videos on iPhone6 but not on iPads, since I updated to iOS9 now even iPad is not playing the videos at all. It seams that this is an iOS problem: https://discussions.apple.com/thread/7216194

Friday, June 26th 2015, 1:19pm

Author: stephnx

Video Controls in 1.19 pr2

Dear Klaus thank you for your help!! It works now. What I did is that I modified the start.xml <scene name="video_scene" onstart="plugin[video].play();videointerface_videoready();videointerface_setup_interface(); setup_video_controls();"><include url="%SWFPATH%/skin/videointerface.xml" /> Then since everything was working except the playback control I had to add manual the name of the Video Plugin inside the videointerface.xml's "videointerface_setup_interface"=>set(videointerface_video, 'Video'...

Wednesday, June 24th 2015, 12:12pm

Author: stephnx

Video Controls in 1.19 pr2

Hi Klaus, thanks for the comments! I managed to fix the scale issue. About the disappearing of the video control: I attached the dynamically generate video.xml by the app and indeed there is <image><sphere url="plugin:video" /></image> but I guess this should not be removed. This is a small video to illustrate the effect: link As you can see it doesn't hides the controls, it's more like it would overlap.. Thank you!

Tuesday, June 23rd 2015, 1:12pm

Author: stephnx

Video Controls in 1.19 pr2

Hi Klaus, I'm having a mobile implementation of your plugin for 360 and VR playback for offline and online view. The way how I'm trying to make the videointerface to show is as follow: - Inside webvr.xml I copied the '<action name="setup_video_controls">....</action>' - In the video.xml i'm icluding the videointerface.xml - In the webvr.xml's webvr_onavailable action I'm calling setup_video_controls(); videointerface_videoready(); The results is that the video control interface pops up, then hid...

Tuesday, June 23rd 2015, 10:15am

Author: stephnx

Video Controls in 1.19 pr2

Can someone at least tell me if it should work or not in 1.19 r2?

Wednesday, June 17th 2015, 8:27am

Author: stephnx

Video Controls in 1.19 pr2

Hello everyone! can someone point me to an example where I could see the way to implement video controls for 360/VR mods in 1.19? I have tried 1.18 xml "way" implementations but unfortunately the controls are popping up and then disappearing after the video is displayed. Thanks.

Tuesday, June 9th 2015, 1:37pm

Author: stephnx

VR native app

Is this implementation also works for videos or just for static images? Thanks!

Wednesday, April 15th 2015, 10:22am

Author: stephnx

Dragging, Gyro2 and Zooming in 360 Videos

Hi All, can somehow give me a hint on how to enable Dragging, Zooming and Gyro in the same time in the 360 videos? The problem I'm facing is that once I add the Gyro plugin in the webvr, it will overwrite the dragging functionality. Zooming is not working also Thank you!