You are not logged in.

Search results

Search results 1-9 of 9.

Friday, March 27th 2020, 12:57pm

Author: aperture147

Cannot enable WebVR on Chrome while embeding by iframe

I'm having a problem using WebVR on Chrome browser. Whenever I open a webpage (like this page) which embed another webpage (in this case, I embed this page) containing a Krpano tour, the VR button disappear and this log is printed in the console: This problem doesn't happen on Firefox browser. How can I fix this problem? Thanks!

Monday, March 16th 2020, 2:57pm

Author: aperture147

`oniphonefullscreen` event doesn't work on iPhone XS

The event `oniphonefullscreen` doesn't work on iPhone XS, I also tried on big variants of iPhone like 6S+, 7+ and 8+ and it works flawlessly. XS also has a big variant is XS Max but both of them show the URL bar and tab bar. I checked the `display.iphonefullscreen` variables and it's always zero. I'm using KRPano 1.20.5 and iOS 13.3

Tuesday, December 3rd 2019, 10:52am

Author: aperture147

STL file exported from Blender doesn't show correctly

Hi guys! I'm having some trouble while using depthmap with blender. The STL file exported from Blender is inverted so I tried to correct it by set the scale of the depthmap equal "-1.0", but that made the whole scene inverted, which can easily correct by flipping the image. After all, the depthmap still doesn't match correctly with the scene. Below is a simple scene of a room with a singe box in the corner. This is the URL to download the demo scene. The file is heavy (>600KB) so I cannot add it...

Thursday, June 27th 2019, 4:10pm

Author: aperture147

Is there any efficient way to clear all children of a layer/ScrollArea?

I'm making a ScrollArea layer which needs to update its content frequently. I find that there is no function to remove all of children of the scrollarea and layer in general. My workaround way is removing the layer (which can remove its children too) and recreate a new one then add the new content to it, but this way is too long. Thanks for your helping.

Friday, April 12th 2019, 5:06am

Author: aperture147

+1 if you keep refreshing krpano.com/news/ every hour a day :)

+100, because I've just found this thread a minute ago Bless Klaus and people in the forum!

Friday, April 12th 2019, 5:04am

Author: aperture147

"onpreviewcomplete" events doesn't work right

Quoted from "spacerywirtualne" Quoted from "aperture147" I'm sorry for copying that idea without your permission I understand the difficulty of inventing a new module, so I will change it as soon as I can. Hope my virtual tour will inspire you some ideas. I am not angry. You don't have to change anything. It's a good help animation and you can use it. Piotr Thanks for your generous! It will be nice if you gonna check our main product in House3D website . I'm not advertising, I just thought this...

Thursday, April 11th 2019, 7:27am

Author: aperture147

"onpreviewcomplete" events doesn't work right

Quoted from "spacerywirtualne" Hi aperture147 I am always proud when my small ideas are copied by others. Your help module reminds me of the one I invented for my VT Builder and cms4vr templates. Maybe you can change graphics so that users can not guess I'll take a look at your projects, maybe something will inspire me... Welcome to the forum, where we all respect each other. Piotr I'm sorry for copying that idea without your permission I understand the difficulty of inventing a new module, so ...

Wednesday, April 10th 2019, 6:07am

Author: aperture147

"onpreviewcomplete" events doesn't work right

Hi Klaus and your team! I'm having a question, or it's maybe a bug of your software. In this showcase, I use the "onpreviewcomplete" to hide the loading screen, which is a html code outsite of krpano. It works pretty well in good internet connection, but sometimes or in a poor connection, the loading screen was hidden before the preview images be loaded. I tested in both CDN-based and not CDN-based images and got the same result. You can recreate that situation by throtling the connection using ...