Sie sind nicht angemeldet.

1

Freitag, 22. Januar 2010, 11:37

Only one thumbnail is showing

Hello Klaus or any expert,

I am a newbie and this is the situation:

I have 8 pano in a tour and wanted to show a thumbnail on the left side in 4 columns by 2 rows. The result is only showing only one which is the last pano. Btw the code is generated by Autopano Tour 1.1 beta6. I just copy and pasted the code below. I can not show the html because I do not have a domain yet and I am working offline.

Thank you very much for your kind analysis and best regards.
Manuel.

Source Code:

<krpano version="1.0.8" logkey="false">

<include url="54f0.xml"/>
<plugin name="data" keep="true"/>
<textstyle name="DEFAULT" alpha="1" bold="false" font="Arial" fontsize="16" italic="false" textcolor="0xff000000"/>

<plugin name="openfs" align="bottom" blendmode="screen" keep="true" onclick="set(fullscreen,true);" onout="set(blendmode,screen);" onover="set(blendmode,add);" url="54fdata/graphics/menu/menu0.png" x="-20" y="10"/>
<plugin name="closefs" align="bottom" blendmode="screen" keep="true" onclick="set(fullscreen,false);" onout="set(blendmode,screen);" onover="set(blendmode,add);" url="54fdata/graphics/menu/menu1.png" visible="flase" x="-20" y="10"/>

<events onenterfullscreen="set(plugin[openfs].visible,false); set(plugin[closefs].visible,true);" onexitfullscreen="set(plugin[openfs].visible,true); set(plugin[closefs].visible,false);"/>
<plugin name="autorotation" align="bottom" blendmode="screen" keep="true" onclick="switch(autorotate.enabled);" onout="set(blendmode,screen);" onover="set(blendmode,add);" url="54fdata/graphics/menu/menu2.png" x="20" y="10"/>

<action name="magnify">
tween(plugin[%1].alpha, 1.5, 0.3, easeInOutCubic);
set(plugin[%1].zorder,3);
tween(plugin[%1].scale, 1.05, 0.3, easeInOutCubic);</action>
<action name="lie">
tween(plugin[%1].alpha, 0.8, 0.3, easeInOutCubic);
set(plugin[%1].zorder,2);
tween(plugin[%1].scale, 1, 0.3, easeInOutCubic);</action>
<action name="slide_action_in">
tween(plugin[slide].x,450,1,easeOutQuint, set(plugin[slide].onover,); );</action>
<action name="slide_action_out">
tween(plugin[slide].x,0,1,easeOutQuint, set(plugin[slide].onover,action(slide_action_in);); );</action>

<plugin name="slide" keep="true" zorder="0" url="54fdata/graphics/slide.png" visible="true" enabled="true" handcursor="false" capture="false" children="true" alpha="0.8" blendmode="normal" smoothing="true" x="0" y="0" scale="1" align="left" edge="right" ox="0" oy="0" width="450" height="100%" rotate="0" scale9grid="" crop="" mask="" onloaded="" onover="action(slide_action_in)" onhover="" onout="action(slide_action_out)" ondown="" onup="" onclick="action(slide_action_out)"/>
<plugin name="strap" keep="true" zorder="0" url="54fdata/graphics/strap.png" parent="slide" scale="1" align="right" edge="left" alpha="1.0" handcursor="false" onclick="action(slide_action_out)"/>

<plugin name="54f0" keep="true" zorder="2" url="54fdata/54f0/preview.jpg" parent="slide" scale="1" width="22.2222%" height="prop" align="right" edge="center" x="13.3333%" y="-13.0556%" alpha="0.8" ondown="loadpano(54f0.xml,NULL,NULL,BLEND(1));" onup="" onover="action(magnify,54f0); " onhover="showtext(54f0,DEFAULT);" onout="action(lie,54f0);"></plugin>
<plugin name="54f1" keep="true" zorder="2" url="54fdata/54f1/preview.jpg" parent="slide" scale="1" width="22.2222%" height="prop" align="right" edge="center" x="13.3333%" y="13.0556%" alpha="0.8" ondown="loadpano(54f1.xml,NULL,NULL,BLEND(1));" onup="" onover="action(magnify,54f1); " onhover="showtext(54f1,DEFAULT);" onout="action(lie,54f1);"></plugin>
<plugin name="54f2" keep="true" zorder="2" url="54fdata/54f2/preview.jpg" parent="slide" scale="1" width="22.2222%" height="prop" align="right" edge="center" x="37.7778%" y="-13.0556%" alpha="0.8" ondown="loadpano(54f2.xml,NULL,NULL,BLEND(1));" onup="" onover="action(magnify,54f2); " onhover="showtext(54f2,DEFAULT);" onout="action(lie,54f2);"></plugin>
<plugin name="54f3" keep="true" zorder="2" url="54fdata/54f3/preview.jpg" parent="slide" scale="1" width="22.2222%" height="prop" align="right" edge="center" x="37.7778%" y="13.0556%" alpha="0.8" ondown="loadpano(54f3.xml,NULL,NULL,BLEND(1));" onup="" onover="action(magnify,54f3); " onhover="showtext(54f3,DEFAULT);" onout="action(lie,54f3);"></plugin>
<plugin name="54f4" keep="true" zorder="2" url="54fdata/54f4/preview.jpg" parent="slide" scale="1" width="22.2222%" height="prop" align="right" edge="center" x="62.2222%" y="-13.0556%" alpha="0.8" ondown="loadpano(54f4.xml,NULL,NULL,BLEND(1));" onup="" onover="action(magnify,54f4); " onhover="showtext(54f4,DEFAULT);" onout="action(lie,54f4);"></plugin>
<plugin name="54f5" keep="true" zorder="2" url="54fdata/54f5/preview.jpg" parent="slide" scale="1" width="22.2222%" height="prop" align="right" edge="center" x="62.2222%" y="13.0556%" alpha="0.8" ondown="loadpano(54f5.xml,NULL,NULL,BLEND(1));" onup="" onover="action(magnify,54f5); " onhover="showtext(54f5,DEFAULT);" onout="action(lie,54f5);"></plugin>
<plugin name="54f6" keep="true" zorder="2" url="54fdata/54f6/preview.jpg" parent="slide" scale="1" width="22.2222%" height="prop" align="right" edge="center" x="86.6667%" y="-13.0556%" alpha="0.8" ondown="loadpano(54f6.xml,NULL,NULL,BLEND(1));" onup="" onover="action(magnify,54f6); " onhover="showtext(54f6,DEFAULT);" onout="action(lie,54f6);"></plugin>
<plugin name="54f7" keep="true" zorder="2" url="54fdata/54f7/preview.jpg" parent="slide" scale="1" width="22.2222%" height="prop" align="right" edge="center" x="86.6667%" y="13.0556%" alpha="0.8" ondown="loadpano(54f7.xml,NULL,NULL,BLEND(1));" onup="" onover="action(magnify,54f7); " onhover="showtext(54f7,DEFAULT);" onout="action(lie,54f7);"></plugin>


</krpano>

2

Freitag, 22. Januar 2010, 11:47

Hi,

the "name" of an element in krpano must begin with an alphabetic character!

when a numeric character is used as first character, then the name will be
interpreted as "index", in your case now always "54", therefore only one thumbnail,

I don't know why everything starts with "54f" in your example, but try just adding
an alphabetic character in front of it (e.g. "x54f") then it will work,

best regards,
Klaus

3

Sonntag, 24. Januar 2010, 18:21

Hi Klaus,

Now I've leraned this rule and it works ok. Thank you very much for your time and advise. Best regards.

Manuel

Ähnliche Themen