You are not logged in.

1

Friday, April 23rd 2010, 4:33pm

flatimage hotspot probs

Moin zusammen, ich bastel schon eingie zeit an ner tour herum und möchte die tour mit nem mulit res falt image beginnen lassen und diese mit hotspots verlinken...die hotspot_ani.swf verstecken sich nur immer hinter dem flatimage.. wenn ich die darstellung auf sphere ändere läuft alles ...nur das flatimage wird verzerrt. weiß vlt. jmd nen tip ????

lg carlo

2

Thursday, April 29th 2010, 11:31am

Hi,

kannst du eventuell die <hotspot> Einstellungen posten?

ein Flat Pano wird mit hfov="1.0" definiert,
d.h. im Prinzip ein sehr kleines Pano,

wird dann beim hotspot - distorted="true" oder zoom="true" - verwendet,
dann müssten für "scale" sehr kleine Werte verwendet werden, sonst kann
der Hotspot ziemlich groß werden,

Schöne Grüße,
Klaus

3

Sunday, May 9th 2010, 1:27pm

Danke Klaus das hab ich jetzt hinbekommen

<!-- flatstart -->

<!-- first Startbild/pano -->
<scene name="Startbild" onstart="action(startscene);">

<action name="startscene">
showtext(, infostyle);

</action>

<plugin name="mapmask" url="pano1_mapmask.png" parent="map" enabled="false" onloaded="updatemask();" />


<view hlookat="0" vlookat="0" maxpixelzoom="1.0" />
<display details="22" />

<preview type="CYLINDER" url="Startbild.tiles/preview.jpg" />

<image type="CYLINDER" hfov="1.00" multires="true" tilesize="504">
<level tiledimagewidth="6048" tiledimageheight="4032">
<cylinder url="Startbild.tiles/l3_%0v_%0h.jpg" />
</level>
<level tiledimagewidth="3024" tiledimageheight="2016">
<cylinder url="Startbild.tiles/l2_%0v_%0h.jpg" />
</level>
<level tiledimagewidth="1512" tiledimageheight="1008">
<cylinder url="Startbild.tiles/l1_%0v_%0h.jpg" />
</level>
</image>



<hotspot name="spot2" url="hotspot_ani.swf" ath="0" atv="0" scale="0.01" zoom="true"
alpha="2.3"
onover="tween(alpha,2);tween(scale,0.0120);"
onout="tween(alpha,2);tween(scale,0.0100);"
onclick="looktohotspot(spot2); loadscene(scene4, null, MERGE, BLEND(1));"
/>


<!-- LOADING SCREEN -->
<progress showwait="none" showload="bar(center,180,1,0%,10%,shaded,0x000000,0xd1d1d1,0xAAAAAA)"/>
<events onloadcomplete="set(plugin[previewimage].visible,false);" />


Nur jetzt wollte ich diesen duplizieren und mit ath u atv die pos. ändern und der hotspot verschwindet=(

Wäre nett wenn du mir verräts wie ich das hinbekomme.

lgs
carlo

4

Monday, May 10th 2010, 1:26pm

Hi,
Nur jetzt wollte ich diesen duplizieren und mit ath u atv die pos. ändern und der hotspot verschwindet=(
hat der neue Hotspot einen anderen "Namen"?
sind die ath/atv nicht zu groß? beim hfov="1.0" müssen die auch entsprechend klein sein,
ath="1.0" wäre z.B. schon außerhalb des sichtbaren Bereichs,

Schöne Grüße,
Klaus

5

Monday, May 10th 2010, 2:25pm

DU BIST EIN KÖNIG! *smile* *smile* *smile*

Similar threads