You are not logged in.

1

Thursday, May 6th 2010, 5:49pm

kprotect bettet kubische Bilder nicht ein

Hallo,
obwohl in kprotect im Tab "Embedding" die 6 kubischen Bilder drinnen stehen, verlangt das ausgegebene swf file (wo ALLES eingebettet worden sein sollte) beim Öffnen nach den Files die auf dem Desktop liegen sollten.
Wenn ich die Bilder auf den Desktop lege, dann klappt das Pano. Jedoch hat das swf file eine Dateigröße die vermuten lässt, dass die Bilder dort auch eingebettet worden sind.

Ich weiß, dass ich es auch schon geschafft habe, alles komplett ins swf zu packen, nur schaff ich es momentan nicht.

Gruß Marc

2

Friday, May 7th 2010, 12:10pm

Hi,

wie sehen die Pfade im Embedding Tab aus?
was für Fehlermeldungen kommen dann im Viewer?

Schöne Grüße,
Klaus

3

Friday, May 7th 2010, 1:56pm

Hallo,
im konkreten Fall sieht es so aus wie im Anhang.

Wie du siehst, die Startxml ist die tour.xml und aus der wir ddann per swfpath die allgemein geladen und von der dann die einzelpano (wo auch menü etc. drinnen ist). das funktioniert alles einwandfrei.

Auch wenn ich die kubischen Bilder direkt unterhalb der tour.xml sortiere, selbe symptome.

Gruß
MarcW. has attached the following images:
  • embed.gif
  • error.gif

4

Friday, May 7th 2010, 10:05pm

Hi,

da bräuchte ich noch mehr Informationen (am besten alles , um wirklich sagen zu können wo das Problem ist),

funktioniert das Panorama in der Form wenn es direkt aufgerufen wird? (also ohne kprotect),
wurden die Panoramabilder automatisch hinzugefügt oder nachträglich?
wie lautet der XML Pfad in der HTML?
wie lauten die Pfade in der XML?

Schöne Grüße,
Klaus

5

Friday, May 7th 2010, 11:33pm

Hallo Klaus,
Panorama funktioniert einwandfrei wenn ich es normal (ohne kprotect) aufrufe.
Das ganze hab ich mit dem "Make Pano (normal) droplet.app" erstellt, welches ich jedoch an meine Bedürfnisse angepasst habe.

In der panorama.html wird das ganze so aufgerufen:

Quoted

var swf = createswf("file:///Macintosh HD/Users/Marc/Panoramafotografie/Pano Sonstiges/krpano_neueste/krpano.swf", "krpanoSWFObject", "100%", "100%");

swf.addVariable("xml", "tour.xml");
Die tour.xml schaut so aus:

Quoted

<krpano onstart="processactions();" actionintervalbase="timer" logkey="true">
<include url="%SWFPATH%/einzelpano.xml"/>

<view hlookat ="9"
vlookat ="27"
fov ="90.000000"
/>

<preview type="CUBESTRIP" url="kubische/preview.jpg" />

<image type="CUBE" multires="true" tilesize="4000">
<level tiledimagewidth="1300" tiledimageheight="1300">
<left url="kubische/pano_l.jpg" />
<front url="kubische/pano_f.jpg" />
<right url="kubische/pano_r.jpg" />
<back url="kubische/pano_b.jpg" />
<up url="kubische/pano_u.jpg" />
<down url="kubische/pano_d.jpg" />
</level>
</image>

</krpano>
und dann die einzelpano.swf beginnt so und lädt dann die navigation (die korrekt eingebettet wird im swf):

Quoted

<krpano version="1.0.8">
<include url="%SWFPATH%/allgemein.xml"/>
und in der allgemein.xml hab ich dann noch lensflare und editor und options plugins, die auch korrekt eingebettet werden,
ansonsten für mich nichts auffälliges...

Gruß Marc

6

Friday, May 7th 2010, 11:43pm

auch diese einfache Einbindung hat nicht geklappt (Bilder sind natürlich direkt im Verzeichnis der tour.xml gelegen)

Quoted

<krpano actionintervalbase="timer" logkey="true">

<view hlookat ="9"
vlookat ="27"
fov ="90.000000"
/>


<preview type="CUBESTRIP" url="kubische/preview.jpg" />

<image type="CUBE" multires="true" tilesize="4000">
<level tiledimagewidth="1300" tiledimageheight="1300">
<left url="pano_l.jpg" />
<front url="pano_f.jpg" />
<right url="pano_r.jpg" />
<back url="pano_b.jpg" />
<up url="pano_u.jpg" />
<down url="pano_d.jpg" />
</level>
</image>

</krpano>

7

Monday, May 10th 2010, 3:14pm

Hi,

biete versuche hier einmal einen relativen Pfad:

Source code

1
var swf = createswf("file:///Macintosh  HD/Users/Marc/Panoramafotografie/Pano  Sonstiges/krpano_neueste/krpano.swf",



ansonsten sehe ich eigentlich kein Problem...

könntest du mir das erzeugte SWF noch schicken,
dann kann ich einmal 'rein-schauen' und dann eventuell mehr sagen

Schöne Grüße,
Klaus

8

Monday, May 10th 2010, 3:32pm

Hallo Klaus,
ich hab jetzt nochmal alle benötigte Dateien in einen Ordner gespielt und die Pfade nochmal relativ gesetzt und siehe da - es klappt!

Schade, dass ich das nun immer so machen muss, vielleicht lässt sich das für dich in kprotect ja einfach ändern?

Denn ich habe einen Ordner (krpano_neueste) dort liegt dann die krpano.swf und der ganze skin. Wenn ich dort eine Änderung mache, wird das in allen meinen Panoramen lokal geändert - wär natürlich fein, wenn für kprotect die dateien und pfade nicht wieder zusammenkkopieren müsste, was jedoch auch kein großes Problem darstellt ;-)

Lg Marc