You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

101

Tuesday, February 24th 2009, 1:08pm

It don't want work on Mac *cry*

102

Tuesday, February 24th 2009, 1:30pm

It don't want work on Mac *cry*
Hi, what does not work?
did you get any error messages?

which Mac OSX version do have you?
I have only OS X 10.4 but there everything works...

103

Tuesday, February 24th 2009, 3:46pm

Sorry again Klaus
I am not awake today, all work well and a special thank for Krpano protect *thumbsup* *thumbsup* *thumbsup*

104

Tuesday, February 24th 2009, 5:56pm

hi, i'd like to say thank you for new beta version at first :)
and i have one question: is the AS3 Interface for krpano 1.0.7 compatible with 1.0.8? seems to be but..

spacerywitualne

Professional

Posts: 866

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

105

Tuesday, February 24th 2009, 9:40pm

HI Klaus

We made tests and we got something like this.

1.0.8-beta5



1.0.8-beta6




*cry* *cry*

How to repair this *question*

Pietero & Pablo
spacerywirtualne.pl teem
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*

Graydon

Professional

Posts: 614

Location: Texas

Occupation: Industrial gas turbine services.

  • Send private message

106

Wednesday, February 25th 2009, 8:25am

1.0.8b6 plugin ox/oy orientation

When doing this sample... http://testsite.marlincreek.com/demo/xmlscroll/ ...

... the plugin oy seemed to be working backwards.

I had to use this...

Source code

1
2
3
	<action name="thumb_onover">
		set(plugin[%1].oy,-5);
	</action>


... with the -5 in order to get the image to move "UP" even though the origin / edge is bottom.

The ox seems to be acting as I would expect it to.

Zephyr

Professional

Posts: 994

Location: Netherlands

Occupation: Web developer

  • Send private message

107

Wednesday, February 25th 2009, 8:32am

Are these events added in this beta?

Quoted

I've planned to add new events in the next version,
e.g.
"onxmlcomplete" - when the xml was loaded, and krpano is ready for new loadpano calls
"onviewcomplete" - when the loading of the current view was done, can be used for multiresolution panoramas,
"onloadcomplete" - when loading of the whole panorama was complete (for normal panoramas)
Regards,
Zephyr
3d childrens game using krpano Game
Minify your xml with my krpano XML Compressor
Krpano XML Parsing Error Checklist
Available for hire (krpano xml, javascript, actionscript, flash, php and ipad plugins).

108

Wednesday, February 25th 2009, 10:12am

hi, i'd like to say thank you for new beta version at first :)
and i have one question: is the AS3 Interface for krpano 1.0.7 compatible with 1.0.8? seems to be but..
Hi,

yes, the AS3 interface is upward compatible

109

Wednesday, February 25th 2009, 10:17am

HI Klaus

We made tests and we got something like this.

*cry* *cry*

How to repair this *question*

Pietero & Pablo
spacerywirtualne.pl teem
Hi,

thanks for finding this bug!
this was a side-effect of the new ox/oy/rotate parameters and the changed position calculation
here is a fixed version: krpano_swf.zip

I'll do some additional tests and then integrate it in the normal download package.

EDIT: the bugfix is now integrated in the normal beta download package!

110

Wednesday, February 25th 2009, 10:22am

... the plugin oy seemed to be working backwards.
the ox/oy parameters are not related to the origin/align parameter like the x/y parameters,
they work always the same: -x = left, +x =right, -y = up, +y = down

note - the ox/oy can be also used for hotspots,
and together with rotate and % values for x/y or ox/oy same interesting effects are possible

btw - great work with the xml driven thumbnails

111

Wednesday, February 25th 2009, 10:26am

Are these events added in this beta?



Quoted

I've planned to add new events in the next version,
e.g.
"onxmlcomplete" - when the xml was loaded, and krpano is ready for new loadpano calls
"onviewcomplete" - when the loading of the current view was done, can be used for multiresolution panoramas,
"onloadcomplete" - when loading of the whole panorama was complete (for normal panoramas)
Regards,
Zephyr
Hi,

in this beta - "onpreviewcomplete" and "onloadcomplete" are implemented
(onxmlcomplete would be near the same like onstart, but will be added soon anyway)

e.g. - for testing:

Source code

1
2
3
<events onpreviewcomplete="trace(onpreviewcomplete);"
        onloadcomplete="trace(onloadcomplete);"
        />


best regards,
Klaus

112

Wednesday, February 25th 2009, 6:11pm

Hi,

the next beta version is ready - 1.0.8 beta 6

- <plugin>/<hotspot> - ox/oy - addtional x/y offset, % values can be used and they are relative to the own size
- <plugin>/<hotspot> - rotate - rotation in degrees
- <plugin></hotspot> - enabled - enable/disable all plugins or hotspots globally - "hotspot.enabled", "plugin.enabled"
Hi, Klaus !

I was hopping that 1,0,8 beta 6 would be ok to fix this problem (Use a plugin as a hotspot...), but it doesn't seems...

My map can't still be placed with spherical coordinates when I name it
"plugin" instead of "hotspot", and my mappoints are still not turning
with my map... or is it because I don't know the way to use it ?

Regards,



David

113

Wednesday, February 25th 2009, 9:56pm

Hi all,

I've updated the beta 6 version: (please download again)
- the align bug was fixed
- and in the kmakemultires tool a bug regarding partial panoramas was fixed

best regards,
Klaus

114

Wednesday, February 25th 2009, 10:00pm

I was hopping that 1,0,8 beta 6 would be ok to fix this problem (Use a plugin as a hotspot...), but it doesn't seems...

My map can't still be placed with spherical coordinates when I name it
"plugin" instead of "hotspot", and my mappoints are still not turning
with my map... or is it because I don't know the way to use it ?
Hi, that's possible now
declare the map and the spots as <hotspot> with the same ath/atv values,
and align the spots via the ox/oy parameters,

this is not the best way (a child<=>parent system for plugins and hotspots is in work),
but it's possible now

best regards,
Klaus

115

Wednesday, February 25th 2009, 10:07pm

Ok, I'll try !
Thanks ;) !

116

Wednesday, February 25th 2009, 11:59pm

Ok, I tried... :(

Source code

1
2
3
4
5
6
7
8
9
10
<hotspot name="spotx" url="../../images/mappoint_bleu.png" keep="true" 
			zorder="4" origin="bottom" 
			ath="0" atv="90"
			x="200" y="200" 
			scale="0.55" zoom="true" 	
			alpha="1" handcursor="true" 
        	width="12" height="12" 
			onhover="showtext(Eiffel);"
			onclick="action();"
			/>


I thought it was like this... but I must be wrong...
Sorry

Graydon

Professional

Posts: 614

Location: Texas

Occupation: Industrial gas turbine services.

  • Send private message

117

Thursday, February 26th 2009, 4:07am

origin, x, y are not attributes of hotspots for placement... only the ath, atv are... and now the ox, oy for offsets.

With the offset x/y, I don't know if you can specify an edge (relative to the plugin image)... or if the offsets are always taken from a center point.

This post has been edited 1 times, last edit by "Graydon" (Feb 26th 2009, 4:43am)


118

Thursday, February 26th 2009, 10:03am

Hi,

yes, ox/oy must be used instead of x/y,
at the moment they are only relative to the hotspot center

119

Thursday, February 26th 2009, 12:49pm

Ok, that's it ! Great !

martyhr

Intermediate

Posts: 328

Location: CZ

  • Send private message

120

Thursday, February 26th 2009, 2:46pm

impossible to generate protected file

I have 3 files in the same folder - kprotect.exe,krpano.swf and krpano.licence ( my unlimited domain) and It is not possiblle to generate protected file.

Warning message:WARNING - licenses not found - DEMO MODE!

My license is recognised by kprotect.exe under "krpano Domain or Unlimited Domain License - "krpano.license" - third row.

What am I doing wrong? Do I need some other file with license? *confused*
Marty