You are not logged in.

Shanti

Intermediate

  • "Shanti" started this thread

Posts: 301

Location: Puerto Vallarta

Occupation: Web Developer

  • Send private message

1

Thursday, February 26th 2009, 8:25am

Combobox problems

ok I tried creating an xml with the combobox, and it didn't worked, so i whent into the examples folder, to test the combobox there and it didn't worked either..... i get this error

TypeError: Error #1010: A term is undefined and has no properties.
at Kqtvr/event_complete()
at flash.events::EventDispatcher/dispatchEventFunction()
at flash.events::EventDispatcher/dispatchEvent()
at krpano::krpano_plugin/loadurl_addedtostage()
at flash.display::DisplayObjectContainer/addChild()
at krpano::krpano_plugin/loadurl_done()

and then this one

ReferenceError: Error #1056: Cannot create property additem on String.
at combobox_fla::MainTimeline/registerEvent()
at flash.events::EventDispatcher/dispatchEventFunction()
at flash.events::EventDispatcher/dispatchEvent()
at krpano::krpano_plugin/loadurl_addedtostage()
at flash.display::DisplayObjectContainer/addChild()
at krpano::krpano_plugin/loadurl_done()

anyone know why this is happening? *confused*

the xml I am using is the same as in the combobox example.

also, using Krpano 1.0.8 b6
Thanks

Shanti

Intermediate

  • "Shanti" started this thread

Posts: 301

Location: Puerto Vallarta

Occupation: Web Developer

  • Send private message

2

Thursday, February 26th 2009, 8:27am

nevermind, re-downloded the beta 6 and it worked , but i get this error (or warning)

TypeError: Error #1010: A term is undefined and has no properties.
at Kqtvr/event_complete()

the pano loads and at the end i get the error....I wonder why?

3

Thursday, February 26th 2009, 10:21am

Hi,

Quoted

TypeError: Error #1010: A term is undefined and has no properties.
at Kqtvr/event_complete()
sorry, this was a small bug as result of the new added "onloadcomplete" event,
it was very new and I just forget to test it with QTVR files (that's why it's a beta )

here is a bugfixed version - krpano-108b6-20090226.zip

about the combobox error - did you maybe call additem() before the combobox plugin loaded? (onloaded)

best regards,
Klaus

Shanti

Intermediate

  • "Shanti" started this thread

Posts: 301

Location: Puerto Vallarta

Occupation: Web Developer

  • Send private message

4

Thursday, February 26th 2009, 7:52pm

Thanks for the bug fixed version, the problem with the combo boxes was that I was using the first b6, then I downloaded the next b6 release and it worked perfectly :)

Thanks