Sie sind nicht angemeldet.

1

Mittwoch, 9. Juni 2010, 17:22

problem bei texteinblendungen zwischen moveto`s

hallo,

ich versuche mich gerade am moveto - klappt auch.

jetzt wollte ich zwischen den einzelnen moveto`s text einblenden, doch nach der ersten texteinblendung war`s das und es moved nicht weiter.

sascha




<events onloadcomplete="action(kamera);" />
<action name="kamera">

moveto(0.0,45,linear(20));
moveto(45.0,45,linear(20));
showtext(get(data[infotext1].content), infostyle)
moveto(90.0,60,linear(20));
moveto(135.0,45,linear(20));
showtext(get(data[infotext2].content), infostyle)
moveto(180.0,45,linear(20));
moveto(225.0,45,linear(20));
showtext(get(data[infotext3].content), infostyle)
moveto(270.0,30,linear(20));
moveto(315.0,45,linear(20));

moveto(360.0,45,linear(20));
showtext(get(data[infotext4].content), infostyle)

</action>

<data name="infotext1"> Blindtext 1 </data>

<data name="infotext2"> Blindtext 2 </data>

<data name="infotext3"> Blindtext 3</data>

<data name="infotext4"> Blindtext 4 </data>



<textstyle name="infostyle"
origin="center" edge="center" yoffset="-39" textalign="center" background="false" border="false"
fontsize="40" textcolor="0xFFFFFF" bold="false" effect="glow(0xFFFFFF,0.7,4,2);glow(0x000000,1,4,2);dropshadow(3,45,0x000000,2,0.6);"
showtime="3.0" fadeintime="1.0" fadetime="1.0"
/>

2

Mittwoch, 9. Juni 2010, 17:29

Hi,

es fehlt der Strichpunkt ';' nach jedem showtext() Aufruf,

Schöne Grüße,
Klaus

3

Mittwoch, 9. Juni 2010, 18:13

danke klaus *g*

schön auch, dass es nur so ein dummer überseh-fehler war.

da ist die hoffnung noch nicht ganz verloren, das ganz mal zu kapieren!

sascha

Ähnliche Themen