You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

21

Saturday, March 28th 2009, 4:42am

Hi Lee,

Your ClearTour panos are pretty much smooth for me in Firefox, but even at the auto-rotate speed in IE7 they appear a bit hesitant and jerky. And I agree it doesn't seem to be a CPU issue.

Here's what I find really annoying:
http://www.panoramiques-photo.fr/amiens/

An equivalent sized FPP pano doesn't jerk in IE7 (at least for me).

ClearTours

Beginner

Posts: 18

Location: Naperville, IL USA

Occupation: Architectural Photographer

  • Send private message

22

Saturday, March 28th 2009, 5:06am

Hmmm.....

Sounds like you see a different jerking that what I see on my computer...

Just so I'm making an equal comparison... Is the Pano at http://www.panoramiques-photo.fr/amiens/ a tiled multi-resolution image? From what I know about FPP, it doesn't support Multi-res images right now (Go Klaus!!) All the Panos on my site at http://cleartours.com/portfolio are configured as tiled Multi-res images. Sorry if this is a repeat in the Thread, but perhaps the jerking you see in the FPP vs krpano is more of a tiled multi-res vs single-res image issue. (Just a thought)

Also, when debugging this problem, have you tried putting the krpano viewer within in a fixed size Div tag to see if the same jerking characteristics across all of the computers you have when the actual pixel dimensions are identical within the browser window?

Lee

---

Lee Evans
levans@cleartours.com

23

Saturday, March 28th 2009, 8:40am

If I turn off Flash 10 then I start seeing wavy lines and ripples in straight edges. So I'm stuck with 10 for now.


I have tested on my panoramas and with flash10 it behaviours the same like yours. But If I switch flash10 off I have smooth movings.
If you don't want to see wavy lines with flash9 you should set more details for example 24, or 32, because you have only 16 now, so in the edges there are distorsions.
For me below sets works fine, but if I turn to flash10 it's going bad.

Source code

1
2
3
4
5
6
7
8
9
10
<display fps="60"
          details="24"
          tessmode="auto"
          movequality="LOW"
          stillquality="HIGHSHARP"
          flash10="off"
          movequality10="HIGH"
          stillquality10="HIGH"
          stilltime="0.25"
          />


I think, we should not force the final user to change something in flash setup, or so. The people should turn the standard browser on and see fine panorama without thinking about setups.
Regards
G.

24

Saturday, March 28th 2009, 10:04am

Bazuki, I think you have solved the problem !

Turning off Flash 10 and upping the details gives a far better result ! So simple, yet it seems to work even on my old Matrox-powered P4 at 60fps.

Thanks very much *smile*

ps: By turning off the Flash 10 option does that mean that people with only Flash 9 installed can view it without being prompted to upgrade their Flashplayer ? Looking at the Adobe "installed base" figures they claim roughly 98% Flash9, but only 55% Flash 10 installed.

VN2009

Professional

Posts: 1,336

Location: Duluth MN

  • Send private message

25

Saturday, March 28th 2009, 3:29pm

no that just means you cannot utilitze the added features of flash 10 and the people who do have flash 10 are still viewing it in flash 9 quality.

26

Monday, March 30th 2009, 12:15am

Turning off Flash 10 and upping the details gives a far better result ! So simple, yet it seems to work even on my old Matrox-powered P4 at 60fps.
Hi, have you used a spherical pano?
for optimal Flash10 performance try using a cubical pano!

also read the Flash10 notes here:
http://krpano.com/forum/wbb/index.php?pa…tID=322#post322

for the final 1.0.8 version I have planned a framerate autodetection mode,
to switch automatically between Flash9 and Flash10 to get the best performance,

best regards,
Klaus

27

Monday, March 30th 2009, 1:22pm

I was using spherical and switched to cube. I like it much better. I can't notice any significant display difference so far as the user is concerned. Also it makes it much easier to patch the nadir !

With Flash 10 I really meant to ask that if I disable Flash 10 in the XML is the pano then viewable by people who just have flashplayer 9 installed ? I don't want to force people to install player 10. I have already had complaints about that.

And given all my issues with Flash 10 I'd be unhappy if I was unable to switch it off.

Zephyr

Professional

Posts: 994

Location: Netherlands

Occupation: Web developer

  • Send private message

28

Monday, March 30th 2009, 4:33pm

Im running a quadcore with 8g ram - 64bit OS.
With Flash 9 1680x1050 old graphicscard and hardware mode disabled (and lots of programs in de back ;p) I run @ 10%, when I start to turn, just a little bit, It jumps to 50% all cores.
Same settings with hardware mode enabled, No difference. Turning fast or real slow, doesn't make a difference in my performance.

When I look at the ground or the sky and turn, my fps increases compared to looking at the centre (logical, cause' there are more tiles in the centre).

I can't see any jerking. Hmm perhaps a tiny bit, when I move just real slow, it seems to speed up and slow down, speed up and slow down. But that can be optical illusion (the sides of a panorama are more distorted then the centre)
3d childrens game using krpano Game
Minify your xml with my krpano XML Compressor
Krpano XML Parsing Error Checklist
Available for hire (krpano xml, javascript, actionscript, flash, php and ipad plugins).

29

Saturday, April 4th 2009, 10:24am

With Flash 10 I really meant to ask that if I disable Flash 10 in the XML is the pano then viewable by people who just have flashplayer 9 installed ? I don't want to force people to install player 10. I have already had complaints about that.
Hi, you don't need to disable it, the flashplayer version will be detected automatically

nelk

Intermediate

Posts: 358

Location: Paris

  • Send private message

30

Wednesday, April 8th 2009, 11:27am

<display fps="60" details="24" tessmode="auto" movequality="LOW" stillquality="HIGHSHARP" flash10="off" movequality10="HIGH" stillquality10="HIGH" stilltime="0.25" />


Hi,

I'm having the same problem of jumping with my computeur.

With the settings above (flash v10 deactivated) the pan is smoother (less jump), but the quality of image is less good : the line are not straight anymore, there are made by small rectangle (I don't know the word to explain that in english)

The pano made on FPP I saw were most of the time better. It's probably because of the better default settings ... ?
VideoStitch, a video stitching engine / blog sur les visites virtuelles ( french ).

31

Wednesday, April 8th 2009, 1:46pm

With the settings above (flash v10 deactivated) the pan is smoother (less jump), but the quality of image is less good : the line are not straight anymore, there are made by small rectangle (I don't know the word to explain that in english)

The pano made on FPP I saw were most of the time better. It's probably because of the better default settings ... ?
Hi, for best quality and performance use a cube pano and flash10!
the FPP can only render cube panos and so it doesn't have this problem with spherical panos!

32

Friday, September 3rd 2010, 4:37pm

Jerking dissapeared!

Bingo! In My case jerking and jumping dissapeared when i update video driver for my ATi Radeon Mobility HD 5730. My new version of driver 10.8

33

Thursday, October 28th 2010, 1:44am

Hi!

I also have the same problem. Watching my pan is not smooth, as it should be.

My settings:

Source code

1
<control usercontrol    ="all"         mousetype      ="moveto"         movetocursor   ="arrow"         cursorsize     ="10.0"         mouseaccelerate="7.30"         mousespeed     ="15.00"         mousefriction  ="0.80"         headswing      ="0.30"         keybaccelerate ="0.50"         keybspeed      ="10.00"         keybfriction   ="0.90"         keybinvert     ="false"         mousefovchange ="1.00"         keybfovchange  ="1.00"         fovspeed       ="3.00"         fovfriction    ="0.90"         keycodesleft   ="37"         keycodesright  ="39"         keycodesup     ="38"         keycodesdown   ="40"         keycodesin     ="16,65,107"         keycodesout    ="17,89,90,109"         /> <view       camroll       ="0.000000"      fov           ="90.000000"      fovmin        ="16.951293"      fovmax        ="90.000000"      maxpixelzoom  ="1.000000"      limitfov      ="true"      fisheye       ="0.00"      fisheyefovlink="0.50"      stereographic ="false"      architectural ="0.0"      architecturalonlymiddle="false"      limitview     ="auto"      hlookatmin    ="NaN"      hlookatmax    ="NaN"      vlookatmin    ="NaN"      vlookatmax    ="NaN"      />    <memory maxmem="350" /><network downloadqueues="" decodequeues="" /><display movequality="LOW" stillquality="HIGHSHARP" details="32" fps="40" flash10="off" movequality10="HIGH" stillquality10="HIGHSHARP" tessmode="5" stilltime="0.25" />



See pano here: http://8m4.utnij.net

I will be grateful for any suggestions!



34

Thursday, October 28th 2010, 3:10pm

Hi,

remove the:

Source code

1
swf.addParam("wmode","transparent");

from the html, this slows down the flashplayer rendering,

best regards,
Klaus

35

Thursday, October 28th 2010, 3:41pm

Hi!


Thank you for answer but unfortunately, I do not see any improvement *confused* Is the other way?


"tiles" may have something to?