You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

servaas

Intermediate

  • "servaas" started this thread

Posts: 206

Location: Belgium

  • Send private message

1

Thursday, December 9th 2010, 11:33am

interactive area troubles

Hello,

I made the tutorial about interactive area but I have some troubles with the calculations.

I can't put my hotspot image on the exact location..

In this tutorial folowing calculations are made

hotspot.width = 583 * 1000 / 1900 = 306.842105
hotspot.height = 332 * 1000 / 1900 = 174.736842
hotspot.ox = 662 * 1000 / 1900 - 500 = -172.631578
hotspot.oy = 941 * 1000 / 1900 - 500 = -4.736842

But when I recalculate the hotspot.ox my result is = 662 * 1000 / 1900 - 500 = -151.578947

What's wrong here. ??

In my test it looks like this "hotspot.ox coordinate" causes the problem..

Thanks for any help.
=servaas=

2

Thursday, December 9th 2010, 5:17pm

Hi,

sorry, that was a typo,

662 was wrong,
622 is right,

the value in the example thread was wrong, but in the image it was right:


I will correct the values in the example thread now,

best regards,
Klaus

servaas

Intermediate

  • "servaas" started this thread

Posts: 206

Location: Belgium

  • Send private message

3

Thursday, December 9th 2010, 6:16pm

Hello,

Thanks for your reaction !

And I found my own mistake as well..
I switched the x and y values and that was the reason why it didn't match...

Cheers,
=servaas=