You are not logged in.

hub

Trainee

  • "hub" started this thread

Posts: 118

Location: Annecy, France

  • Send private message

1

Friday, March 20th 2009, 12:38am

possibility of "mailto:..." and of the 2nd sound track

I made a virtual tour
http://www.annecypanoramique.com/krpano_…5_vv_Prevy.html
I thought, during this project, that it would be nice to be able :
1) to indicate an e-mail adress (like : onclick="mailto(....@...);" (press "i" button to understand this necessity)
2) to dispose of the 2nd sound track; the 1st one as sound for all virtual tour and the 2nd, contextual for each panorama.
Would it be possible?
Hub

2

Friday, March 20th 2009, 10:45am

Hi,

you can use the openurl() action also for "mailto:"

Source code

1
onclick="openurl(mailto:mail@homepage.com);"


you can stop a soundtrack with "stopsound(id);" where the "id" is the one
you set at playsound(id, soundfile.mp3);"

best regards,
Klaus

hub

Trainee

  • "hub" started this thread

Posts: 118

Location: Annecy, France

  • Send private message

3

Saturday, March 21st 2009, 7:47am

Thank you Klaus for "mailto"! it was important for me.
I used the function that lets stop the sound (http://www.annecypanoramique.com/krpano_…0090301_06.html); it works fine. But I wish to have 2 sounds simultaneusely: one that changes with every next pano, and the second that stay during the whole virtual tour. How can I do that?

hub

Trainee

  • "hub" started this thread

Posts: 118

Location: Annecy, France

  • Send private message

4

Saturday, March 21st 2009, 8:16am

I changed my XML with a new indication of "mailto". It works, it opens the mail browser. The problem is that if I return to my virtual tour, I can not call any other pano! I can only look at the last pano when I asked for the contact by mail. Here is my code:

Source code

1
2
3
4
5
6
7
8
9
10
11
  <plugin name="e_mail"
          url="../img/txt_info_mail.png"
          keep="true"
          visible="false"
          align="center"          
          x="0" y="220"
          scale="0.5"
          zorder="15"
          onhover="showtext(e-mail)"
          onclick="openurl(mailto:daniel@frontbus.com);"
          />

5

Saturday, March 21st 2009, 5:35pm

Hi,

you can start two sounds with different id's and only stop one,
e.g.

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
<action name="play">
    <!-- note the '0' as third parameter means endless looping -->
    playsound(sound1,sound/depart.mp3 ,0); 
    playsound(sound2,sound/othersound.mp3); 
   ...
</action>
...
<action name="load_pano2">
    stopsound(sound2);        
   ...          
    load(...); 
    playsound(sound2,sound/chapelle.mp3);     
</action>


Quoted

I changed my XML with a new indication of "mailto". It works, it opens the mail browser. The problem is that if I return to my virtual tour, I can not call any other pano! I can only look at the last pano when I asked for the contact by mail.
sorry, I don't unterstand, do you mean the opening of others panos via hotspots or images doesn't work after opening the mail?
did you have any error/warning messages in the log? (press 'O' on the keyboard to open it)

best regards,
Klaus

hub

Trainee

  • "hub" started this thread

Posts: 118

Location: Annecy, France

  • Send private message

6

Saturday, March 21st 2009, 8:46pm

I put a test version of my virtual tour here:
http://www.annecypanoramique.com/krpano_…/vv2_Prevy.html
The XML code of the first pano is modified and call <onclick="openurl(mailto:...@...);">
I use Opera 9.62. What you said is exact: the opening of others panos via hotspots or images doesn't work after opening the mail!
There is no warning message. When I come back to my virtual tour after openning the mail everything seems normal (I can move the pano, etc) until I click onto the hotspot or miniature-image: it became impossible to pan.
In local, I got a warning message: "loadpano() - busy".
There is no problem with FFox and Outlook! It seems to be Opera problem.

7

Monday, March 23rd 2009, 8:24am

Hi,

I tested it now also with Opera 9.62, you're right, I got the same behavior,
after opening the mail, and clicking on a hotspot to load the next pano, it stopped working,

It seems the problem is the loading of the new xml file:
the old pano is removed and only a "screenshot" of the old pano stays
(the reason why it's not dragable anymore)
and then the loading of the new xml file begins (the downloading is handled by the browser)
but the loading never get finish or fail... so the flashplayer seems endless waiting for a response
of the browser for the download... maybe a opera bug...

I'll try to find something, but I can't promise...

best regards,
Klaus

Similar threads