You are not logged in.

1

Thursday, May 26th 2011, 2:46pm

Textfield content is not coming in exact center position in iPhone

Hi klaus,

Textfield content is not coming in exact center position in iPhone.
I have written following code.

<plugin name="testwindow" enabled="true" url="plugins/textfield.swf" keep="true" offset="center" align="center" width="300" height="64" edge="center" x="0" y="0" visible="false" html="[p][table width='240' border='0' cellspacing='0' cellpadding='0'][tr][td width='130' align='center' valign='middle']Some image is coming[/td][td width='110' align='center' valign='middle']Some Text coming[/td][/tr][/table][/p]" css="p{color:#FFFFFF; font-family:Arial; font-size:13px; font-weight:bold; text-shadow: 2px 2px 2px #000; width:240px; border:1px solid #FFF;}" backgroundalpha="1" backgroundcolor="0x000000" alpha="1" background="false" textblur="0" textglow="8" textglowcolor="0x000000" textshadow="4" />

HTML content is coming properly but the position is not exact center it is moved to right about 100px. and content is going outside the screen of iPhone.

Is it the bug with textfiled on iphone?

Please help me out.

--
Pratiks

2

Wednesday, June 1st 2011, 6:55pm

Hi klaus,
Hi pratiks,

i am facing the same problem!

If i set the css styles and increase the font size it seems the text moves down but the actual textfield keeps the same size!

This made me already a lot of headache.

Need some support here!

Many thanks
Olli

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

3

Wednesday, June 1st 2011, 7:06pm

Try not setting height and use autosize true I think
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

4

Wednesday, June 1st 2011, 11:27pm

Hi Sachagriffin,

your idea seems to make some different views but does not solve the problem.
Autosize generates a textfield size of 300x400 ...

BTW: i am using the .14 BETA version and the behavior between .12 and .14 BETA seems to be really different.

With .14 BETA i get an offset like margin-top: ?px
With .12 i do not get this offset

Simply tested with the examples krpano.xml and the main menu!

Maybe Klaus can check this as well and approve this!

Thx
Olli

mhobbi01

Beginner

Posts: 23

Location: New York

  • Send private message

5

Friday, July 15th 2011, 4:29am

Having the same issue... Anyone find a solution to this?
Maz

Virtual Tour Group Inc.
VirtualTourGroup.com