You are not logged in.

  • "sachagriffin" started this thread

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

1

Saturday, August 20th 2011, 1:12am

loadpano designed to make one go insane.

So loadpano won't take a path meaning all xml's have to be in the original xml location.. and if you have any commands working on the same frame as loadpano it won't work either.. I didn't get calling loadscene(scenename); to work right after either.. wrapping with a delay call was effective however finally.

fyi
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

VN2011

Professional

Posts: 1,336

Location: Duluth MN

  • Send private message

2

Monday, August 22nd 2011, 4:01pm

So loadpano won't take a path meaning all xml's have to be in the original xml location


i load xmls from many different directories ../../newfolder/thisxml.xml or ../anotherfolder/thisxml.xml works for me. they are not all in the same location as my starting xml. unless i am thinking about this wrong.

  • "sachagriffin" started this thread

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

3

Monday, August 22nd 2011, 6:29pm

I was using an initial forward slash. Perhaps that may be a reason.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

4

Monday, August 22nd 2011, 6:30pm

Hi,

see the loadpano() documentation:
http://krpano.com/docu/actions/#loadpano

the url in the loadpano commands are relative to the folder that was defined in the "basedir" variable, which is %FIRSTXML% by default:
http://krpano.com/docu/xml/#krpano.basedir

best regards,
Klaus

5

Monday, August 22nd 2011, 6:31pm

Hi,
I was using an initial forward slash. Perhaps that may be a reason.
in this case its an absolute path to the server root,

best regards,
Klaus

  • "sachagriffin" started this thread

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

6

Monday, August 22nd 2011, 7:23pm

Yes I assumed server root but still no go. I"ll generate an proof of concept. It didn't assign a basedir.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

VN2011

Professional

Posts: 1,336

Location: Duluth MN

  • Send private message

7

Monday, August 22nd 2011, 9:40pm

i do not use the basedir setting so all my paths are based off of the location of whatever krpano.swf file that particular tour was using.