You are not logged in.

1

Wednesday, September 21st 2011, 4:29am

change minimum flash version

Is it possible to change the Flash version check in the javascript embed code to a different version? I'd like for the script to check for version 10 or above.

Thanks

2

Monday, September 26th 2011, 5:27pm

Hi,

you could either hack the swfkrpano.js file - search for ">=9" and replace it with ">=10",

or use the swfobject 1.5 embedding script:
http://krpano.com/docu/htmlalt/#swfobject15

or use the swfobject 1.5 functions with the swfkrpano.js (the swfkrpano.js includes the swfobject 1.5 script)

Source code

1
2
3
4
5
6
7
8
9
if (deconcept.SWFObjectUtil.getPlayerVersion().major >= 10)
{
 // Flashplayer 10 or higher
 // call krpano embedding code, e.g. the embedpano() function,
}
else 
{
 // older Flashplayer
}


best regards,
Klaus