You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

nelk

Intermediate

  • "nelk" started this thread

Posts: 358

Location: Paris

  • Send private message

1

Wednesday, March 3rd 2010, 6:17pm

image.layer

Hi Klaus,

I try to add an filter on the image, but it changes nothing on the panorama.

Am I doing the right things ?

in the register event :

Source code

1
2
panoimage = _krpano.get("image.layer");
panoimage.filters[ new BlurFilter (30,30,1) ] ;


Thanks
VideoStitch, a video stitching engine / blog sur les visites virtuelles ( french ).

2

Friday, March 5th 2010, 1:31pm

Hi,

theoretical it's right,
but I forgot something - the 'filters' was internally also used for the sharpening when using the HIGHSHARP quality, but HIGHSHARP was not used 'filters' will be set to 'null',

I will change that in the next release,

best regards,
Klaus

nelk

Intermediate

  • "nelk" started this thread

Posts: 358

Location: Paris

  • Send private message

3

Friday, March 5th 2010, 2:49pm

Ok, so if I use the HIGHSHARP filter, my filter should be visible too ?
VideoStitch, a video stitching engine / blog sur les visites virtuelles ( french ).

nelk

Intermediate

  • "nelk" started this thread

Posts: 358

Location: Paris

  • Send private message

4

Friday, May 21st 2010, 3:29pm

Hi Klaus,

I've tried with the version 1.0.8.10 and it doesn't seems to work. Have you fixed the bug ?

Thanks !
VideoStitch, a video stitching engine / blog sur les visites virtuelles ( french ).

nelk

Intermediate

  • "nelk" started this thread

Posts: 358

Location: Paris

  • Send private message

5

Sunday, June 6th 2010, 11:40am

Seems to work on version 1.0.8.11 ... Great ! ;-)
VideoStitch, a video stitching engine / blog sur les visites virtuelles ( french ).

nelk

Intermediate

  • "nelk" started this thread

Posts: 358

Location: Paris

  • Send private message

6

Sunday, December 11th 2011, 8:12pm

Hi Klaus,

I just tried to apply a filter on the krpano.get("image.layer"); with the 1.0.8.14, and nothing is applied ...

Is there any bug with the last version ?

This is what I tried

Source code

1
2
panoimage = krpano.get("image.layer");
panoimage.filters.push ( new BlurFilter (64,64,3) ) ;


Thanks for your answer !


Make it worked with the (fantastic) imagelayer plugin
VideoStitch, a video stitching engine / blog sur les visites virtuelles ( french ).

This post has been edited 1 times, last edit by "nelk" (Dec 11th 2011, 8:26pm)


Similar threads