You are not logged in.

kosmodroms

Beginner

  • "kosmodroms" started this thread

Posts: 40

Location: Latvia

Occupation: Kosmodroms | Digital Creative Studio - programmer, designer

  • Send private message

1

Monday, February 20th 2012, 7:14pm

Camroll and hostpots alignment

If I apply camroll to panorama hotspots seem to be not rolled. Hard to explain...
I attached 2 images where You can see 1) panorama with hotspots and no camroll and 2) camroll with misaligned hotspots (pano is rolled but hotspots stayed as they were before). If I pan and tilt hotspots go their own path instead of being "sticked" to image.

I'm using latest KRpano JS on Mac Safari, tried on iOS Simulator and I'm not 100% sure but as far as I remember it was the same on iPad2 and iPhone 4s last time I checked.
Does anyone have the same problem? Didn't find any thread about it on this forum.

Edgars @ Kosmdoroms
kosmodroms has attached the following images:
  • 1.jpg
  • 2.jpg
Edgars
Kosmodroms | Digital Creative Studio
www.kosmodroms.lv

2

Monday, February 20th 2012, 7:20pm

Hi,

at the moment only distorted hotspots were rotated correctly when using view.camroll (by the gryo plugin),

try adding - distorted="true" - to the <hotspot> elements,

best regards,
Klaus

kosmodroms

Beginner

  • "kosmodroms" started this thread

Posts: 40

Location: Latvia

Occupation: Kosmodroms | Digital Creative Studio - programmer, designer

  • Send private message

3

Tuesday, February 21st 2012, 2:52pm

Thanks, that did the job!
Edgars
Kosmodroms | Digital Creative Studio
www.kosmodroms.lv