You are not logged in.

1

Thursday, January 10th 2013, 1:33am

view zoom limit on 360 video

Hi,

Using paid krpano to show an underwater 360 video I created as seen here:

http://subsurfacemedia.com/immersive-underwater-360-video/


One issue I have yet to resolve is getting 'lost' when zooming in too far. I would like limit the zoom depth. I tried doing so with limits in the 'view' tag, but nothing seems to work for me. I'm wondering if there is a bug where zoom and fov limits don't work on video as they would on still images. Does anyone know if zoom and FOV limits work on video in krpano?

Thank you,
briand123

2

Thursday, January 10th 2013, 7:51am

this can be done with the "fovmin", "fovmax" settings.

http://www.krpano.com/docu/xml/#view

hope this helps
cheers

ali

Beginner

Posts: 4

Location: Turkey izmir

  • Send private message

3

Thursday, January 10th 2013, 2:59pm

<view hlookat="0" vlookat="0" fovtype="MFOV" fov="130" fovmin="110" fovmax="130" limitview="range" vlookatmin="-100" vlookatmax="50" hlookatmin="-180" hlookatmax="180" />

Ideal settings for zoom fov *evil*

4

Monday, January 14th 2013, 2:02am

Thank you for the tips. I was using the fovmin and fovmax which had no effect until I added the fovtype="MFOV". This is what I have now which works on the first load of my scene.

<view hlookat="-150" vlookat="0" fovtype="MFOV" fov="120" fovmin="75" fovmax="130" limitview="range" />



What I need to solve now is a problem where the above limit have no effect if I jump to the scene using a hot spot or map point link. I jump into the scene using this within the hot spot plugin tag.

onclick="looktohotspot(spot1); loadscene(scene1, null, MERGE, NOBLEND);"


Anyway, I'm getting closer and thanks for the helpful tip on the MFOV value for fovtype.

briand123