You are not logged in.

Stefan.L

Trainee

  • "Stefan.L" started this thread

Posts: 102

Location: Sweden

Occupation: Photography/ webdesign

  • Send private message

1

Saturday, February 16th 2013, 3:32pm

(SOLVED)Scaling trouble embed tour into website - please help

This below and http://krpano.com/docu/html/#top works fine but i experience scaling trouble with for instance the thumbs layers.
If not embedded it look perfekt on both iPad/ iphone desktop etc.

Please advice *cry*


<object width="100%" height="100%"> <embed src="http://WWW.MY-DOMAIN.COM/VIRTUAL_TOUR/MY-TOUR.SWF" width="100%" height="100%" allowFullScreen="true"> </embed> </object>




Best regards - Stefan

This post has been edited 1 times, last edit by "Stefan.L" (Feb 20th 2013, 3:02pm)


Stefan.L

Trainee

  • "Stefan.L" started this thread

Posts: 102

Location: Sweden

Occupation: Photography/ webdesign

  • Send private message

2

Monday, February 18th 2013, 12:15am

This is what i want to do when it comes to embedding.

http://krpano.com/plugins/scrollarea/
Best regards - Stefan

3

Tuesday, February 19th 2013, 3:49pm

Hi,

please see the notes here:
http://krpano.com/docu/html/#mobilenotes

When all notes from there - doctype, the meta viewport setting, no iframe - will be respected, then the scaling should be perfectly 1:1.

Best regards,
Klaus

Stefan.L

Trainee

  • "Stefan.L" started this thread

Posts: 102

Location: Sweden

Occupation: Photography/ webdesign

  • Send private message

4

Tuesday, February 19th 2013, 4:39pm

Hi,


Thank you for your reply!

All this info is in the virtualtour.html straight out of the, by the PTP rendered tour. Everything works perfekt after updated plugins to latest version.
To tell you the truth i canĀ“t figure out how to use this (I should be able to figure out)


<script>

embedpano({swf:"pano.swf", xml:"pano.xml", target:"pano"});
</script>

or why it is not scaling well with, perhaps it have to be put inside a fixed div?


<
object width="100%" height="100%"> <embed src="http://WWW.MY-DOMAIN.COM/VIRTUAL_TOUR/MY-TOUR.SWF" width="100%" height="100%" allowFullScreen="true"> </embed> </object>
Best regards - Stefan

5

Tuesday, February 19th 2013, 4:42pm

Hi,
or why it is not scaling well with, perhaps it have to be put inside a fixed div?
sorry, I don't understand...

<object width="100%" height="100%"> <embed src="http://WWW.MY-DOMAIN.COM/VIRTUAL_TOUR/MY-TOUR.SWF" width="100%" height="100%" allowFullScreen="true"> </embed> </object>
Such flash-only fallback code should be not necessary and I would not recommend to use it.

Best regards,
Klaus

Stefan.L

Trainee

  • "Stefan.L" started this thread

Posts: 102

Location: Sweden

Occupation: Photography/ webdesign

  • Send private message

6

Tuesday, February 19th 2013, 5:29pm

hmm ok it is not only swf as the link i pasted - i change the .swf to html - with scaling trouble.

What i want to do is to embed a virtualtour (made by ppt) into a wordpress site.



This is what am trying with this. Good or bad:)


<div class="testing">
<object width="100%" height="100%"> <embed src="http://tours.website.se/bmw/bmw.html" width="100%" height="100%" allowFullScreen="true"> </embed> </object>
</div>
Best regards - Stefan

This post has been edited 1 times, last edit by "Stefan.L" (Feb 19th 2013, 5:52pm)


7

Tuesday, February 19th 2013, 6:22pm

Hi,

that code here is totally wrong:

Source code

1
<object width="100%" height="100%"> <embed src="http://tours.website.se/bmw/bmw.html" width="100%" height="100%" allowFullScreen="true"> </embed> </object>

the <object>/<embed> html tags are for embedding plugins, to include an html page, the <iframe> element would need to be used - but with iframes the scaling is not controllable!

Try that:

Source code

1
2
3
4
5
6
7
<script src="http://WWW.MY-DOMAIN.COM/swfkrpano.js"></script>

<div id="pano" style="width:640px; height:400px;"></div>

<script>
  embedpano({swf:"http://WWW.MY-DOMAIN.COM/krpano.swf", xml:"pano.xml", target:"pano"});
</script>


Best regards,
Klaus

Stefan.L

Trainee

  • "Stefan.L" started this thread

Posts: 102

Location: Sweden

Occupation: Photography/ webdesign

  • Send private message

8

Tuesday, February 19th 2013, 7:10pm

Much better!!

Works in flash and looks fine!

Ios - not working (fatal error virtualtour.xml - loading failed! (404) - i have tried with the full link also. (loading or parsing failed)
Firefox mac html5 - asks for flash install.

Everything look fine in source and the panos (without embedding) works fine on both ios and html5 desktop) I have written all correct.

What am i doing wrong:( A "devices" thing perhaps?
Best regards - Stefan

This post has been edited 1 times, last edit by "Stefan.L" (Feb 19th 2013, 7:26pm)


9

Tuesday, February 19th 2013, 7:26pm

Right, HTML5 is a problem in this case...

For 'security reasons' the browsers don't allow loading XML files from other domains without additional server-side settings. The 'Access-Control-Allow-Origin header would need to be sent from your server.

If you are using an Apache web server, you could try uploading a file named '.htaccess' with the following content to your server:

Source code

1
Header set Access-Control-Allow-Origin *


The other and more-reliable and recommend solution would be loading all files to the domain where they should be displayed.

Best regards,
Klaus

Stefan.L

Trainee

  • "Stefan.L" started this thread

Posts: 102

Location: Sweden

Occupation: Photography/ webdesign

  • Send private message

10

Tuesday, February 19th 2013, 7:37pm

ok Just tried with the access, with the asterix right? Header set Access-Control-Allow-Origin *

I have the website on www.website.se and the panofiles on tours.website.se

So that is not a good solution. i where planning to put panos on a subdomain but i guess i have to rethink that....
Best regards - Stefan

Stefan.L

Trainee

  • "Stefan.L" started this thread

Posts: 102

Location: Sweden

Occupation: Photography/ webdesign

  • Send private message

11

Tuesday, February 19th 2013, 7:57pm

Alright - I moved the pano to the same webserver with out any luck - then i added Header set Access-Control-Allow-Origin * to the access file and now it works. Now it works on the subdomain as well. Goodness! Maybe better to skip embedding if my webserver cant handle this...
Are there any downsides with this? Safe?

Thank you very much for you replies Klaus - cheers!
Best regards - Stefan