You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, March 17th 2013, 7:16pm

loadscene()-Fehler auf Tablets

Hallo,

ich habe meine ersten Panoramas mit krpano erstellt und sie laufen auf verschiedenen Systemen und verschiedenen Browsern alle einwandfrei.

Schaue ich mir eines dieser Bilder allerdings auf einem Android-Tablet oder iPad an, erhalte ich eine Fehlermeldung

ERROR: loadscene() - scene "pano_01" not found

und der Bildschirm bleibt schwarz. Dabei heißt die erste Scene wirklich 'pano_01'. Hat jemand eine Idee, wo ich zuerst nach dem Fehler suchen soll?

toosten

Intermediate

Posts: 469

Location: Berlin

Occupation: freier Software-Entwickler ( HTML, JS, PHP, JSP, Flash, AS3, C++, Java, krpano, ---)

  • Send private message

2

Sunday, March 17th 2013, 10:20pm

Sorry, meine Glaskugel ist defekt.

3

Wednesday, March 20th 2013, 8:03pm

Hi,

ist dieser Szene in der xml eventuell - devices="flash" - definiert?

Falls ja, dann handelt es sich bei der Szene um ein nicht-HTML5-kompatibles Panorama, welche durch die 'devices' Einstellung für HTML5 'ausgeblendet' wird.

Schöne Grüße,
Klaus

4

Thursday, March 21st 2013, 10:03am

ist dieser Szene in der xml eventuell - devices="flash" - definiert?


Richtig geraten ;-)

Ich habe das Teilpanorama (hfov < 360) inzwischen durch einen einfarbigen Hintergrund so erweitert, dass die Bildmaße einem 360-Panorama entsprechen und dann hlookatmin und hlookatmax so gesetzt, dass nur der eigentlich gültige Bildausschnitt gezeigt wird. Das klappt, aber

1) bläht die Speichergröße durch die vielen überflüssigen Kacheln doch stark auf

2) ich erhalte manchmal einen kleinen senkrechten Streifen mit der gewählten Zusatzfarbe beim Scrollen durch das Bild.

Frage:

1) Gibt es da bessere Lösungen für solche Teilpanoramen?

2) Kann man das nicht besser durch die krpano-Tools erledigen lassen? Da müsste man doch bei Angabe dieser zwei Parameter die nicht benutzten Kacheln gleich automatisch weglassen können, wenn das implementiert wäre?

ciao pirx

5

Thursday, March 21st 2013, 2:23pm

Hi,
2) Kann man das nicht besser durch die krpano-Tools erledigen lassen? Da müsste man doch bei Angabe dieser zwei Parameter die nicht benutzten Kacheln gleich automatisch weglassen können, wenn das implementiert wäre?
Ja, eine automatische Lösung hierfür ist bereits geplant, allerdings ist dies intern etwas komplexer als nur die Tiles wegzulassen.

Schöne Grüße,
Klaus

6

Thursday, March 21st 2013, 5:38pm

a, eine automatische Lösung hierfür ist bereits geplant ...


Das hört sich richtig gut an *smile*

ciao pirx