Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

41

Sonntag, 31. März 2013, 16:24

Thanks Tuur, I know, but it works different. When zoomed in and trying to move the object, it's turning around. When you do that on the 'desktop' version, the object is moving. With the html5-version, you only zoom in in the middle and you can't see the sides when zoomed in.

Besides, would be nice if I don't have to write the code again for html5 (have to do that a little bit of course, but not the whole code).

Tuur

Erleuchteter

Beiträge: 3 042

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

42

Sonntag, 31. März 2013, 16:27

i don't see the problem, well explain me later ;-)
maybe use the area tag?

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

43

Sonntag, 31. März 2013, 16:35

No. When you zoom in, it will only zoom in to the middle. You can't see the sides anymore. When you try to drag the object (car) to the side, it will turn around.
The 'real' krpano object movie will when zoomed in not turn, but you can drag the object to the left or right (or up/down, etc). So you can also see the corners of the object.

I'll explain it in our native language:
Weetjewat, ik leg het ff in het Nederlands uit. Als je die auto van jouw voorbeeldlinkjes inzoomt, dan zoomt ie in naar het midden. Als je dan de zijkanten wil zien kan dat niet, want als je probeert te 'draggen' gaat ie meteen draaien. Als je met wat Klaus ooit heeft gemaakt een object movie inzoomt en dan naar een zijkant wil kijken, dan kun je het object gewoon opzij draggen. Hij gaat dan niet verder draaien. Dus je kunt dan ook de hoeken van het object zien als je ingezoomd bent in plaats van alleen maar het midden. Snap je het nou?

If you don't understand, I have to show you next tuesday ;).

Tuur

Erleuchteter

Beiträge: 3 042

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

44

Sonntag, 31. März 2013, 16:52

ah ja, snap hem ... zal er eens over nadenken..
misschien de 'auto draggable maken als je ingezoomed bent, en dan de draai functie aan de 'pijltjes' overlaten.. (?)

that's dutch for: maybe make the car draggable when zoomed and leave the rotate function to the arrows.. (?)

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

45

Sonntag, 31. März 2013, 17:29

Hi,
Ich habe einen Test durchgefuehrt. Ich habe die Taste "links" so zugedrueckt,
dass das Panorama sich staendig links drehte und habe das Niveau fps verfolgt.
Und das ist herausgekommen:

> krpano-1.0.8.15 = 45 fps
> krpano-1.16 = 29 fps

browser: Opera
cubesize: 2200
Ich nehme an es ist die Flash Version gemeint, oder?

Das Flash Renderering selbst, in der neuen Version, ist das gleiche wie in der vorherigen Version, d.h. hier kann es keine Performance Unterschiede geben.

Was allerdings neu ist, dass das die neue Version des Einbinde-Skript, standardmäßig die Flashplayer Einstellung wmode=direct verwendet. Auf den meisten Systemen und Browsern wird dadurch die Darstellung schneller, auf manchen (abhängig von Browser, System, Grafikkarten usw.) kann sie allerdings auch langsamer werden, wobei ich sagen muss das ich bei meinen Tests keinen so starken Unterschied gesehen habe.

Hast du auch andere Browser und Systeme getestet?
Wie verhalten sich diese?

Mittels wmode=normal in der HTML, müsste sich die neue Version auf deinem System genauso verhalten wie die alte.


Thanks for the update! By the way, there are other good news that go very well with this krpano update: IE11 will support WebGL (http://winsupersite.com/windows-8/blue-s…l-support-ie-11)
Thanks, good to know.

Best regards,
Klaus

46

Sonntag, 31. März 2013, 18:50

about nadirlogo i saw this using the default browser (internet icon) on samsung galaxy tab2 (android 4.1.1)



the nadir logo is over the menù icons


Quellcode

1
2
3
4
5
6
7
8
9
10
11
		<hotspot name="nadirlogo" keep="true"
			 url="%SWFPATH%/skin/nadirlogo.png"
			 ath="0"
			 atv="90"
			 distorted="true"
			 scale="1.0"
			 rotate="0.0"
			 enabled="true" 
			 onclick="openurl('Http://www.villapiave.it',_blank);" 
			 handcursor="true" 
		  />


an other thing is the loading time of the scene with different browsers:

link: http://www.sky360.it/hotel4/tour.html

krpano 1.16.1
loading scene speed test on win7 with Flash 11.6 :
- ie10, chrome 26 = loading time ok
- firefox19, safari 5.7.1, opera 12.14 = loading time very slow...

loading scene speed test on win7 with ?html5=prefere :
- ie10 , safari 5.1.7, = very slow
- chrome 26 = slow
- firefox 19 = slow and doesn't load background sound
- opera 12.14 = html5 doesn't start... it load on flash version...

all browsers are updated to the last version available, i made the same test with different pc's hardware with same results.
the background sound file size is 800kb , the icons are few kb..
the tour was made with last version of krpano 1.16.1 with the multires droplet, original first pano got a resolution of 10000x5000 with a size of 20mb more or less...
the code:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
		<preview url="panos/01.tiles/preview.jpg" />

		<image type="CUBE" multires="true" tilesize="512" progressive="false">
			<level tiledimagewidth="4090" tiledimageheight="4090">
				<cube url="panos/01.tiles/l4_%s_%v_%h.jpg" />
			</level>
			<level tiledimagewidth="2048" tiledimageheight="2048">
				<cube url="panos/01.tiles/l3_%s_%v_%h.jpg" />
			</level>
			<level tiledimagewidth="1024" tiledimageheight="1024">
				<cube url="panos/01.tiles/l2_%s_%v_%h.jpg" />
			</level>
			<level tiledimagewidth="512" tiledimageheight="512">
				<cube url="panos/01.tiles/l1_%s_%v_%h.jpg" />
			</level>
			<mobile>
				<cube url="panos/01.tiles/mobile_%s.jpg" />
			</mobile>
		</image>

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Aperol« (1. April 2013, 12:48)


47

Sonntag, 31. März 2013, 22:15

Zitat

Ich nehme an es ist die Flash Version gemeint, oder?

Das Flash Renderering selbst, in der neuen Version, ist das gleiche wie in der vorherigen Version, d.h. hier kann es keine Performance Unterschiede geben.

Was allerdings neu ist, dass das die neue Version des Einbinde-Skript, standardmäßig die Flashplayer Einstellung wmode=direct verwendet. Auf den meisten Systemen und Browsern wird dadurch die Darstellung schneller, auf manchen (abhängig von Browser, System, Grafikkarten usw.) kann sie allerdings auch langsamer werden, wobei ich sagen muss das ich bei meinen Tests keinen so starken Unterschied gesehen habe.

Hast du auch andere Browser und Systeme getestet?
Wie verhalten sich diese?

Mittels wmode=normal in der HTML, müsste sich die neue Version auf deinem System genauso verhalten wie die alte.


So it flash.
wmode: normal - much better.
45 fps, as in the old version.
On other systems do not have the possibility to check.
another test for firefox - 32/18

Here is my configuration:
> Intel Core 2 Duo 1.73
> RAM 2 Gb
> NVIDIA GeForce 8400 GS

Sorry for machine translation!

48

Montag, 1. April 2013, 11:29

The new option on the vtoureditor works great Klaus, thanks! There is a very small issue with the new version though: apparently it's not possible to set the visibility to "false" in the vtoureditor plugin. One thing I do when I'm in "tour editing" mode is to have a key which shows and hides the vtoureditor and options plugins, so that I can check how the final version will look. I find it quite useful when setting the initial views or when there is a top menu that needs to be tested. It's a really simple code, but I can post it in case you would like to include it in the default skin.

Here is a test which shows how the plugin is visible even with visible="false": http://demo.digisfera.pt/krpano-stuff/vt…16.1/index.html

Thanks!
Manuel
PanoTag: Facebook tagging for krpano

KRPano development and more: http://www.digisfera.pt/en/development

49

Dienstag, 2. April 2013, 07:38

new version dont normal work playsound... new scene reload sound! anddont not continuing!
id verified.

old version rkpano good work! new version no.

BUG? *wacko*

Tuur

Erleuchteter

Beiträge: 3 042

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

50

Dienstag, 2. April 2013, 11:35

1.16 zoom

Hi,

I experience some things on safari.

- not possible to zoom by shift or ctrl buttons.
- when in fullscreen the zoom by mousepad works but when not in fullscreen it works not..

safari 6.0.3
osx 10.8.3

this is offline.. when i look at example from emediquel it works good.

didn't test it with the bug fix 1.16.1 yet..

EDIT: ok it's only offline not zooming by mousepad.. online= ok
buttons don't work on both

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Tuur« (2. April 2013, 12:21)


51

Dienstag, 2. April 2013, 12:29

Hi,
The new option on the vtoureditor works great Klaus, thanks! There is a very small issue with the new version though: apparently it's not possible to set the visibility to "false" in the vtoureditor plugin.
That hadn't changed compared to the previous version - the vtoureditor buttons are not directly a part of the plugin element itself and so they can't be hidden by the visible setting. The whole vtoureditor GUI is put on top of the viewer to avoid deep-ordering problems.


new version dont normal work playsound... new scene reload sound! anddont not continuing!
id verified.
The soundinterface itself hadn't changed. Do you mean the same example had worked in 1.0.8.15 and now it not in 1.16.1?
If yes, please provide an example.


- not possible to zoom by shift or ctrl buttons.
Please see the release notes:

Zitat

Change: The default keycodes for zooming in/out were removed because they often have interfered with the browser keyboard controls.


- when in fullscreen the zoom by mousepad works but when not in fullscreen it works not..
When not in fullscreen mode, the krpano embedding script handles the mouse-wheel scrolling because the Mac Flashplayer itself is buggy and can't do it. This is done by Javascript and therefore it doesn't work by default locally, because the Flashplayer security settings need to be changed to use the Javascript Interface locally.

Best regards,
Klaus

52

Dienstag, 2. April 2013, 14:21

I've updated to the new 1.16.1 and a strange issue came up. I only tested the HTML5 viewer since that's what I'm interested in for this version and it all works well in Firefox and Safari, but in Chrome I get loading errors that I cannot explain. And for some weird reason I get xml parsing failed only in IE and by looking at the dev console the xml isn't being loaded properly (it looks fragmented).

Test link panoramatec.com/html5test (the link has a redirect with a timer, so in case you you are inactive for a longer period of time, you have to access this link again and not refresh the page)

Another thing I noticed is that I get a license error if I add the "www." to the link which I didn't get before.

Please let me know if it's something on the implementation part or if it's a bug.
Any help would be greatly appreciated.

53

Dienstag, 2. April 2013, 14:37

Hi,
Test link panoramatec.com/html5test (the link has a redirect with a timer, so in case you you are inactive for a longer period of time, you have to access this link again and not refresh the page)
One problem might be the HTML4 doctype - try using a HTML5 doctype instead.


Another thing I noticed is that I get a license error if I add the "www." to the link which I didn't get before.
This is strange, I need to check that in detail, it seems to be related to the domain limitation, but 'www.' prefixes shouldn't matter normally...

Best regards,
Klaus

54

Dienstag, 2. April 2013, 14:55

One problem might be the HTML4 doctype - try using a HTML5 doctype instead.
I changed it to "<!DOCTYPE html>" and the results are the same.

55

Dienstag, 2. April 2013, 15:17

Your server returns - Content-Type:text/html - for the images - this might be eventually a problem for Chrome.
Try to configurate your server/server-script this way that it returns the correct content/mime type for the images.

Best regards,
Klaus

56

Dienstag, 2. April 2013, 16:04

Your server returns - Content-Type:text/html - for the images - this might be eventually a problem for Chrome.
Try to configurate your server/server-script this way that it returns the correct content/mime type for the images.

Best regards,
Klaus
This is weirder than expected. On Firefox it returns the right content type, but on Chrome for some reason when loading the images by the viewer it says they are indeed "text/html", but when I access them directly by link in Chrome they have the correct content type.
Thanks for the help, I think this is the cause of the problem. I'll try to find a solution to it.

Later Edit: It seems that the problem is still 1.16.1 specific. If I use the 1.0.8.15 version, the content type is correct for all of the images. (the server script is the same for all versions)
To see the difference between versions, all you have to do is edit the URL after the redirect and put "4.0.0" instead of "4.0.1" (4.0.0 has version 1.0.8.15) . If I find out anything else, I'll post it.
Another curious issue is that desktop Safari works (content type is OK), while iPad Safari doesn't (content type incorrect).

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Marius« (2. April 2013, 16:48)


57

Dienstag, 2. April 2013, 17:07

Hi Klaus,

Any news on when you will support flat panos in html5?

Thanks,
Darren

ramirox3

Fortgeschrittener

Beiträge: 162

Wohnort: La Ceja, Colombia

Beruf: photographer

  • Nachricht senden

58

Dienstag, 2. April 2013, 18:53

sound on off button behaves differently at 1.16

sound on off button behaves differently at 1.16
I update this tour to version 1.16

http://www.ciudadcubica.com/rn16/
(For those who do not understand Spanish, you have to click on the Welcome screen to start the tour)

everything is fine, only the sound button behaves strange:
in android 2.3, flash only works perfect.
in android 4.1 in flash only works in full screen, native browswer
html5 in android 4.1 not working in chrome
it can be? any clues?
Thanks
Ramiro

59

Dienstag, 2. April 2013, 21:23

Hi,

sound on off button behaves differently at 1.16
I update this tour to version 1.16

The reason is this bug in 1.16:

Zitat

Release Notes - krpano 1.16.1
Changes from 1.16 to 1.16.1:

* krpano Flash Viewer (krpano.swf)
o Fix: Problem when the <scene> onstart attribute contains '&' or '=' characters.

It was fixed in 1.16.1 - see here:
http://krpano.com/news/#releasenotes1161

Best regards,
Klaus

60

Dienstag, 2. April 2013, 21:33

Hi,

Later Edit: It seems that the problem is still 1.16.1 specific. If I use the 1.0.8.15 version, the content type is correct for all of the images. (the server script is the same for all versions)
To see the difference between versions, all you have to do is edit the URL after the redirect and put "4.0.0" instead of "4.0.1" (4.0.0 has version 1.0.8.15) . If I find out anything else, I'll post it.
Another curious issue is that desktop Safari works (content type is OK), while iPad Safari doesn't (content type incorrect).
The only technically difference between 1.0.8.15 and 1.16 regarding requesting images from the server is the 'crossOrigin' request header (for WebGL crossdomain loading).

That means the http request header also contains a line like this:

Quellcode

1
Origin: http://panoramatec.com


And when I compare the http request headers between 4.0.0 and 4.0.1 in your link (with the Chrome Developer Tools) then I see only differences are this 'Origin' line and this cookie:

Quellcode

1
Cookie: PHPSESSID=95ea3c894e16d027cf6cd61a595e95d1; __unam=e0d68f0-13dcc35ce80-300a488d-2; __utma=229536669.1180272145.1364930710.1364930710.1364930710.1; __utmb=229536669.2.10.1364930710; __utmc=229536669; __utmz=229536669.1364930710.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)

But krpano itself isn't sending this cookie.

Best regards,
Klaus