You are not logged in.

1

Thursday, April 18th 2013, 7:58am

Kleiner Bug im Flash-Viewer (krpano.swf) mit der Version 1.16.2 ?

Hallo allerseits

Habe gestern alles von der Version 1.16.1 auf 1.16.2 upgegraded. Nun stelle ich fest, dass bei allen Panoramen und Touren der Start-Text nicht mehr vollständig eingeblendet wird (Safari, Firefox, Chrome). Wenn ich die Vorgängerversion des krpano.swf nutze, funktionier wieder alles einwandfrei...

Hier der relevante Code-Auszug:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
<events onloadcomplete="delayedcall(1.0, normalview() ); set(events.onloadcomplete,null);" />


<action name="normalview">
showtext(get(data[infotext].content), infostyle)
</action>


<data name="infotext">
[b]Text[/b][br]
[font size="15"]mehr Text[/font][br][br]
[font size="25"]noch mehr Text[/font]
</data>


<textstyle name="infostyle"
font="Trebuchet MS,Arial,Helvetica,sans-serif"
fontsize="40"
bold="false"
italic="false"
background="false"
border="false"
textcolor="0xFFFFFF"
textalign="center"
origin="center"
edge="center"
yoffset="-39"
showtime="5.0"
fadeintime="1.0"
fadetime="1.0"
effect="glow(0xFFFFFF,0.7,4,2);glow(0x000000,1,4,2);dropshadow(3,45,0x000000,2,0.6);"
/>


Es wird nur noch "Text" eingeblendet, "mehr Text" und "noch mehr Text" fehlen...
Habe ich etwas übersehen?

Vielen Dank für eure Hilfe!

Gruss
Mischa

FINSCHI PHOTOGRAPHY & ENGINEERING

2

Thursday, April 18th 2013, 11:06am

Hi,

Danke für den Hinweis - der Unterschied zwischen 1.16.1 und 1.16.2 ist hier, das die XML 'Sonderzeichen' innerhalb von <data> und <scene> Elementen nicht mehr automatisch aufgelöst/korrigiert werden. Die Änderung war notwendig für die HTML5 Kompatibilität, ich werde dies aber noch einmal genau überprüfen und eventuell erweitern.

Als Workaround für den Moment wäre aber folgendes möglich - ersetze die " Zeichen innerhalb von <data> mit %22- z.B.
[font size=%2215%22]mehr Text[br][br][/font]
[font size=%2225%22]noch mehr Text[/font]

Schöne Grüße,
Klaus

3

Tuesday, April 30th 2013, 2:23pm

Ein kurzes Update diesbezüglich - in der nächsten Version (1.16.3) wird dieses Problem behoben sein.