You are not logged in.

1

Friday, October 4th 2013, 7:18pm

Eigenes Skin funktioniert bei aktueller Version nicht mehr

Hallo,
habe bis vor kurzem die KRPANO Version 1.0.8 benutzt. Mein Skin hat hier einwandfrei funktioniert. Jetzt mit deraktuellen Version kommen Fehlermeldungen. Hab schon den ganzen tag rumprobiert. Komme aber nicht drauf an was es liegt.

Hier mein Code:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
<plugin name="balken" url="%SWFPATH%/guibilder/balken_weiss.png" keep="true" visible="true" enabled="true" handcursor="false" capture="true" children="true" zorder="0" alpha="1.00" blendmode="normal" smoothing="true" origin="bottom" edge="center" x="0" y="18" width="500%" scale="1" onloaded="" onover="" onhover="" onout="" ondown="" onup="" onclick=""/>
<plugin name="up" url="%SWFPATH%/guibilder/btn/btn_up.png" keep="true" visible="true" enabled="true" handcursor="true" capture="true" children="true" zorder="2" alpha="0.8" smoothing="true" origin="bottom" edge="center" x="20" y="16" scale="1" onloaded="" onover="set(alpha,1);" onhover="" onout="set(alpha,0.8);" ondown="set(movevectory,-1);" onup="set(movevectory,0);" onclick=""/>
<plugin name="down" url="%SWFPATH%/guibilder/btn/btn_down.png" keep="true" visible="true" enabled="true" handcursor="true" capture="true" children="true" zorder="2" alpha="0.8" smoothing="true" origin="bottom" edge="center" x="+60" y="16" scale="1" onloaded="" onover="set(alpha,1);" onhover="" onout="set(alpha,0.8);" ondown="set(movevectory,+1);" onup="set(movevectory,0);" onclick=""/>
<plugin name="in" url="%SWFPATH%/guibilder/btn/btn_in.png" keep="true" visible="true" enabled="true" handcursor="true" capture="true" children="true" zorder="2" alpha="0.8" smoothing="true" origin="bottom" edge="center" x="-140" y="16" scale="1" onloaded="" onover="set(alpha,1);" onhover="" onout="set(alpha,0.8);" ondown="set(movevectorz,-1);" onup="set(movevectorz,0);"/>
<plugin name="out" url="%SWFPATH%/guibilder/btn/btn_out.png" keep="true" visible="true" enabled="true" handcursor="true" capture="true" children="true" zorder="2" alpha="0.8" smoothing="true" origin="bottom" edge="center" x="-100" y="16" scale="1" onloaded="" onover="set(alpha,1);" onhover="" onout="set(alpha,0.8);" ondown="set(movevectorz,+1);" onup="set(movevectorz,0);"/>
<plugin name="left" url="%SWFPATH%/guibilder/btn/btn_left.png" keep="true" visible="true" enabled="true" handcursor="true" capture="true" children="true" zorder="2" alpha="0.8" smoothing="true" origin="bottom" edge="center" x="-60" y="16" scale="1" onloaded="" onover="set(alpha,1);" onhover="" onout="set(alpha,0.8);" ondown="set(movevectorx,-1);" onup="set(movevectorx,0);" onclick=""/>
<plugin name="right" url="%SWFPATH%/guibilder/btn/btn_right.png" keep="true" visible="true" enabled="true" handcursor="true" capture="true" children="true" zorder="2" alpha="0.8" smoothing="true" origin="bottom" edge="center" x="-20" y="16" scale="1" onloaded="" onover="set(alpha,1);" onhover="" onout="set(alpha,0.8);" ondown="set(movevectorx,+1);" onup="set(movevectorx,0);" onclick=""/>
<plugin name="openfs" url="%SWFPATH%/guibilder/btn/btn_fs.png" keep="true" visible="true" enabled="true" handcursor="true" capture="true" children="true" zorder="2" alpha="0.8" smoothing="true" origin="bottom" edge="center" x="+100" y="16" scale="1" onloaded="" onover="set(alpha,1);" onhover="showtext(Vollbildmodus starten)" onout="set(alpha,0.8);" ondown="" onup="" onclick="set(fullscreen,true);set(visible, false); set(plugin[closefs].visible, true);"/>
<plugin name="closefs" url="%SWFPATH%/guibilder/btn/btn_fs_close.png" keep="true" visible="false" enabled="true" handcursor="true" capture="true" children="true" zorder="2" alpha="0.8" smoothing="true" origin="bottom" edge="center" x="+100" y="16" scale="1" onloaded="" onover="set(alpha,1);" onhover="showtext(Vollbildmodus beenden);" onout="set(alpha,0.8);" ondown="" onup="" onclick="set(fullscreen,false);set(visible, false); set(plugin[openfs].visible, true);"/>
<plugin name="fcb" url="%SWFPATH%/guibilder/btn/faceb.png" keep="true" visible="true" enabled="true" handcursor="true" capture="true" children="true" zorder="2" alpha="1" smoothing="true" origin="bottom" edge="center" x="+210" y="17" scale="1" onloaded="" onover="set(alpha,2);" onhover="showtext(Besuchen Sie uns auf Facebook);" onout="set(alpha,1);" ondown="" onup="" onclick="openurl(http://www.facebook.com);"/>
<plugin name="info" url="%SWFPATH%/guibilder/btn/btn_i.png" keep="true" visible="true" enabled="true" handcursor="true" capture="true" children="true" zorder="2" alpha="1" smoothing="true" origin="bottom" edge="center" x="+140" y="17" scale="1" onloaded="" onover="set(alpha,2);" onhover="showtext(Information);" onout="set(alpha,1);" ondown="" onup="" onclick="action(infobild);"/>
<plugin name="infobild" url="guibilder/btn/infobox.png" keep="true" visible="false" alpha="1.0" align="center" onclick="tween(alpha, 0.0, 0.5, linear, set(visible,false); );" />


Folgende Fehlermeldung erscheint:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
INFO: krpano 1.16.8 (build 2013-09-27)

INFO: Desktop/Win32 - Firefox 24.0 - WebGL

ERROR: hotspot[nadirlogo] loading error: include/%SWFPATH%/logo.png

ERROR: plugin[balken] loading error: include/%SWFPATH%/guibilder/balken_weiss.png

ERROR: plugin[up] loading error: include/%SWFPATH%/guibilder/btn/btn_up.png

ERROR: plugin[down] loading error: include/%SWFPATH%/guibilder/btn/btn_down.png

ERROR: plugin[in] loading error: include/%SWFPATH%/guibilder/btn/btn_in.png

ERROR: plugin[out] loading error: include/%SWFPATH%/guibilder/btn/btn_out.png

ERROR: plugin[left] loading error: include/%SWFPATH%/guibilder/btn/btn_left.png

ERROR: plugin[right] loading error: include/%SWFPATH%/guibilder/btn/btn_right.png

ERROR: plugin[openfs] loading error: include/%SWFPATH%/guibilder/btn/btn_fs.png

ERROR: plugin[closefs] loading error: include/%SWFPATH%/guibilder/btn/btn_fs_close.png

ERROR: plugin[fcb] loading error: include/%SWFPATH%/guibilder/btn/faceb.png

ERROR: plugin[info] loading error: include/%SWFPATH%/guibilder/btn/btn_i.png


Wäre nett wenn mal ein Profi drüberschauen könnte :-)

Vielen Dank

Gruß Philipp

2

Monday, October 7th 2013, 3:52pm

Hi,

anhand der Fehlermeldungen stimmen die Pfade nicht.

Hast du einen Link zu dem Beispiel?
Funktioniert die Flash Version?

Da laut Log die HTML5 Version verwendet wird, stimmt eventuell die Pfadangabe in der HTML zu der SWF Datei nicht, sodass der HTML5 Viewer, mangels Kenntnis der SWF Datei, den SWFPATH nicht richtig auflösen kann.

Schöne Grüße,
Klaus

3

Sunday, November 10th 2013, 7:45pm

Hier der Link

Im Anhang die Ansicht über Android Handy.

Kann mir wer weiterhelfen ?? Bin mit meinem latain am Ende !!

Vielen Dank
Phiraili has attached the following image:
  • Screenshot_2013-11-10-19-33-25.jpg

4

Friday, November 15th 2013, 9:19am

Hi,

das Laden der Bilder sollte eigentlich funktionieren (eventuell versuchen den Browser Cache zu löschen).

Aber in der 'allpano.xml' hier:
http://www.panoimmo.de/test/include/allpano.xml

wird 'origin' für die Platzierung der Buttons verwendet!
Diese Einstellung wird aber seit der Version 1.0.7 nicht mehr unterstützt und wurde zu 'align' umbenannt.

Der Flash Viewer selbst unterstützt 'origin' zwar immer noch aus Kompatibilitätsgründen, aber da der HTML5 Viewer nach 1.0.7 entwickelt wurde, gab es dort nie eine Unterstützung dafür.

D.h. einfach alle 'origin' Einstellungen nach 'align' ändern/umbenennen.

Schöne Grüße,
Klaus

5

Sunday, December 22nd 2013, 4:12pm

Vielen Dank !! hat funktioniert !!