You are not logged in.

1

Tuesday, January 21st 2014, 3:00pm

Polygonaler Hotspot erscheint nicht

Vom lokalen Rechner aufgerufen, funktioniert der Hotspot, nicht aber im Web.

Wie kann ich den sichtbar machen?

Source code

1
2
3
4
5
6
<krpano version="1.17">		<include url="skin/defaultskin.xml" />		<view hlookat="0" vlookat="0" maxpixelzoom="1.0" fovmax="150" limitview="auto" />
	<preview url="Sonnenuntergang.tiles/preview.jpg" />
            <textstyle name="hotspottextstyle" font="Arial" fontsize="18" bold="true" italic="false" 			  textcolor="16775151" background="false" backgroundcolor="16777215" border="false" bordercolor="0" 			  alpha="1" blendmode="normal" effect="glow(0x000000,0.5,4,3);" 			  origin="cursor" edge="bottom" textalign="center" xoffset="0" yoffset="-3" noclip="true" showtime="0.1" fadetime="0.15" fadeintime="0.15" 			  />

  <hotspot name="hs3" keep="false" visible="true" enabled="true" handcursor="true" zorder="" style="style1" alpha="1.0" fillcolor="0xFFFFFF" fillcolorhover="0xFFFFFF" fillalpha="0.0" fillalphahover="0.1" borderwidth="0.0" borderwidthhover="4.0" bordercolor="0xFFFFFF" bordercolorhover="0xffff00" borderalpha="0.0" borderalphahover="0.8" onover="" onhover="showtext(www.szenerien.de,hotspottextstyle);" onout="" onclick="openurl(http://www.szenerien.de)" ondown="" onup="">		<point ath="-62.8" atv="-6.2"></point>		<point ath="-46.0" atv="-5.9"></point>		<point ath="-46.0" atv="3.4"></point>		<point ath="-62.8" atv="3.4"></point>      	</hotspot>           	<image>		<cube url="Sonnenuntergang.tiles/pano_%s.jpg" />		<mobile>			<cube url="Sonnenuntergang.tiles/mobile_%s.jpg" />		</mobile>	</image>
</krpano>


Um die Sonne herum ist ein polygonaler Hotspot angeordnet.

http://www.pano.szenerien.de/Polygonal-H…nuntergang.html




Grüße

Harald

2

Thursday, January 23rd 2014, 7:43am

Noch keine Lösung - bitte mal testen!

Bisher konnte ich die Ursache des Problems nicht herausfinden. Um zu einer PDF zu verlinken, verwende ich daher nun einen Bild-Hotspot.

Warum aber die selben Code-Teile in einem Projekt laufen und im neuen nicht, würde ich gern wissen.

Grüße

Harald

3

Thursday, January 23rd 2014, 9:01am

Hi,

Polygon-Hotspot werden aktuell immer noch nur in Flash unterstützt.
Sobald diese auch in HTML5 unterstützt werden, wird dies bei den News bekannt geben werden.

Hier ein Link mit html5=auto (um Flash zu bevorzugen) - damit ist der Hotspot sichtbar:
http://www.pano.szenerien.de/Polygonal-H…html?html5=auto

Schöne Grüße,
Klaus

4

Thursday, January 23rd 2014, 9:39am

Danke! Dann verlinke ich solange mit dem Zusatz ?html5=auto.


Grüße


Harald

5

Thursday, January 23rd 2014, 11:58am

Entweder das oder die html5 Einstellung in der HTML Datei ändern.

Weitere Informationen zur html5 Einstellung gibt es hier:
http://krpano.com/docu/html/#html5

Schöne Grüße,
Klaus