Sie sind nicht angemeldet.

1

Dienstag, 30. Oktober 2012, 15:10

How to use krpano iphone simulator?

My actions:
1) copied the iphone-ipad-simulator.html to the folder with my project
2) opened the iphone-ipad-simulator.html by Notepad++ (coding UTF-8 without BOM)
3) changed rows
...
<script src="../../swfkrpano.js"></script>
<script src="../../krpanoiphone.license.js"></script>
<script src="../../krpanoiphone.js"></script>
...
var viewer = createPanoViewer({swf:"../../krpano.swf", id:"krpanoSWFObject", html5:"always", html5licenseload:false});
viewer.addVariable("xml", "../../krpano.xml");
...


to


...
<script src="/swfobject/swfkrpano.js"></script>
<script src="/krpanoiphone.license.js"></script>
<script src="/krpanoiphone.js"></script>
...
var viewer = createPanoViewer({swf:"build.swf", id:"krpanoSWFObject", html5:"always", html5licenseload:false});
viewer.addVariable("xml", "build.xml");

4) Saved changes
5) I do launch iphone-ipad-simulator.html in browser and got the error: "Browser not supported"
Trying in IE, Crome and Mozilla...
What I`m doing wrong?!
With regards, Igor.

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »Ukrajinec« (30. Oktober 2012, 16:11)


2

Donnerstag, 31. Oktober 2013, 12:30

How to use krpano iphone simulator?

Don't suppose anyone found a solution to this? Currently grappling with the same problem.

Beiträge: 623

Wohnort: Sevastopol, Crimea, Russian Federation

Beruf: Interpreting, Building virtual tours

  • Nachricht senden

3

Donnerstag, 31. Oktober 2013, 16:32

I've just made a quick test and all works fine.

Step by step:

1) copy simulator to the folder
2) adjust license file
3) adjust paths to .swf and .xml
3) upload everything to a server (Chrome won't load locally);
4) open the resulting
"your_address_iphone-ipad-simulator.html" link in Chrome.

Opera doesn't support WebGL so it won't work in Opera.
Regards,

Alexey

4

Montag, 17. Februar 2014, 14:06

Anyone having problems with simulator & krpano-1.17.pr2

Hi,

I don't seem to be having much luck getting the simulator to work. I'm using krpano-1.17.pr2

As before I changed this part as I just have the one js file

Quellcode

1
2
	<!-- path to the krpano viewer files (when these files are merged into one .js file, then just include that one file) -->
	<script src="tour.js"></script>

and then changed this part as both are called 'tour'

Quellcode

1
2
3
4
					var viewer = createPanoViewer({swf:"tour.swf", id:"krpanoSWFObject", html5:"only"});
					viewer.addVariable("xml", "tour.xml");
					viewer.addVariable("simulatedevice", viewerdevice);
					viewer.embed("krpanoDIV")


but all I get is a black screen when I view iphone-ipad-simulator.html either online or via the KRPano testing server.

Tried all sorts but don't seem to have any luck.

I have a small iPod that I use for basic testing and that won't show the HTML5 version either.

Any help is appreciated.

Thanks,

Andrew

Beiträge: 623

Wohnort: Sevastopol, Crimea, Russian Federation

Beruf: Interpreting, Building virtual tours

  • Nachricht senden

5

Montag, 17. Februar 2014, 14:30

Hi! Check out this link, it works for me in chrome (Win XP):

http://vt.most-inform.com/ethno/iphone-ipad-simulator.html

Btw, what browser are you using?


I REMEMBERED ONE ISSUE: on this very PC I had to change its graphic card because previous one didn't support some stuff and simulator failed to work all the time. But it threw me an error at least that browser is not supporting Web GL or something.
Regards,

Alexey

6

Montag, 17. Februar 2014, 15:10

Hi Alexey,

Thanks for the quick reply. I checked your link in both Firefox V27.0.1 and Chrome
Version 32.0.1700.107 m and both work well. Windows 7. Excellent looking tour *thumbsup*

I checked your paths on iphone-ipad-simulator.html and I seem to be ok there. Went to check your tour.xml code but it's encrypted so no way to check that.

At least I know it works as you've just proved it so tomorrow will concentrate on looking at my xml code and see if it's messing things up. Just seemed a little odd as I use to have no problems with it at all before switching to krpano-1.17.pr2 but chances are it's just my code.

Thanks,

Andrew

Beiträge: 623

Wohnort: Sevastopol, Crimea, Russian Federation

Beruf: Interpreting, Building virtual tours

  • Nachricht senden

7

Montag, 17. Februar 2014, 15:18

Thanks)
Yep, I encrypted xmls not to show some of my tricks there)) ;-)


If the tour itself loads fine online, then there must be no connection with the paths inside xml. However, simulator uses html5 only so if the tour works fine in Chrome with Flash off and doesn't show at all in simulator, then there's something strange, of course.
Regards,

Alexey

8

Dienstag, 18. Februar 2014, 03:56

No problem. I understand the need to encrypt when you've spent so many hours on your xml code ;-)

I made some progress with my problem. Worked out all I had to do was remove <include url="swfaddress.xml"/> from the top area of my tour.xml and everything runs ok.

Well not exactly ok as the iPad simulator works but the image tile next to the one that's visible is always black until you rotate then that black tile becomes visible and the one next to that switched to black. I've attached a screen shot to this post.

I don't care though as I checked it online with my iPod and that displays ok (without the black tiles).

Not sure what to do about the swfaddress.xml as I really need it for this project. Will have to get in touch with the creator and see if something can be worked out.
»andrew22222« hat folgendes Bild angehängt:
  • screen.jpg

9

Dienstag, 18. Februar 2014, 20:46

Hi,
I don't care though as I checked it online with my iPod and that displays ok (without the black tiles).
These 'black tiles' in this case are a Desktop Chrome CSS3D bug.

When using the iPhone/iPad Layout simulator, the CSS3D rendering was used by default (instead of WebGL as normally) and Google has screwed up the CSS3D rendering in Chrome again. When using Chrome normally WebGL will be used, where this can't happen. Real devices and other browser will also not show that problem.

The krpano version 1.17 itself has already got a change to avoid this case - there the viewer will always use WebGL by default in Chrome, regardless if in the simulator mode or not.

Best regards,
Klaus