You are not logged in.

1

Monday, June 2nd 2014, 6:47pm

Why am I getting GLIBC error?

All,

I searched the forum and didn't find a direct answer.

Downloaded and unzipped TAR to server (CentOS 5.10, GLIBC 2.5) and have everything set to run like this:

<?php
exec("/home/mazdas5/public_html/krpano/krpano-1.17.2/krpanotools makepano -config=templates/vtour-multires.config ./panoimage.jpg");
?>

However, everytime I attempt to call I get:



/home/mazdas5/public_html/imageupload64/krpanotools:
/lib64/libc.so.6: version `GLIBC_2.14' not found (required by
/home/mazdas5/public_html/imageupload64/krpanotools)


/home/mazdas5/public_html/imageupload64/krpanotools:
/lib64/libc.so.6: version `GLIBC_2.7' not found (required by
/home/mazdas5/public_html/imageupload64/krpanotools)


/home/mazdas5/public_html/imageupload64/krpanotools:
/lib64/libc.so.6: version `GLIBC_2.11' not found (required by
/home/mazdas5/public_html/imageupload64/krpanotools)
I was under the impression that 2.15 or higher GLIBC, which the host I am using is, would be sufficient? *confused*

Thanks-
MT

2

Monday, June 2nd 2014, 6:57pm

I should say that I have downloaded the newest 1.17.3-linux64, but it has not resolved the GLIBC issues. Any ideas?

This post has been edited 1 times, last edit by "supertucker" (Jun 2nd 2014, 11:23pm)


3

Thursday, June 12th 2014, 9:05pm

Me too

Hi,

I'm having the same problem too

./krpanotools: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./krpanotools)


I am running a bang up to date version of Debian wheezy with I beleive the latest version of glib


ii libglib2.0-0:amd64 2.33.12+really2.32.4-5 amd64 GLib library of C routines
ii libglib2.0-data 2.33.12+really2.32.4-5 all Common files for GLib library

Does anyone have a suggestion?

Or have I done something dumb and can't see it.

Thanks

Tom

4

Saturday, June 14th 2014, 5:13pm

Hi,

GLIBC 2.5 is older than GLIBC 2.14 (5 < 14).

The krpano command line tools for Linux require at least a Linux system with GLIBC 2.14 and the krpano GUI tools at least GLIBC 2.15.

I'm already planing to make a special command-line-only build for GLIBC 2.11, but this will still take some time and has lower priority because a lot of code need to adjusted/rewritten to compilable there.

Best regards,
Klaus