You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, June 19th 2014, 4:43pm

Virtual Tour Editor

Hi, I seem to be having problems saving the lensflare in the VT Editor. Everything else works, ie Start up view and hotspots . I save the tour xml and overwrite the default version but any added Lenflare just disapears. Am I missing something out in the process?

NB I use the top menu to set the start up and hotspots but then I click on Editor Tab at the bottom to give me the lensflare addon. I have added the editor.swf plugin the give me this feature.

Any advice appreciated.

martyhr

Intermediate

Posts: 343

Location: CZ

  • Send private message

2

Thursday, June 19th 2014, 9:39pm

Link?
XML?

Alexey Tkachenko

Professional

Posts: 760

Location: Sevastopol, Crimea, Russian Federation

Occupation: Interpreting, Building virtual tours

  • Send private message

3

Sunday, June 22nd 2014, 7:51pm

Vtour editor and editor are two different plugins. So, it seems, that when we add a lensflare in Editor, only Editor itself "remembers" about the lensflare. Vtour Editor "has no idea" about changes you made in the Editor. After you added a lensflare, press "XML" tab in the bottom which will open a generated XML. Here, scroll down until you see the following line:

Source code

1
<plugin name="editor" url="plugins/editor.swf" keep="true" align="bottom" x="0" y="16" />


Below it, there will be the generated code for your lensflare(s). Copy it into your xml.

Yup, a bit tricky, the best way would be to add lensflares directly to the VToureditor with ability to save the xml directly. But that's may be a feature request for the VTour editor.
Regards,

Alexey

4

Monday, June 23rd 2014, 6:57pm

Thanks Alexey, thats just what I wanted to know. Just confirmed I am not going mad :)