You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, July 22nd 2014, 10:10pm

Fatal Error: License Error with KRPano on new Mac

I got KRPano 1.17.4 working on my Mac a few days ago, updating from a previous version. It all went smoothly; I pasted the code into the app and everything worked.

I just got a new Mac today (SSD, yay!) and I'm trying to set things up fresh. I installed KRPano 1.17.4 and set it up the same way – pasting the code into the app, which accepted it. (It shows my details correctly.)

However, when I drop an equirect onto the MAKE PANO (NORMAL) droplet and open the html file I get the Fatal Error: License Error message.

Any thoughts?

Keith

(I will delete everything from the old Mac, don't worry! Just not until the new one's set up. Then it goes to my wife, who has less than zero interest in panorama production. ;) )

2

Tuesday, July 22nd 2014, 10:34pm

I don't know if it's useful info, but when I copy the .js file from a pano built with my previous version of KRPano into one built with the new version it opens and displays without fuss.

*confused*

3

Tuesday, July 22nd 2014, 10:39pm

Correction: I copied the .js file from a pano made with 1.17.4 on my other Mac. Swapping that out from what 1.17.4 made on this new Mac made the pano work.

KRPano, strangeness and charm...

4

Tuesday, July 22nd 2014, 10:52pm

More info: when I add ?showlicenseinfo to the URL for a problem pano the result is blank below the "SHOWLICENSEINFO" line, but with a pano made on my other Mac it shows the user name and email address.

(And just as a reminder, the "krpano tools" application's Registration Information display shows the correct details.)

Keith

5

Wednesday, July 23rd 2014, 12:15am

Perhaps it's just a hiccup with the new installed files? I copies the 1.17.4 folder from my old Mac and built a pano using that – no problems at all. Weird. Oh well... *cool*

6

Thursday, July 24th 2014, 11:17am

Hi,

when you have got the 'Fatal Error: License Error' error message, then you have probably mixed krpano viewer files from different versions.

Best regards,
Klaus