You are not logged in.

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,111

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

1

Monday, November 3rd 2014, 10:45pm

Private encryption question

Hi,

I was wondering...
When i encrypt all xml privately.. And also set in the tools when i make the viewer js and swf private plugins etc..
It also wants me to encrypt the videoplayer plugin otherwise encryption error...
But not for the gyro..
Is it supposed to be like that?
And will the other plugins, i didn't use them in this case, needed to be encrypted as well?

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

jordi

Intermediate

Posts: 427

Location: Barcelona

Occupation: creating ideas & coding them

  • Send private message

2

Tuesday, November 4th 2014, 10:10am

videoplayer is already encrypted, but not the gyro one which is only compressed
everpano.com smart virtual tours

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,111

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

3

Tuesday, November 4th 2014, 10:21am

Why do i have to privatly encrypt the videoplayer plugin then when i use that for the project?
Otherwise i get encryption error.
Gyro not.
*question*
Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

4

Tuesday, November 4th 2014, 3:57pm

Hi,

when in the protect tool the option 'Allow loading only privately encrypted xml and plugin files' is checked, then ALL xml and plugins files would need to be encrypted with private encryption.

Plugin files that were (public-) encrypted would need to be privately-encrypted too - then the public encryption will be replaced by a private one.

About the gyro - this would apply for the gyro plugin too of course. Maybe there is a devices setting or something else involved that avoids that the gyro plugin gets loaded in your test case.

Best regards,
Klaus

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,111

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

5

Tuesday, November 4th 2014, 4:51pm

in this case http://www.virtualtuur.com/movinghotspots2/tour1/
i just encrypted the video player plugin..
the gyro seems not to need that to work.
path to gyro.js is:
http://www.virtualtuur.com/movinghotspot…plugins/gyro.js


Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

6

Tuesday, November 4th 2014, 8:13pm

Sorry - yes, you're right - this will be fixed in 1.18.1.

Best regards,
Klaus

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,111

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

7

Tuesday, November 4th 2014, 8:27pm

*thumbup*

Great!

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

Similar threads