You are not logged in.

HansNyb

Professional

  • "HansNyb" started this thread

Posts: 936

Location: Denmark

Occupation: Photographer

  • Send private message

1

Monday, December 22nd 2014, 11:04pm

Update IOS 8.1.2 problems

Just updated my iPad Air to IOS 8.1.2
When you use Homescreen bookmarks you get a white band at bottom and at top the texts from the system are at top and could even block menu clicks if you have a small text at top

This is really bad.


Hans

This post has been edited 2 times, last edit by "HansNyb" (Dec 23rd 2014, 12:33am)


2

Tuesday, December 23rd 2014, 8:45am

Hi,

that's an iOS bug of the 'homescreen browser' - e.g. see here:
http://stackoverflow.com/questions/25884…sizing-problems

To avoid the 'white band at bottom' add this code in the html - then it will be black and less visible (that's already there by default in the html templates of the current krpano versions):

Source code

1
<meta name="apple-mobile-web-app-status-bar-style" content="black">


As this is a core iOS bug, it's not possible to put any content in that bottom area, it would be only possible to reduce the pano height a bit and move it a bit down to make the top bar 'black again' - then it would look almost 'normally', but such workaround would be counterproductive and problematic when Apple will fix this.

Best regards,
Klaus

HansNyb

Professional

  • "HansNyb" started this thread

Posts: 936

Location: Denmark

Occupation: Photographer

  • Send private message

3

Friday, January 2nd 2015, 7:20pm

that's an iOS bug of the 'homescreen browser' - e.g. see here:
http://stackoverflow.com/questions/25884…sizing-problems


Unfortunatelly this is not the only bug.

Videos do not work at all any longer when using the Homescreen bookmark.

All my videos do not respond to click on Posterimage. Here is one example. Video on first pano and on pano 13 http://virtualdenmark.dk/dnm/kina/
Everything works OK when opening the tour from normal link in Safari.

I also now have a lot of crashes which I did not experienced before.When it crashes from a Homescreen link. It just crashes but from a normal link it automatically reloads with an information text at the top.

I get the same crashes now also using Site 2 Go. My last 2 Museum tours uses HTML text popups and that made the tours very stable with no crashes in 8.1.1.

I really hope they find a solution to this.