You are not logged in.


Tuesday, January 20th 2015, 6:05pm

Segmentation fault

Hi all,

I have this situation.

Folder krpano. In this folder I have the krpanotools and one image for testing the tools.

I launch this comand on server Linux (Debian GNU/Linux 6.0.10):

./krpanotools makepano -config=templates/vtour-normal.config R0010001.JPG
and display this message:

segmentation fault

any idea?

Many thanks,


Tuesday, January 20th 2015, 6:50pm


difficult to say... either that Linux system isn't compatible or there is some problem with the input file...

A crash (segmentation fault) is very uncommon.

Do the tools run when running them without any parameters?
Are other images working - or is the same image working on Windows or Mac?

Best regards,


Tuesday, January 20th 2015, 7:05pm

Hi Kalus,

thanks for reply.

If I launch only ./krpanotools makepano, displayed same error.
the same image run on Mac and on Ubuntu, I tried with another image, but same error



Wednesday, January 21st 2015, 12:31pm


when you get a crash just by this, then that Linux system isn't binary compatible.

Best regards,


Wednesday, January 21st 2015, 5:31pm

Hi Karl,

he tested in Debian and in Ubuntu and he make me a question regard a librairies hormis glibc.

He ask me in which Linux distribution krpanotools is tested.

This is the reply from the sys admin:

nos admin unix ont testé la commande donnée sous Debian 7.8 (Wheezy, ldd (Debian EGLIBC 2.13-38+deb7u6) 2.13) et Ubuntu 14.04 (ldd (Ubuntu EGLIBC 2.19-0ubuntu6.5) 2.19), et obtiennent un segmentation fault à chaque fois. Avec quelles distributions ça a été testé et approuvé?

Vous pouvez aussi essayer de lancer la version 32 bit pour voir ...

Est-ce que le développeur peut indiquer ce qu'il faut comme librairies hormis glibc ?

strace sur Debian 6 Squeeze :
execve("./krpanotools", ["./krpanotools", "makepano", "-config=templates/vtour-normal.c"..., "R0010001.JPG"], [/ 18 vars /]) = 0
brk(0) = 0xffc000
access("/etc/", F_OK) = -1 ENOENT (No such file or directory)
mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd558fd1000
access("/etc/", R_OK) = -1 ENOENT (No such file or directory)
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd558fd0000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd558fcf000
arch_prctl(ARCH_SET_FS, 0x7fd558fd06a0) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

Best regards,


Thursday, January 22nd 2015, 3:34pm


Hi Karl,

the sys admin say that segmentation fault comes by GLIBC 2.14.

This the output:
./ /lib/ version `GLIBC_2.14' not found (required by ./ => (0x00007fff175fe000) => /lib/ (0x00007f8662799000) => /lib/ (0x00007f8662437000)
/lib64/ (0x00007f8662b84000)

Is it really this the problem? The libraries GLIBC?

The sys ask the correct procedure to install GLIBC.

Can you help me?



Monday, January 26th 2015, 2:21pm


the krpanotools itself requiring only GLIBC 2.4 or higher.
Only the GUI (which your output above is from) requires at least GLIBC 2.14.

Best regards,