You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, February 25th 2015, 10:14am

Set Cube URLs from an action creates error No device compatible image available…

With the flash viewer this code works fine

set(image.level[0].tiledimagewidth, 956);
set(image.level[0].tiledimageheight, 956);
set(image.level[0].front.url, panos/View_1.tiles/f/l1/%v/l1_f_%v_%h.jpg);
set(image.level[0].right.url, panos/View_1.tiles/r/l1/%v/l1_r_%v_%h.jpg);
….
….

but the HTML5 viewer returns the error - No device compatible image available…

Is there a problem in HTML 5 with setting image URLs from an action?

This post has been edited 2 times, last edit by "nicoclark" (Feb 26th 2015, 10:20am)


2

Thursday, February 26th 2015, 2:58pm

I've had to find a workaround for this problem using the text add command

e.g.

txtadd(scene[%1].content, get(scene[%1].content),
'<image type="CUBE" multires="true" tilesize="512">
<level tiledimagewidth="1910" tiledimageheight="1910">
<left url="panos/View_%2.tiles/%s/l2/%v/l2_l_0%v0%h.jpg" />
<front url="panos/View_%2.tiles/%s/l2/%v/l2_f_0%v0%h.jpg" />'
);


it's a shame that the code that's useable for Flash is now not working with HTML5.

3

Thursday, February 26th 2015, 5:33pm

Hi,

no, it's not shame, it was never been indented that changing <image> settings dynamically would work.

Best regards,
Klaus