You are not logged in.

1

Thursday, April 17th 2014, 9:45am

krpanotools on ARM processor

Hi,
I would like to use krpanotools on ARM processor.

Concretely, I want to use krpanotools on Raspberry PI.


Does anyone know how to do this?

Thanks,
Nikaera

2

Friday, April 18th 2014, 1:27pm

Sorry, but there is no ARM version of the krpano tools.

Best regards,
Klaus

3

Saturday, April 19th 2014, 6:49am

> Sorry, but there is no ARM version of the krpano tools.
OK I see.

I discovered one method to use krpanotools on ARM.
(But only 1.0.6.x or lower version..)

For the person who wants to use krpanotools on ARM, here is the method.

  1. Install qemu(CPU Emurator)
    -> http://askubuntu.com/questions/138140/how-do-i-install-qemu

  2. Confirm whether qemu-i386 command is usable.

  3. Download toolchain for i386
    -> http://diablo.elis.ugent.be/download

  4. Unzip Toolchain files somewhere.
    (ex. tar xjvf toolchain-i386-glibc.tar.bz2 -C /home/nikaera/toolchain-i386)

  5. Make a path to toolchain at LD_LIBRARY_PATH.
    (ex. export LD_LIBRARY_PATH="/home/nikaera/toolchain-i386")

  6. Download krpanotools version 1.0.6.x or lower._
    -> http://krpano.com/download/archive/

  7. Unzip Krpanotools files somewhere.
    (ex. tar zxvf krpanotools-1.0.6.1-linux.tar.gz -C /home/nikaera)

  8. Change directory to the folder where krpanotools is unzipped.
    (ex. cd /home/nikaera/krpanotools)

  9. Input command as following.
    -> qemu-i386 ktransform

  10. If a ktransform help is displayed, succeed!!

4

Monday, January 12th 2015, 1:39pm

Thank you for your workaround.

Is there any update regarding this matter? I would like to run krpanotools on a ARM based device as well...

5

Thursday, February 26th 2015, 12:04pm

Krpano Version 1.0.6.x

Hello,

I am trying to run the tool on ARM processor...
Unfortunately I cannot find Krpano Version 1.0.6.x in the KRPano archive or other places in Internet. The oldest version available is 1.0.8.15? Does anyone know where I can find Krpano Version 1.0.6.x?


Thank you.

6

Thursday, February 26th 2015, 5:38pm

Why should only 1.0.6 work?
This version is extremely old!

Happens happens when trying an actual version?

Best regards,
Klaus

7

Monday, March 2nd 2015, 5:10pm

Hello there,

I have just tried to run krpanotools (1.17 version) with qemu-i386, this is the error I am getting:


qemu-i386 ./krpanotools makepano -config=templates/vtour-normal.config /tests/testPano.jpg
Error -13 while loading ./krpanotools


Nikaera suggests to use 1.0.6.x or lower version, is it possible to have a copy, to try it out?


Thanks.

8

Monday, March 2nd 2015, 5:29pm

Hi,

which 1.17 version?
In version 1.17.5 the minimum required GLIBC version was reduced from 2.14 to 2.4 (and why even a 1.17 version and not the latest 1.18 version?)

About the error itself:
- are you trying to run the 32bit or the 64bit version?
- are the executable rights set correctly?

Best regards,
Klaus

9

Tuesday, March 3rd 2015, 11:20am

Hello,

which 1.17 version?
I tried with Version 1.17.6 (build 2014-10-17), available at http://krpano.com/download/archive/.


why even a 1.17 version and not the latest 1.18 version?
Because I tried 1.18 version in Ubuntu 12.04 32bit, and I get a scripting error when I try to use any of the executables (a "(" paranthesis missing) - I didn't dig too much in the issue because I knwe that with 1.17.6 the error does not occur.
are you trying to run the 32bit or the 64bit version?
32 bit.
are the executable rights set correctly?
Yes, they are.

For now I can load the panorama only by specifying "sphere" in the xml file and therefore using flash (html5:auto). As I prefer to use HTML5, is it possible to have the old copy mentioned at the beginning, just so that I can try it out and convert the panorama into tiles (cube format)?

Thanks.

This post has been edited 1 times, last edit by "daytan" (Mar 3rd 2015, 3:44pm)


10

Tuesday, March 3rd 2015, 12:06pm

Errata corrige:

I have just tried again with qemu-i386 and krpanotools In version 1.17.5 32bit for Linux, this is the error I am getting:

qemu-i386 ./krpanotools makepano -config=templates/vtour-normal.config /tests/testPano.jpg
/lib/ld-linux.so.2: No such file or directory


if I type:

uname -a:
SMP PREEMPT Thu Jan 2 22:10:03 CST 2014 armv7l armv7l armv7l GNU/Linux

This post has been edited 1 times, last edit by "daytan" (Mar 3rd 2015, 1:38pm)


11

Wednesday, March 4th 2015, 10:33am

Hi,
Because I tried 1.18 version in Ubuntu 12.04 32bit, and I get a scripting error when I try to use any of the executables
What kind of 'scripting error'?
The 1.17 and 1.18 versions were build the same way.


As I prefer to use HTML5, is it possible to have the old copy mentioned at the beginning, just so that I can try it out and convert the panorama into tiles (cube format)?
No sorry, the old versions are not available anymore for license reasons - and especially the sphere to cube conversion was bad in the old versions (not fully correct aligned cube edges).


qemu-i386 ./krpanotools makepano -config=templates/vtour-normal.config /tests/testPano.jpg
/lib/ld-linux.so.2: No such file or directory
http://unix.stackexchange.com/questions/…-armel-via-qemu

Best regards,
Klaus

12

Wednesday, March 4th 2015, 2:21pm

'Thank you for your help Klaus., it is very much appreciated.

I will test the Optware package solution, hoping in the meantime that krpanotools will be one day compatible with ARM platforms :)

13

Thursday, March 5th 2015, 12:06pm

..

Hi,

I tried the solution above, unfortunately the package provided by Optware is for armel architectures and does not work on armhf, which is the one I need to use.

What I need to do in order to run the application is just to be able to display the sphere on the browser, but using html5 and a armhf OS. Does anyone any alternative suggestion?

Thanks in advance.

14

Thursday, March 5th 2015, 8:01pm

When your device is supporting WebGL and the sphere image isn't very large, you could use the image directly in the krpano HTML5 viewer.

15

Thursday, March 5th 2015, 10:43pm

The browser runs on Windows and so I thought of that. I set html5 to "html5=prefer+webgl", but I still see a black image instead of the image. Am I doing something wrong?

Thanks.

16

Monday, March 9th 2015, 10:25am

Am I doing something wrong?
That's impossible to answer without example!

17

Tuesday, March 10th 2015, 5:04pm

I did not specify an example because I hoped that a black image would have been an issue common enough to be indicative of the problem.

Please find an example below.

Windows 8 64bit - Firefox v36.0.1

tour.html

Source code

1
2
3
4
<!DOCTYPE html><html><head>	<title>krpano.com - test_sphere</title>	<meta name="viewport" content="target-densitydpi=device-dpi, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, minimal-ui" />	<meta name="apple-mobile-web-app-capable" content="yes" />	<meta http-equiv="Content-Type" content="text/html;charset=utf-8" />	<meta http-equiv="x-ua-compatible" content="IE=edge" />	<style>		@-ms-viewport { width:device-width; }		@media only screen and (min-device-width:800px) { html { overflow:hidden; } }		html { height:100%; }		body { height:100%; overflow:hidden; margin:0; padding:0; font-family:Arial, Helvetica, sans-serif; font-size:16px; color:#FFFFFF; background-color:#000000; }	</style></head><body>
<script src="tour.js"></script>
<div id="pano" style="width:100%;height:100%;">	<noscript><table style="width:100%;height:100%;"><tr style="valign:middle;"><td><div style="text-align:center;">ERROR:<br/><br/>Javascript not activated<br/><br/></div></td></tr></table></noscript>	<script>		embedpano({swf:"tour.swf", xml:"tour.xml", target:"pano", html5:"prefer", passQueryParameters:true});	</script></div>
</body></html>



tour.xml

Source code

1
2
3
4
5
6
7
8
<krpano version="1.17.4" title="Virtual Tour" onstart="startup();">
	<include url="skin/vtourskin.xml" />
	<!-- set skin settings: bingmaps? gyro? thumbnail controlling? tooltips? -->	<skin_settings bingmaps="false"	               bingmaps_key=""	               bingmaps_zoombuttons="false"	               gyro="true"	               thumbs_width="120" thumbs_height="80" thumbs_padding="10" thumbs_crop="0|40|240|160"	               thumbs_opened="false"	               thumbs_text="false"	               thumbs_dragging="true"	               thumbs_onhoverscrolling="false"	               thumbs_scrollbuttons="false"	               thumbs_scrollindicator="false"	               thumbs_loop="false"	               tooltips_thumbs="false"	               tooltips_hotspots="false"	               tooltips_mapspots="false"	               controlbar_offset="20"	               />
	<!-- set optional skin logo url -->	<layer name="skin_logo" url="" scale="0.25" opened_onclick="openurl('...',_blank);" />

	<action name="startup">		if(startscene === null, copy(startscene,scene[0].name));		loadscene(get(startscene), null, MERGE);	</action>
		<scene name="scene_test_cube" title="test_cube" onstart="" thumburl="panos/test_cube.tiles/thumb.jpg" lat="" lng="" heading="">		<view hlookat="0" vlookat="0" fovtype="MFOV" fov="120" maxpixelzoom="2.0" fovmin="70" fovmax="140" limitview="auto" />		<preview url="panos/test_cube.tiles/preview.jpg" />		<image>			<cube url="panos/test_cube.tiles/pano_%s.jpg" />			<mobile>				<cube url="panos/test_cube.tiles/mobile_%s.jpg" />			</mobile>		</image>		<!-- place your scene hotspots here -->	</scene>		<scene name="scene_test_sphere" title="test_sphere" onstart="" thumburl="panos/test_sphere/thumb.jpg" lat="" lng="" heading="">				<preview url="panos/test_sphere/preview.jpg" />		<image>			<sphere url="panos/test_sphere/test_sphere.jpg" />		</image>	</scene>
</krpano>



By typing "tour.html?html5=prefer+webgl", so that flash is not used, the first scene (the one that uses tiles) it is loaded fine. When loading the second scene I see only a black image with "loading". I attach a screenshot for clarity purposes.

test_sphere.jpg is a equirectangul panorama image with size 850x425 (I tried several sizes).

Hopefully can help others too.

Thanks.
daytan has attached the following image:
  • screenshot.jpg

18

Wednesday, March 11th 2015, 10:39am

The problem occurred with KrPano version 1.17.4 for Windows.
I double-checked by downloading and trying with version 1.17.6 and the problem still occurred.


I used then the latest version of KrPano 1.18.3 and the issue was solved under the same conditions.



19

Wednesday, March 11th 2015, 10:46am

The 1.17 version wasn't supporting spherical panos in HTML5!

Check the news and release-notes:
http://krpano.com/news/#news118