You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

VN2011

Professional

  • "VN2011" started this thread

Posts: 1,336

Location: Duluth MN

  • Send private message

1

Thursday, March 12th 2015, 9:30pm

MP4 plays locally but not online

i cannot get an MP4 to play online at all. Always states unable to open file. I even tried the cats-short.mp4 from the krpano examples and it also will not play when uploaded online. FLV and WEBM plays ok so I know it is not a file path issue. All videoplayer plugins and video files are sitting in the same root folder as the swf.

<hotspot name="spot7" url="skin/play.png" scale="0.45" alpha="0.75" ath="4.967" atv="-7.497" onclick="set(hotspot[spot7].visible, false); hotspot[videospot].playvideo(second.flv); looktohotspot(videospot);" />

<hotspot name="spot5" style="skin_hotspotstyle2" ath="-27.129" atv="18.459" onclick="set(hotspot[spot7].visible, false); hotspot[videospot].playvideo(cats.mp4); looktohotspot(videospot);" />
<hotspot name="spot6" style="skin_hotspotstyle2" ath="28.273" atv="19.289" onclick="set(hotspot[spot7].visible, false); hotspot[videospot].playvideo(km_full.mp4); looktohotspot(videospot);"/>

The first line works the second and third do not. If I change cats.mp4 to second.flv the video plays. km_full.mp4 is the actual file i need to work and play, maybe someone could test this file to see if it work online for them? I am just getting back into the pano game after taking a few years off. This is only a rough demo there are stitching and other issues but i don't want to worry about all that until it is technically sound and working.

www.virtualnorthland.com/hentges

please help if you can, the racing team wanted to post this by the weekend :(

benji33

Intermediate

Posts: 244

Location: France

Occupation: Senior Software engineer

  • Send private message

2

Friday, March 13th 2015, 9:04am

I've a 404 (file not found) error on http://www.virtualnorthland.com/hentges/cats.mp4

VN2011

Professional

  • "VN2011" started this thread

Posts: 1,336

Location: Duluth MN

  • Send private message

3

Wednesday, March 18th 2015, 2:34pm

thanks for checking the mp4 in the web browser i forgot to do that. it was in the right place so at least the 404 told me there was something wrong with the server not the files. i had not added the .mp4 MIME type. Once I added that the files played ok.