You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

jordi

Intermediate

Posts: 484

Location: Barcelona

Occupation: creating ideas & coding them

  • Send private message

201

Friday, May 1st 2015, 6:47pm

every view parameter is ignored, hlookat & vlookat are defined by the gyro sensor, fov is defined from de HMD, and no limits horitzontal or vertical...

hlookat & vlookat, with a tricky prealign can be reset, that would also make you move all your hotspots.

And I think when we are out of pre version, vertical or horitzontal limits will be allowed
everpano.com step beyond 360

Ibrendie

Trainee

Posts: 68

Location: The Netherlands

  • Send private message

202

Friday, May 1st 2015, 7:02pm

Thanks for the explanation Jordi. I hope it will be possible to limit the vertical fov. It's a really simple way to hide the nadir spot.

jordi

Intermediate

Posts: 484

Location: Barcelona

Occupation: creating ideas & coding them

  • Send private message

203

Friday, May 1st 2015, 7:07pm

Yes I also wish to have all the features *cool* , but with what we already have we can do so much !!
If you would really need that feature, you could go back to the old method, with to players syncronized, there you could do everything, limit vertical & horitzontal view, fov, hlookat, textfield layers, ...
But I guess that nowadays is not a good time investment to work with the old method, so I prefer to take the huge advantatges of working with the 1.19 with the obious limits of a pre version
everpano.com step beyond 360

Ibrendie

Trainee

Posts: 68

Location: The Netherlands

  • Send private message

204

Friday, May 1st 2015, 7:19pm

I definitely agree. I think Klaus is way ahead with krpano compared to all other pano viewers. I will just wait for this feature in the final 1.19 release (if it will be available). In the meantime I can cover the Nadir with a nadir logo.

I just started with stereo panoramas, and the most difficult part is the nadir ;-) .

205

Friday, May 8th 2015, 10:51am

Awesome Panofeature!

Hi just saw the upcoming stereoscopic feature - awesome.

I don't have used krPano before, so sorry for maybe some stupid questions - but i'm asking myself how did you make the "main menu" ( start pano falling down and the menu sliding upwards ? ). Was a development framework used or "just" hardcode xml ?

P.S.
Is there any release date planed or in sight ?

This post has been edited 2 times, last edit by "suppenhuhn" (May 8th 2015, 11:20am)


206

Friday, May 8th 2015, 12:37pm

Hi,
how did you make the "main menu" ( start pano falling down and the menu sliding upwards ? ). Was a development framework used or "just" hardcode xml ?
That's normal krpano xml code. The 'falling down' is a simply tweening of the hotspot positions. The example is included in the download package. Have a look into the krpano_vr.xml.

Best regards,
Klaus

207

Friday, May 8th 2015, 4:37pm

DK2 not working

Hi,

I tried the VR example with Oculus DK2 but there's no headtracking. I'm not even sure if the Oculus is detected at all. Also tried some other VR tours that users posted in this thread, but with no luck!

I spend a day trying to get it to work. Updated the Oculus SDK, updated my videocard driver, tried both Nightly and Chromium, set the Oculus display mode to "Direct Access" and "Extend desktop", clear cache and use incognito browsing.. and tried lots of other things.

The stupid thing is that webVR seems to work fine. All example projects on mozvr.com work perfect! I'm kind of out of ideas what might be causing the problem. Does anyone have some more ideas that i can try out, or thing I need to check that i might have been missing all the time? (btw I saw today the 1.19 pre-release 2 is out, tested that example too)

Best regards,
Bouke

208

Friday, May 8th 2015, 9:36pm

Hi,

the WebVR API specs were updated and therefore the old examples weren't work anymore in the latest WebVR browser builds. But the new 1.19 Pre-Release 2 should work.

Also note - the WebVR API need to be enabled manually first in the latest browser builds - in Chromium via 'chrome://flags' and in Firefox Nightly via 'about:config'.

On browser side I would recommend the Chromium WebVR build on Windows with Direct Mode because this one supports 75hz rendering.

Best regards,
Klaus

gabriel

Beginner

Posts: 24

Location: Paris, France

Occupation: photographer

  • Send private message

209

Friday, May 22nd 2015, 4:47am

Show a image instead of changing pano

Hi Everybody,
i recently make a tour for handicapped people when they are visiting a museum ( there is a little stair, people with wheelchair cannot enter in this piece ).
So, i would like that the hotspots on the tour showing a image instead of going to a other piece ( there is only one piece where they cannot go, and only one pano in my tour )
the virtual tour is here : http://www.gabrielacoca.fr/musee-bourdelle/index.html , you can see there several hotspot, showing additional information.
here is the VR version of this tour : http://www.gabrielacoca.fr/musee-bourdel…oard/index.html
i try to do the same in the VR, i change several things in the "tour.xml" and the "mobilevr.xml", here is my code (unfunctionnal):
tour.xml:

Source code

1
2
3
<krpano>
	<scene name="bourdelle">		<view hlookat="0" vlookat="0" />		<image>			<cube url="panos/bourdelle/%$cubesideprefix%_pano_%s.jpg" />		</image>	</scene>     <hotspot name="spotsevastos"    		   keep="true"	  	   zorder="10"	  	   ath="-51.0" atv="9.831959"	  	   visible="true"           distorded="true"           height="150"           width="150"           url="icon.png"           handcursor="false"           onclick="do_hotspot_sevastos_onclick"           />           	<action name="do_hotspot_sevastos_onclick">	tween(layer[sevastos].visible,true,);	</action> 	  <layer name="sevastos"           keep="true"           align="center"           url="sevastos.jpg"           width="444"           height="500"           handcursor="false"           alpha="1"           visible="false"           />
</krpano>



and mobilevr.xml:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
<krpano onstart="loadscene(0, null, MERGE);">
	<!-- no default krpano fullscreen -->	<contextmenu touch="false" fullscreen="false" />
	<!-- set the default fov settings (might need to be adjusted for the particular VR adapter) -->	<view fovtype="DFOV" fov="90" fovmin="30" fovmax="150" view.vlookatmin="-70" view.vlookatmax="90" />
	<!-- events for sync viewing control -->	<events name="vrcontrol" keep="true"	        onxmlcomplete="if(side == left, loadgyro() );"	        onviewchange="if(plugin[gyro].available, js(sync_1to2()) , if(syncother, if(side == left, js(sync_1to2()) , js(sync_2to1()) ); ) );"	        onmousedown="set(syncother,true); events[vrcontrol].onviewchange();"	        onmousewheel="events[vrcontrol].onmousedown();"	        />
	<action name="loadgyro">		addplugin(gyro);		set(plugin[gyro].onavailable, js(sync_set(control.usercontrol,off)) );		set(plugin[gyro].url, 'gyro.js');	</action>
	<action name="js_sync_call">		js( sync_call(%1(%2,%3)) );	</action>
	<action name="do_hotspot_sevastos_onclick">		tween(layer[sevastos].visible,true,);	</action> 

	<!-- zoom the hotspots when looking at them and after 2 seconds load the linked scene -->	<events name="testshotspots" keep="true"	        onviewchanged="testhotspots();"	        />
	<action name="testhotspots">		for(set(i,0), i LT hotspot.count, inc(i),			getlooktodistance(d, hotspot[get(i)].ath, hotspot[get(i)].atv);			if(d LT 7,				hotspot_in_focus(get(i), get(hotspot[get(i)].tween(layer[sevastos].visible,true,);));			  ,				hotspot_out_of_focus(get(i), 0.5, 0.5);			  );		  );	</action>
	<action name="hotspot_in_focus">	    if(hotspot[%1].infocus != true,	        set(hotspot[%1].infocus, true);	        tween(hotspot[%1].scale, 1.0, 2.0, default),	        tween(layer[sevastos].visible,true);	</action>
	<action name="hotspot_out_of_focus">	    set(hotspot[%1].infocus, false);	    tween(hotspot[%1].scale, 0.5, 0.5);	</action>
	<!-- include the panos -->	<include url="tour.xml" />
</krpano>



What i want to do is that the hotspot open the image :
- for 10 second,and then close.
or
- trig a action to close the hotspot (move the head for example)

I f someone can tell me where did i go wrong or have an example of code who work, it will be helpful.

Thanks a lot and have a nice day.

Gabriel.

Red

Trainee

Posts: 98

Location: Australia

Occupation: Virtual tour creator, VR app developer

  • Send private message

210

Friday, May 22nd 2015, 6:37am

Gabriel,

In your tour.xml code, for the hotspot, it shows distorded="true" while it should be distorted="true"


That may get your hotspots showing in VR.
However, it looks like you're also trying to tween an image layer. As far as I know, layers are still unsupported in VR mode and only distorted hotspots can be displayed.
So you could convert your layer images to distorted hotspots and that may do the trick.

Congrats on the stereo pano. Looks great. Goes a bit loopy when looking at the zenith/nadir though.

Cheers
Red

gabriel

Beginner

Posts: 24

Location: Paris, France

Occupation: photographer

  • Send private message

211

Friday, May 22nd 2015, 4:23pm

Hi Red

Thank for your reply ... arg "d" instead of "t" ... il always been a "0" in orthography *cry* ... anyway, it doesn't work.
During testing, i can show the image describe as a layer, and distorted="false" on my iPhone, online.

Cheers.

Gabriel.

Tourvista

Intermediate

Posts: 258

Location: Leicester UK

  • Send private message

212

Wednesday, May 27th 2015, 12:59pm

Quick question about a problem that I'm having in one of my tours.

I have a hotspot, and at some point I need to change the image for a different one. This is something I have done hundreds of times, and it works perfectly OK when I'm not in VR mode.
But if I'm in VR mode, the image doesn't change. Tracing the URL parameter I can see the the new image is in the path, but not in the screen.
Even more. If I exit VR mode, the the new image appears.

Am I doing anything wrong?

Is this something to do with the setting 'continuousupdates'? Just guessing.

Source code

1
<view continuousupdates="true" devices="html5" />


Thanks!

213

Wednesday, May 27th 2015, 3:25pm

Hi,
Am I doing anything wrong?
Sorry, no idea, please use the pre-release-2, make an example and post it in a separate thread for testing/analyzing.

Best regards,
Klaus

214

Wednesday, May 27th 2015, 4:18pm

Vertical axis for the Oculus ?

Hello,

I'm trying the last prerelease with the Oculus and WebVR plugin. Once the Oculus is connected and configured, I start the WebVR example from krpano. If the panorama displays, it doesn't move at all. It seems the positional tracker isn't lit, the blue led is OFF although on the Toscana Unity demo, it is ON.
Did I miss something?

This post has been edited 2 times, last edit by "gbv30120" (May 27th 2015, 4:39pm)


215

Wednesday, May 27th 2015, 4:38pm

Did you use a WebVR capable browser and manually enabled the WebVR API there?

216

Wednesday, May 27th 2015, 4:40pm

I use the Firefox Nightly and clicked in the krpano WebVR demo the startVR, yes. But as I said, it seems the positional tracker isn't activated...

217

Wednesday, May 27th 2015, 4:48pm

The 'dom.vr.enabled' setting (via about:config) is enabled in Firefox Nightly?

Btw - I would recommend using the Chromium WebVR build (on Windows) - it performs way better, just like native Oculus Rift apps. As note - in Chromium the WebVR API need to be enabled via 'chrome://flags/#enable-webvr'.

218

Wednesday, May 27th 2015, 4:51pm

unfortunately, the dom.vr.enabled is set to 'true'

I already tried Chromium but as I'm on Mac Os, It didn't work well.

219

Wednesday, May 27th 2015, 4:58pm

Do other WebVR pages work for you?
When the browser is working correctly, then krpano should work automatically too.

About Chromium - what means 'didn't work well' in your case?

I would really recommend trying VR on Windows, it's way better (assumed that the GPU is capable enough).

220

Wednesday, May 27th 2015, 5:02pm

Nope, the WebVr pages don't work at all.
I currently only have the krpano VR examples and some I did from my side.
Otherwise, the oculus examples work well, that's how I've noticed the blue led is ON.

The problem I had with Chromium is that it can't load the XML. I'm looking how to bypass this error, using the Testing server tool. But, maybe because I'm working on a Mac, even the Testing Server doesn't work from my side. My webpage returns an error, unreachableā€¦

I think I'll do new tests on a Windows computer

Similar threads